1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Nv4_disp issue with GeForce 8600 GT

By Tiro3 ยท 9 replies
Jul 28, 2009
  1. Hey!

    Today, I experienced an issue with what seems to be my GPU's drivers.

    It occured out of the blue, with no manual software or hardware changes or updates.
    I suppose automatic software updates could have occured though.

    Whenever I launch a graphics-intensive game, I get about a half a minute of game time,
    before it gets messed up. I get wierd textures superimposed all over the screen, either
    arbitrary mess like in the attached screenshot, or partly transparent textures from a
    completely different part of the game. In the background though, the game will run normally, so any movements still occur and I hear the sound effects.

    Mostly I must exit the game with the Task Manager, but sometimes I get an error message.

    It says the graphic card drivers are not responding, and that my nv4_disp screen driver is
    not functioning properly.

    It seems I can run DVDs just fine, browse the net, or do pretty much anything else without
    any issues. It also seems that the temperature in the GPU is about normal, even when playing.

    I tried to uninstall the drivers, clean the disk with Driver Sweeper, and then re-install
    the latest drivers with Anti-Virus disabled, but I get the same result.

    Any suggestions as to what is wrong? Any help is greatly appreciated!

    My system:

    - Windows XP Pro 32 Bit
    - AMD Athlon 64 4000+
    - AGP PCI IMB USB i2c/SMBus MoBo
    - NVIDIA GeForce 8600 GT
    - 2 GB Memory

    Attached Files:

    • F3.jpg
      File size:
      242.9 KB
  2. fimbles

    fimbles TS Evangelist Posts: 1,171   +203

  3. Tiro3

    Tiro3 TS Rookie Topic Starter


    Thanks for helping me out here! :)

    However, this solution involves only reinstalling the latest drivers in safety mode, something I have already tried, to no luck.
    Also, I never saw any BSODs or actual 'freezes' per se, as the game itself kept running.
    It also seems as this information is rather old, I would expect what caused an error in 2006 to be fixed in NVIDIA's new drivers.

    Could it rather be related to an issue with their newest driver, 190.38?
    Or could this be the signs of a hardware fault?
    If so, how could I confirm that this in fact is the case?

  4. snowchick7669

    snowchick7669 TS Maniac Posts: 660

    You can test your graphics card using this tool here

    The driver you are using, is it Beta? If so then I would download the one before it, if not then it may not be a problem.

    If that program runs fine then you may want to upload your latest minidumps so we can debug them.

    Let us know how you get on
  5. TBolt

    TBolt TS Rookie Posts: 65

    This is actually a fairly common and somewhat old issue with nVidia drivers. My understanding is nVidia has not come up with a concrete solution (especially as it relates to Xp OS'es) due to so many indirect causes. I believe the root of this issue is related to memory and how it is handled between the OS and the GPU RAM, but indirectly can be caused by almost anything. However, starting with the GPU is a good jumping off point. As snowchick indicated, check your GPU memory as well as system memory for stability. You can use Memtest for system memory. Some other things to consider checking:
    -Power supply, is it falling off or not high enough on the wattage and/or +12v rail side?
    -Heat, is your card or CPU getting too hot?
    -Incompatibility, have you installed any new software/hardware?
    -Instability, have you recently overclocked any components?

    Some random ideas to check or try:
    -Reseat your system memory and video card
    -Unplug peripherals one at a time and play a game
    -Sound drivers up to date?
    -USB drivers up to date?
    -Anything (even the most obscure) out of the ordinary happen to your PC lately? The reason I include this is last year I was plagued with this "error". I racked my brain for several days going through one thing after another trying to pin it down. Finally, I was able to get a minidump which pointed to a USB port. I then looked behind my PC (which sits underneath my desk) and noticed one of my plugs was somewhat sandwiched between the back of my desk and the port (my PC must have been bumped a bit until it got too close to the back of the desk). Although the USB device was working fine, the plug was not sitting perfectly square in the port. I removed the plug, put it into a different USB port...problem solved. Now, anytime I plug anything into that port, the error returns indicating some kind of damage to that port. Yeah, pretty random...pretty stooopid and yet somehow related to that driver error :S Unfortunately, indicates that indeed this problem can be caused by almost anything.

    Anyway, take it one thing at a time...might be a simple thing, might be impending hardware failure. Start with the no to low cost solutions first. If you google that error you'll see page after page of this problem going back several years (also indicating several different indirect causes and solutions to try). Good luck and let us know how it turns out.
  6. Tiro3

    Tiro3 TS Rookie Topic Starter


    I am currently running the tool snowchick gave me, and it's not looking good!
    It takes a long time to finish, so I won't have a log file until later, but I get lots and lots of faults in the interleaving test so far. It says the value should be 00FF but that it finds 0000.
    Anyways I'll post the log file when it's done...

    This might be an indicator of hardware malfunction then I guess? :/

    The drivers I'm using are not beta, they are the latest stable versions.

    Also, when I get home tonight, I will check the solutions TBolt posted!

    Thanks so much for the great help!


    It seems it will take a very long time to complete a scan due to the high amount of errors found, even on the smallest scan version.
    I will try to leave it on over the night to see if I can complete it then.
    Does it save any log files from the aborted scans?
    If so, where can I find them then, couldn't find any log files in the app's dir...

    The errors are all on the form, while the letters and digits vary:

    Error at [0F97A14]: must be 00FF, but found 0000 (bits: 00001111)

    It finds literally millions of errors!


    Well, it seems there are too many errors for me to complete a scan, so I I can't get a log file.
    Anyone have a clue what this means though?
  7. TBolt

    TBolt TS Rookie Posts: 65

    Hmmm...unfortunately Tiro, it sounds like if your memory is erroring so much that a scan can't/won't complete, you may have found your problem which may be hardware failure or impending failure.

    You could try downclocking the card some (especially the GPU memory) to see if it improves, but obviously your gaming may suffer a bit more in both fps and quality (you may have to turn game settings down a bit to compensate). Downclocking the card (if this works) is not necessarily a "fix" but more over a "statement" basically saying your card is no longer capable (for whatever reason) at performing at it's stock speeds.

    To downclock your video card, you can try EVGA Precision tool which will work for any nVidia/GeForce based card. Check it out here.


    Do you have access to another computer the card will fit in and test functionality through?
  8. Tiro3

    Tiro3 TS Rookie Topic Starter


    Thanks for the reply and the suggestions. :)

    Bad news: Yesterday I had to power down my computer (for the first time since the errors), due to a thunder storm.
    Now when I attempt to start it up, it powers up for about 1 or 2 secs, before it turns off automatically. So I can't even start my computer!

    At any rate, next week I am going to replace my GPU and see what effect that has.
    Hopefully, it will work normally then!

    I'll keep you updated! :p
  9. Tiro3

    Tiro3 TS Rookie Topic Starter

    It wasn't the GPU after all, but a few of the condensers on my mobo were fried.
    I replaced them manually, now it works like it should!
    Thanks guys!
  10. snowchick7669

    snowchick7669 TS Maniac Posts: 660

    Good to hear!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...