Spread the love! TechSpot Tech Gift Shortlist 2017

Odd problem with USB Mass Storage devices - thumbdrives and others

By JasonLee ยท 4 replies
Aug 24, 2005
  1. Recently, my Pentium 4, Windows XP SP2 developed a very strange problem and I am hoping someone can help me. I was transferring some AAC files(legal) by my PNY attache 512 MB thumbdrive to my desktop. On plugging the thumbdrive into my desktop, it would no longer recognize the thumbdrive. It asked me to format the drive. So I permitted it to format the drive but it said it couldn't complete the format.

    Here is what I tried so far in order and I still get the same message.

    Right clicked on the thumbdrive and clicked on properties - device working fine but listed the file system as raw, tried to update the drivers but no new ones available. Tried roll back of drivers and did not roll back.
    Rebooted the desktop - same message.
    Plugged the same thumbdrive into my labtop - works just fine on the labtop (windows XP SP2) and on the desktop I have at work (Pentium 3 windows XP SP1).
    Tried different USB ports on my desktop computer. I do have a D-Link USB 1.1 hub attached. I plugged the thumbdrive directly into the USB ports in the back of the computer - same message.
    Formatted the USB drive on the labtop and then plugged into my desktop.
    Purchased a new USB thumbdrive Sandisk - same message.
    Device manager says the device is working fine. Tried to update the drivers - told me that there isn't a better match.
    Deleted the USB drivers in the Device manager, reboot, let Windows reinstall the drivers - same message.
    Updated the USB drivers in the Device manager.
    Tried other USB devices also seen as a removable drives such as a camera and they work just fine.
    Tried another USB external hard drive kit - got the same message but the desk top could complete the format of the drive and now no problems.
    Tried a brand new USB thumbdrive.
    Found out that I could open the USB thumb drive as a portable music player but I couldn't access files on it.
    Tried to install the Windows 98SE drivers but I either wasn't doing it right or it wouldn't install.
    Opened Administrator Tools and it says the USB drive is healthy.
    Changed the drive letter of the USB drive - same message.
    Tried to format the USB drive in Administrative Tools but could not complete the format.
    Used system restore - same message.

    Any ideas?
  2. Uilleann11

    Uilleann11 TS Rookie

    Same here

    Just ran across your query while in search of a solution to my identical situation. Did you ever find a solution?
  3. JasonLee

    JasonLee TS Rookie Topic Starter

    You won't like my solution

    It was a strange problem which never really found a solution to except doing a clean install of Windows XP. I had tried a reinstall and it didn't fix the USB problem either. Since I also had a problem with sending out email and my machine was running a little slow I did a clean install of Windows XP. However, a few months ago I ran into the email problem after using my fax-modem where I ususally use a broadband modem. This problem was solved by getting a program to fix the winsock. I found a little program called WinsockFix.exe from Explicit Software. It was free and fixed the email problem. My guess is they may have had a similar cause. Try the program, it will take less time to track down and run than a reinstall of XP. Let me know if you find a solution. And I also took out the faxmodem.
  4. Uilleann11

    Uilleann11 TS Rookie

    Thanks for the tip
    I'll try to find the program you suggested.
    Hate to think a complete rebuild may be the solution.
  5. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    please read the sticky regarding flash drives.

    never hot swap memory sticks.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...