os installed on s-ata and p-ata not allowing boot to so

By OpTiMuSpRiMe
Mar 30, 2006
  1. os installed on s-ata and p-ata not allowing boot to Os

    hey guys i was at home last night and i was farting around with my system when i found a slew of bad registry entries some programs that would not delete..So i said to myself kill it all and start over. hence why i am starting this thread..

    System Specs
    P4EE 3.2ghz 2mb L3 cache
    Asus P4P800-e Deluxe mobo
    Radeon X850XT PE 256mb GPU
    antec true power 600watt PSU
    40gig pata
    2x500gig S-ata no raid have backup server..

    here in lies the the issue.. the 40gig had my main install of windows with nothing else on it so . booted to the Xp pro cd deleted the partition for windows and the diags for it and installed a 100 gig s-ata on the third s-ata controller to install windows on so it was faster..right now here is the issue that i am having. remember that i deleted the partition on the 40gig and formatted it.. when i go to install windows on the 100gig s-ata drive it tells me that there is no xp compatible partition on the drive and that it will have to write some of the setup files to the old 40 gig drive.. ( not right at all ) so yeah i am thinking what the heck.. the only way this would be happening is if the install is detecting a MBR on the 40gig...not possible thought from being formatted.so i unhook the 40gig drive and install windows just fine on the 100 gig s-ata drive with no error about having to write some setup files to the 40 gig pata drive that used to contain my image of windows. Now here is where it gets fun. i get all the way into windows Yeah...k install all drivers correctly update the bios. etc.... ok shut the system down to hook up the pata drive for backup of music files and some storage for hacker tools. no way i get this error that says reboot and try a proper boot device if not then insert boot disk and hit any key.. what the f@*$ i am saying..i am pissed at this time ( 2:00 am my time) work in 4 hours. k so i have tried every setting know to man in the bios and still no go..the only way i can boot to windows with the install on the s-ata drive is if the p-ata drive is not hooked up...
    any help would be great guys...sorry about the novel here but thought you should know all i have done and tried
  2. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    ya you gotta remove the 40 gb for now
    I have found no way around this
    or let xp install the temp files (I didn't)
    M$ cd has something written the setup.ini or inf files that keeps defaulting to the first mast MB drive and you can't fool it by putting the drive as slave ide takes control of sata as far as I can tell
    ,but I have not experimented around with my bios sata controls
    anyone want to donate a used sata drive
    the one's I got are full and it would take forever to upload to my server
  3. OpTiMuSpRiMe

    OpTiMuSpRiMe TS Rookie Topic Starter Posts: 156

    yeah man i have even tried changing which ide controller the p-ata is on and that didn't work either.. i have all the setting in the bios the asus manual tells me and i have even called them to conform the setting and they are right and they don't even know what the issue is.. big surprise though.. i have come up with one last solution..i am going to get home and boot to the xp pro disc and format the drive with a force format and then F3 to quite and see if that knocks out the MBR that is somehow left on the drive..thanks for the help though guys
  4. OpTiMuSpRiMe

    OpTiMuSpRiMe TS Rookie Topic Starter Posts: 156

    good news found out how to make it work man..i hooked the p-ata to the primary ata raid controller on the systemboard and it let me boot to windows just fine..the crappy thing is that the new hdd that i had bought had a bad table so i had to return it..all this stuff that i went through would drive a man to drink if i didn't have so much patience with it all and the help of TechSpot members as well. thanks alot Samstoned
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...