PC won't boot at all... motherboard light is on

By saram96 ยท 8 replies
Nov 23, 2010
Post New Reply
  1. title says it all motherboard light is on and it wont boot up no beeps or nothing everything is connected i think, recently upgraded to a 600W OCZ Psu but i tried another psu aswell and it wouldnt boot, nothing starts at all, tried another case just in case power button had gone i dont know maybe i put something in bent but i honestly dont know any help appreciated, thanks for read system specs below:
    Also put in a new 500GB HDD

    Processor: Athlon II X4 640
    RAM:V DATA 2GB (2X2GB)
    2X 500GB HDD
    CASECOM 6788 case

    Will swiftly answer any questions just need this pc back on quick thanks alot
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Is your motherboard touchingthe side of the case in any way? Any wires that might possibly cause a short?
  3. saram96

    saram96 TS Rookie Topic Starter Posts: 33

    it isnt touching the case and what you mean by a short im a newb
  4. fiftythebe

    fiftythebe TS Rookie

    look maybe while changing the cases you did not connect the 24 pin power connector properly, i once faced that kind of situation. one thing you have to keep in mind while re-assembling a PC is the number of pins to leave out. there are 26 pins on your motherboard and 24 on the power supply connector. the best thing to do now is to connect the power connector leaving 2 ports towards the edge of the board, otherwise its either you receive that problem again or the motherboard doesn't power up at all though the CPU fan will keep spinning.
  5. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    Best thing to try right off the bat. Take the motherboard back OUT of the case, set it onto something soft with a static sheet between the motherboard and the soft object. Plug in the power supply, have your RAM in, processor in.

    Note: You will not have youra Power On/Reset cords attached to the board unless the cords are long enough and you want to plug them in, if you can't, you can use a Flathead screwdriver and touch the two pins that are "Power On" and it will work the same.

    Try and boot the computer. If it boots fine, then start to add hardware one piece at a time, if by any point it Stops booting, you know it is that hardware.

    How ever if it doesn't boot with the motherboard out and only the Power Supply/RAM/CPU. Take out the CMOS battery, disconnect the power, and try and boot it a few times, hit the power pins a few times, this will drain the board. Put the CMOS back in, and connect the power supply again. Try and boot the computer. If it boot's then there are two things to try. Restart the computer a few times, make sure it still boots. Also try to change just One setting that will not effect it (such as the time in the BIOS) save the settings, restart the computer.
    I had one INTEL Model that would refuse to POST after changing 1 setting in the BIOS, and it happened on multiple boards even after RMA.

    Post back any updates.
  6. saram96

    saram96 TS Rookie Topic Starter Posts: 33

    thanks for help will do now
  7. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    no problem, report back with the results or anything new.
  8. saram96

    saram96 TS Rookie Topic Starter Posts: 33

    not working will just scrap it keep the ram and hard drive and sell the rest of it thanks alot guys sorry for wasting your time
  9. ComputerGuy55

    ComputerGuy55 TS Maniac Posts: 380   +8

    Not a waste, just one last thing, I assume the board is out of its warrenty period then ?

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...