Photoshop CS Not Responding on Vista

By livywillow
Aug 16, 2009
  1. I have been trying to get photoshop CS v.8.0 on my laptop for about 2hours now with no luck.

    I have removed my preferences, tried to run it as administrator, reinstalled it but it's still not working. Imageready is working, it's just photoshop.

    What could be wrong with it?

    I am using vista. It has worked for a good two months now but suddenly has stopped working.

    Please help, I can't survive without photoshop!

    - many thanks, Olivia.
  2. Nza

    Nza TS Rookie

    You might want to check the registry and ensure that you have your user ID permissions set on the Current user and Local Machine.

    Also ensure that you have it in the firewall allowed list.

    Check certain services are running that could be affiliated with the application like Adobe License related services etc.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...