Please Help! USB Flash Drive Problems

By bob_blc ยท 14 replies
Oct 21, 2005
  1. I have a SanDisk Micro 256MB flash drive. This drive has been worked properly ever since I got it. And then today, when I plugged it into my drive it shows up as Generic USB drive and it will not open. I go to My Computer and it says "Please insert a disk into drive e:"

    When I go into My Computer \ Manage, I can see the disk but it will not allow me to format it!

    Any ideas on how to get it to work again??

    p.s. It doesn't need drivers - - Already looked on the manufacturers website - -

    Thanks for any ideas!
  2. Rik

    Rik Banned Posts: 3,814

    Its probably the formatting of it that has corrupted, had a similar problem with an mp3 player, i removed all drivers for it and got windows to go on the net to find a driver, it came up with an automated recovery console that fixed the problem for me. It deleted the partition then reformatted so i lost all data on it, but it worked again.
  3. eaarcher

    eaarcher TS Rookie

    I have a client with a simular problem only it happend to me when I was setting up an Maxtor External Drive for her. I'm looking for suggestions my problem. When I plug the device into my laptop it is detected and I can browse to it. I'm running XP Home + SP2. My client is running the same OS, but when I plug it into her HP tower, the system asks me to install the driver. There is no driver offered for this model by Maxtor. It is supposed to use a generic USB driver. I do get the message about not using a High Speed 2.0 USB port but the device is backwards compatable, so other than running slower it should be picked up by the OS. But it isn't.

    Any Suggestions?

  4. Soap

    Soap TS Rookie Posts: 72

    Does the flash drive only have this problem on your computer? are you able to try and use it in another computer?

    i have had a similar problem with flash drives at work and sometimes they work in another computer.
  5. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

  6. vq888

    vq888 TS Rookie

    USB problems

    hi, i have a 1.0 GB USB flash drive, i use it frequestnly on my laptop (windows) and in school computers (linux), i last used it on sunday to save a project and it was fine, but today all of the sudden i plugged it in and my laptop didnt recognize it.... then i tried in my school computer and same thing... it doesnt recognize it.... any ideas on how to solve this problem??
  7. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    Did the link in the post above yours help?
  8. vq888

    vq888 TS Rookie

    no, it didnt, i went control panel ->admin tools->comp management->disk management and the usb doesnt show ... at all!!

    then i plug it in, and it doesnt show in my computer either....i tried plugging in other usb devices thorugh the same port and my computer reads them fine, so its my usb drive... any ideas how to help?
  9. SisterG

    SisterG TS Rookie

    vq888, I had almost the exact problem - found three solutions to try in another thread on this website: go to "USB Flash Drive Problem with Windows XP" thread and check out the options. The one that worked for me was to completely disconnect ALL cables/wires/plugs from the back of my desktop, wait 30 minutes (or so) and then reconnect everything. Before starting the computer, you insert your flash drive and run the CHKDSK if it "goes there" and VOILA! Your flash drive is restored, virtually unharmed. That is, IF it works for you. It's certainly worth a try to check out the thread if it doesn't.

    Good luck!
  10. bobbabe

    bobbabe TS Rookie

    Hello! I have a Sony 2gig usb flash drive . I use a Mac OS10.4.8. I recently tried to add a file to the drive which has only about 50 mb of data on it. It does not allow me to add anything. The message indicates there is not enough free space on the drive.
    I am able to read data and have saved all files. Not sure what to do next here. Reformat? what? any suggestions? thanks- bobbabe
  11. carl_v

    carl_v TS Rookie

    Fake Sony 2Gb Flash Drive

    Unfortunatley there were on the market FAKE Sony 2Gb Flash drives and it seem like you have one. they were 'cooked' 128 Mb

    If to try to format it you will lose it alltogether.
  12. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    noobs - please start a new thread when asking questions and don't piggyback on others. thanks.
  13. faerygirl888

    faerygirl888 TS Rookie

    Do I have to format my disk again? (>_<)

    so i have this stupid flash disk and i put all my poetry and photos on it when i moved from my parents so it wasnt on their computer anymore and when i used it on other computers the first few times it worked but then it said i had to format it, so i eventually did and put my new stuff on it, but now it is saying the same thing, did i loose all my stuff again? the computer i have now has the new windows vista on it, i tried opening it the way tredster said but it didnt work, please help!
  14. Blakace

    Blakace TS Rookie

    check this

    Try this...
    This will re-partition the USB Flash and erase everything in it
    Go To Desktop Start/Run and type diskmgmt.msc and then look for the removal disk and follow the partitioning process. It easy

    Hope this helps
  15. bobbabe

    bobbabe TS Rookie

    flash drive problem

    Blakace- thanks for the reply. I'll give it a shot.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...