Please help - Video Driver problem, Direct3D Acceleration 'Not Available', Project64

By CateJreh ยท 5 replies
Mar 13, 2010
  1. I'm a complete and utter noob when it comes to computers, so please bear with me. Plus, this is a bit of a long story, so I apologise in advance, but I really don't have a clue what's happening with this computer...

    So I'll start from the start:

    I just downloaded Project64 onto my computer again because my hard-drive recently blew up or something, (manufacturer's fault, or so I'm told) and so I've had to start all over again loading my programs onto this new one.

    Anyway, Project64 (emulation software I use to play old Nintendo 64 games on, though you probably all know that already, I'm not sure) used to work fine with my old hard drive, but for some reason when I open it up now it comes up with this Error message that reads:

    'Direct3D failed to initialize
    Error code: 8876086A

    So I click OK, and then this pops up:

    'The default or selected video plugin is missing or invalid.

    You need to go into Settings and select a video (graphics) plugin.
    Check that you have at least one compatible plugin file in your plugin folder.'

    So then I click OK again, and it takes me into Project64's Settings, and I'm quite convinced at this point in time that the problem's not with the video plugins at all, because I do have compatible ones and they should work. (I'm using Jabo's Direct3D8 1.6 as a video graphics plugin and that used to work on this same computer).

    Anyway, I click out of the Settings because I have no idea what I'm doing in there, and then it opens the Project64 window, as if nothing's wrong. That is, until I click on 'File - Open Rom' and try to open one of my games when another Error message pops up and says:

    'Cannot open a rom because plugins have not successfully initialised'

    I then clicked on 'Options - Configure Graphics Plugin...' and yet another Error message pops up and says:

    'Initialize the dll before you try config it!'

    So I pressed OK again and just googled these Error messages. Now, from what I've found on various forums, (and this problem is actually surprisingly common, though nobody seems to be very clear on how to fix it), is that I'm supposed to go to 'Start - Run...' and then type in 'dxdiag', which opens up my DirectX Dianostic Tool, and then go to the 'Display' tab up the top of the window and then, supposedly all I have to do to fix this problem is to enable the 'Direct3D Acceleration'. The only problem is for some reason the Direct3D Acceleration is completely disabled and the little click-box thing is all grey and I can't click on it. And there's a little box down the bottom of the window called 'Notes' and it's telling me 3 things:

    'The file is not digitally signed, which means that it has not been tested by Microsoft's Windows Hardware Quality Labs (WHQL).
    You may be able to get a WHQL logo'd driver from the hardware manufacturer.'

    'To test the DirectDraw functionality, click the "Test DirectDraw" button above.' (I don't think that one's particularly worrying, somehow)

    'Direct3D functionality not available. You should verify that the driver is a final version from the hardware manufacturer.'

    So then I tried to google this last one but I'm just getting way, way out of my depth here. I think it has something to do with my video driver not being 'enabled', but then what the hell do I know? I would just give up on this whole game thing, except that I think the video driver has been affecting some other programs of mine, and I really, really want to play Banjo-Kazooie and Banjo-Tooie again. All my old Ninendo 64 games have gotten lost, you see, and I have this sneaking suspicion that my little brother had something to do with it. But anyhow, I digress..

    So anyway, I'll just tell you what I can find out about my computer:

    Operating System:
    Microsoft Windows XP Home Edition (5.1, Build 2600)

    Pentium(R) Dual-Core CPU
    E5200 @ 2.50 GHz, 2.00 GB of RAM
    Physical Address Extension (I don't know what the hell that one means, but just in case it means something to you I'll include it...)

    About my video card: I know it's Nvidia, and that's about it. It can't be old because a friend of mine put together my computer only like a year ago, maybe less. I'm sorry but I have no idea what driver I have already, and I'm not too sure how to find out (Fat lot of good I am, I know).

    Anyway, please, please help. I'm really lost at the moment but I'd love to have this problem sorted out. My apologies for the ridiculously long post, I just didn't want to leave out any information in case it turned out to be important, so I just wrote down my whole goddamn life story just to be safe.

    Anyway, thanks in advance,
  2. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    To identify which nVidia graphics solution you may have. please download GPUZ and run it.

    If the card is also a year old any of the current nVidia's WHQL drivers should be work to start with. Please go to nVidia's site; download the drivers, and install them. Then see what happens, although it should help alleviate your issue.
  3. CateJreh

    CateJreh TS Rookie Topic Starter

    Hey thanks, Archean, for replying.

    Well I downloaded GPUZ, and it doesn't know what nVidia driver I have.
    The whole window just says:

    Name: Unknown
    GPU: Unknown
    Technology: Unknown
    Revision: N/A
    Release Date: Unknown
    Die Size: Unknown
    Transistors: Unknown

    and it pretty much just goes on like that all the way down the window. So, that doesn't sound very good. Anyway, I'll go try and download some drivers from Nvidia's website.

    Thanks so much for replying so quickly, I wasn't sure how long I'd have to wait for advice.
  4. CateJreh

    CateJreh TS Rookie Topic Starter

    I just went on the Nvidia website and downloaded their latest driver and miraculously my whole computer works again. The screen has stopped randomly going black and not being able to load internet explorer pages and, most importantly of all, both Banjo Kazooie AND Banjo Tooie are now working.
    Plus GPUZ is now telling me that I do actually have a driver, which is always positive. Even the Direct3D thing in 'dxdiag' is enabled. It's all back to normal.

    Thank you so much for your help Archean, I was worried I was going to have to buy a whole new graphics card or something.
    Well, I'm off to go and play some emulated Nintendo 64 games -
    Thank you!
  5. captaincranky

    captaincranky TechSpot Addict Posts: 12,973   +2,527

    The current "solution" for ALL nvidia, and it appears all Windows OS versions is 196.21. I only mention this since it took me back a bit, since I too am accustomed to the different series card, different driver situations of the past. Although, the really, really, old 5XXX series aren't associated with this driver.
  6. Archean

    Archean TechSpot Paladin Posts: 5,690   +96

    Thanks for the informed comment captain; I remember reading somewhere that nVidia has pulled the latest drivers off from their servers. However, that 5xxx point is very good one, but anyway, I guess he/she has got her problem solved. But strangely enough GPUZ didn't tell her what GPU she had hmmmm that is strange, and something to look into before I ask someone else to do this. Regards
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...