Powerline adapter invalid IP address problem

By ledzeppelins ยท 10 replies
Feb 7, 2011
Post New Reply
  1. Before I explain the problem, thank you to anyone willing to help me sort out this mess; I have been at it for hours and have come up with nothing.

    About 1.5 years ago I purchased the Linksys PLK300 Powerline Adapters to give internet access to an Xbox 360 and PC in a room where wireless connection was slightly cold. They worked exceptionally up until just last week. I was surfing the web when I noticed that the internet went down and it has been down ever since.

    The adapters are properly plugged in, it appears as if nothing is wrong with them- LEDs still flashing, and the Xbox and Computer recognize their presence, but they won't connect to the web.The router still sends out a wireless signal, strong as ever.

    I have tried restarting both modem and router, I have checked to see if the MAC addresses are conflicting, I have made sure that there is no security to mess it up, and I have also made sure that any IP address can access my network. I have done just about everything I can think of to make this work. Before anyone delays their ideas waiting for an IPCONFIG /ALL post from me, I have already made sure DHCP and Auto Configuration are enabled and I have no idea what ipconfig /renew and ipconfig /release (or whatever it was) do, but I did that too.

    The computer from the offline room gives me an IP address of 169.254, indicating no connection to DHCP (not totally sure about the DHCP but it definitely means no connection.)

    I have both adapters plugged straight into wall sockets, not on the same socket as the modem/ router and am getting frustrated without the internet in this room, so if you have any idea what could possibly be the problem I would greatly appreciate it.
  2. jobeard

    jobeard TS Ambassador Posts: 10,835   +895

    Yes that's the issue; that address will not exit your LAN and it is the DHCP failure that generated this address.

    Verify that both ends of the Powerline Adapter work locally.
    the Master is already attached to your router, so bring the remote device into the same room and plug it into a wall outlet there. Now test - -
  3. ledzeppelins

    ledzeppelins TS Rookie Topic Starter

    I tried what you said but to no avail, does this mean my powerline adapters have kicked the bucket? It was so odd, they just shorted out on me in the middle of use. Do you know if these types of equipment are short-lived? Any quick fixes that might bring them back to life or signs of which one is malfunctioning?
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    You should also
    > Refer to the Linksys Support site
    > And i would have to guess the LEDs on the units will also tell you much info including whether or not they detect each other over the powerline

    Look at your unit LEDs and check the support documentation
  5. ledzeppelins

    ledzeppelins TS Rookie Topic Starter

    The support site doesn't have any direct answers, and I seem to have misplaced the documentation for the product.
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    You need to take a closer look of site on the support link i provided and look under the Download tab.

    I just looked and it includes
    > Download for User Guide
    > Download for Quick Start guide
    > Download for Firmware upgrade and separate download for instructions how to do the upgrade
  7. ledzeppelins

    ledzeppelins TS Rookie Topic Starter

    Thanks for taking a closer look around that website, I'll definitely try a few things out and report back!
  8. ledzeppelins

    ledzeppelins TS Rookie Topic Starter

    I downloaded the software Linksys provides and I'm not quite sure what to do with it. In each room it says there is one device on the network.
  9. ledzeppelins

    ledzeppelins TS Rookie Topic Starter

    Anyone have any ideas?
  10. ledzeppelins

    ledzeppelins TS Rookie Topic Starter

    bumping topic, adapters still not working.
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Unfortunately, i think there's a limited amount of support you can find here. I, myself, have never used this Linksys model. In fact, i only tried powerline once (i think a netgear) for a couple weeks. Then returned it. Have you tried the Linksys forums? As others there may have used your model

    About all i can suggest is:
    > Read through the user guide. Most importantly, note the LEDs status lights and what they mean plus any buttons/switches on front/back panels and what they do
    > Hit the reset button to first reset both units and then test them by seeing which LED status lights turn on (that's about the best feedback you're going to get from those units as to whether or not they connect to each other)
    > Also try the firmware upgrade if you haven't yet

    And try Linksys forums to see if others have experience with your specific models.

    G;luck :)

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...