1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Problem connecting to wireless network!

By jordzee
Apr 11, 2012
Post New Reply
  1. Hey, I'm using a Toshiba Satellite C500D with an Atheros ar9285 wireless network adapter on Windows 7 OS 32bit.

    I have a problem when trying to connect to my home network. Occasionally it will connect with internet access, but the connection keeps disconnecting,sometimes after an hour, sometimes after only seconds. It's very moody, at other times it will connect to the network but will not have internet access. When I run windows diagnostics it will come up with different solutions each time - either being "Verify the network security key" or "Restart router or modem" (which proves not to help), and at other times it will say there is a problem with the wireless network adapter but cannot fix it. I am able to connect to other networks with no problem at all.

    When using the Atheros "connectivity doctor" it tells me the problem is that it fails to obtain an IP address, but the solutions it provides (restart windows, restart router) have no effect.

    The driver is up to date, I have tried many different driver version and I have also done a system restore, disabled my anti-virus software and firewalls, all with no success.

    The signal for the router is around 3 bars.. On another laptop using a Realtek wireless adapter, the signal is full and able to connect with no problems at all.

    I am unsure what to do and am thinking the only solution would be to buy a new wireless adapter.

    Any help would be much appreciated!!
  2. ITLogicSystems

    ITLogicSystems TS Booster Posts: 21   +7

    Had a similar issue the other day w/ the same router... Humor me and change your wireless encryption from WPA2 down to WPA, or from WPA to WPA2. Whichever you are using, change it to the other. Also change the password on your wireless network. Then try it. If it still doesn't work, try changing the wireless channel to 1 or 11. If all else fails, reset (not restart/power cycle) your router back to the factory default and re-setup the wifi network. Post back and let me know if this resolves your issues. Take care!
  3. alexe3831

    alexe3831 TS Enthusiast Posts: 29

    I have had multiple problems with my Atheros wireless adapter, it seems it mostly is the adapter itself at fault, as I have no issues on other computers on my network. If you have one you might try a USB wireless adapter, using it to connect to the network instead of the internal adapter, it fixed the problem for me.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...