1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Problem with 1GB RAM

By Silverhand · 22 replies
Jan 1, 2004
  1. Problem with 1MB RAM

    Hi everyone. I am looking for some help with a problem upgrading my RAM.

    I just bought 2 x 512MB memory modules to replace my old 2 x 256 sticks. Both the new RAM and the old is the same type, PC2100 DDR RAM. My problem is this:

    I can install one or the other stick and run just fine with 512MB, or I can match one of the new 512 sticks with one of the old 256MB sticks, to give me 768MB.

    What I cannot do is install BOTH 512MB sticks, which is what I want to do. If I install them both the PC either doesn't get as far as desktop or it boots to desktop and runs for a few minutes at most then crashes and enters a restart loop.

    The PC detects 1GB RAM both at boot up and under system properties, but it just won't remain stable to do anything.

    My system details are:

    Athlon XP 2400+
    PC2100 DDR RAM
    Asus A7A266-E Motherboard, BIOS version 1011
    Gainward GeForce4 Ti 4800 SE Video card
    Windows XP Home OS

    Any advice here would be greatly appreciated. My technical knowledge is pretty basic, so please bear that in mind.

    Thanks very much :)
  2. NoisySilence

    NoisySilence TS Rookie Posts: 98

    I suppose you meant 1GB of Ram.

    Install both 512mb sticks & try running a memtest. Ask it to run a complete test & leave it for a few hours.

    If you still get the problem, try putting the newer stick in the DIMM slot closest to the CPU, if it still doesn't work, try moving the different sticks around.
  3. Silverhand

    Silverhand TS Rookie Topic Starter

    Thanks for the reply Noisy. Yes I did mean 1 GB of RAM :)

    I tried installing the sticks both ways, with each one in a different slot and it won't work either way, but either one on its own does work..

    As for the memtest, I don't really get any chance to do anything if I have the 1GB of RAM in. It tends to crash before or just after boot up, with only rare occasions getting as far as desktop.

    Would it help to run the memtest on the RAM I have now or would that not be worthwhile? I have 1 x 512MB and 1 x 256MB sticks in at the moment..

    Thanks again :)
  4. NoisySilence

    NoisySilence TS Rookie Posts: 98

    Install only one stick, to allow you to burn that ISO image to a CD ( even a CDRW if you want ) & once that is done, reinstall both sticks & boot on the CD.

    You can also run the test on each separate stick.

    I didn't ask that before but, what brands are the sticks ? Do both have the same timings ? It could be that you're trying to run a 2.5CL module at 2CL. Try going in the BIOS & forcing timings to the slowest possible values ( 2.5-3-3-6 ) instead of SPD.
  5. Silverhand

    Silverhand TS Rookie Topic Starter

    The RAM is from Crucial Technology, so whatever brand they use :)

    Timing is 2.5CL and that is the same as my old RAM so I presume BIOS settings wouldn't need changing?

    I will have a go at running the memory test though, see if I can figure out how to do it..

    Thanks again for your advice :)
  6. Silverhand

    Silverhand TS Rookie Topic Starter

    I ran the memory test on each stick and it reported no errors.

    I still cannot install them both together though :(

    Someone suggested I increase the Virtual Memory settings so that both minimum and maximum values are twice the amount of installed memory, so in this case they would be set at 2GB. However, I have read elsewhere that there is no need to have the virtual memory set that high so I am not sure if I should do that..

    Any further suggestions would be very welcome.

    Thanks again :)
  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    I have an older ASUS P2B-S mobo which had exactly the same problem. Putting the memory-sticks in slots 1 and 3 solved it.
  8. scooby

    scooby TS Rookie Posts: 19

    what is the fsb running at? is it at the correct speed? pc2100 i think is 166mhz.
  9. Silverhand

    Silverhand TS Rookie Topic Starter

    Realblackstuff, there are only two slots for DDR RAM on my motherboard.

    Scooby, I think the FSB is running at 133MHz. How do I find out for sure? Is it listed in the BIOS? In any case, it seems to work ok with either 2x256MB sticks or 1x512MB plus 1x256MB. It just won't work with 2x512MB...

    Thanks anyway for your replies. Much appreciated :)
  10. ---agissi---

    ---agissi--- TechSpot Paladin Posts: 1,977   +15

    Run the test with both sticks in.

    PC2100=266MHz FSB
    PC2700=333MHz FSB
    PC3200=400MHz FSB

    Silverhand is running a 266MHz FSB. It says 133MHz in the BIOS, because it takes that number x2 (always) to give you the FSB.
  11. scooby

    scooby TS Rookie Posts: 19

    would he need to flash the bios or update it maybe???
  12. Silverhand

    Silverhand TS Rookie Topic Starter

    Agissi, I can't run the memtest with both sticks in because the system is too unstable and crashes within minutes if I put both in..

    I will try to update the BIOS and see if it helps.

    Once again, thanks for all your suggestions.
  13. Silverhand

    Silverhand TS Rookie Topic Starter

    I am at a complete loss :(

    I updated the BIOS and tried the timing settings as you suggested Noisy. The system didn't crash with those settings (at least not for the several minutes I had it turned on) but what happened was this:

    Everything seemed ok but when I connected to the web and tried to scroll up and down a page the screen would go black for a second or so each time new information had to be displayed. Same thing happened when I went to Control Panel. When I wanted to view certain things the screen would go black for a brief moment and graphics wouldn't always display properly.

    I didn't try to run any other programs because it was obviously not working correctly.

    What is so frustrating is that it is perfectly fine with any combinations of 512MB sticks on their own, or any two 512MB + 256MB, 2 x 256MB combinations. Just when I try 2 x 512MB it won't work :(
  14. ---agissi---

    ---agissi--- TechSpot Paladin Posts: 1,977   +15

    Could you RMA it? Sounds like your mobo is defective in one way or another.
  15. Nic

    Nic TechSpot Paladin Posts: 1,549

    Can you try running with both sticks at fsb of 100MHz?

    It may be that both your RAM sticks are not identical, and one of these may be out of spec, and causing instability, though that is only a guess.

    I do know that 512MB sticks require more power to run than smaller sticks, and some older mainboards did struggle to run these sticks.

    Maybe putting two of these in just takes your mainboard over its limit, and it cannot supply enough current to drive them.

    You could also try increasing the RAM chip voltage in the bios (if there is a setting) just to see if this helps (e.g. from 2.5v to 2.7v).

    Again this is all just speculation, so a bit of experimenting is required to get to the answer.

    Good luck.
  16. Silverhand

    Silverhand TS Rookie Topic Starter

    Hmm, the voltage idea seems like a good one Nic. It would seem to explain what has been happening pretty well..

    I don't see anything in BIOS to change it so I was wondering if there was any other way to increase it?
  17. ---agissi---

    ---agissi--- TechSpot Paladin Posts: 1,977   +15

    I dont think theres another way to increase the RAM's voltage, however it is in your BIOS ;) It'll be set at 2.5v, you'll want to change it to 2.6v, see if that fixes your prob, if it doesnt try 2.7v. Keep Looking!
  18. NoisySilence

    NoisySilence TS Rookie Posts: 98

    The a7a266 only supports 2.5V DDR DIMMS ( according to the manual ) & there's no way to change that. But on the other hand, voltages above 2.5V are only required for faster running DIMM modules, like PC3200 for example. PC2100 should run at 2.5V.

    If it still doesn't work after all these tests, it is simply because those two modules are incompatible with each other. Mixing different brands/types of Rams is always a lottery, sometimes it works, most of the time it doesn't.
  19. ---agissi---

    ---agissi--- TechSpot Paladin Posts: 1,977   +15

    More like most of the time it does... for me anyways. My friend has a PC running two different brands, my PC has two different brands, my other PC does, and my dads does. Never had a problem.
  20. NoisySilence

    NoisySilence TS Rookie Posts: 98

    Well as it goes increasingly in size, the difference gets bigger & the tolerance to memory faults is smaller.

    That's why for even larger amounts of memory you need buffered memory & if possible with ECC.
  21. Serlo

    Serlo TS Rookie

    I have been struggling with the same problem (same motherboard same RAM upgrade even down to the make Crucial) and while reading through this forum I also thought the voltage was a good idea.
    In my motherboard manual it refers to a DDR Voltage setting switch JP10, it is located at the inside end of the AGP slot (I had to remove my graphics card to get access to it). This switch is set at a default of 2.5v (pins 1+2)but can be used to switch to 2.6 (pins 2+3).
    After switching my system seems to have accepted the two 512 sticks anyway this is the longest period its EVER ran with 1GB of RAM. Goodluck.
  22. Triton

    Triton TS Enthusiast Posts: 82

    There are many things to consider when buying memory.
    Crucial memory is only "guaranteed" to work if its on the list from the "Memory Advisor™ tool" based on the motherboard used.
    "We guarantee the upgrades you find through our Crucial Memory Advisor will be a perfect match for your computer."

    Compare the memory you have from the list of compatible memory from Crucial for the ASUS A7A266-E.

    The voltage the memory bus is running at should be listed in the motherboard BIOS.
    But I am skeptical of the accuracy of the sensors of many motherboards.

    "The 184-pin DIMM must be a 2.5V unbuffered DDR SDRAM."

  23. Serlo

    Serlo TS Rookie

    Thanks for that Triton.

    You must have guessed that changing the voltage switch wouldn't be a permanent solution. Back to a freezing system.

    The most my motherboard seems willing to accept is 768mb - being an original 256 & one of the new 512's I hoped to upgrade to.
    I checked out each link you provided & confirmed the crucial memory cards I have are on their recommended list 184 PIN DIMM DDR PC2100.
    Re-set the voltage switch to 2.5 - unless someone has any better ideas I am giving up & making do with my 768mb.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...