Problem with crashing in a game at certain points

By shem · 6 replies
Feb 25, 2006
  1. I just put together my computer the other day, installed everything today, and after all of that, I wanted to play some Battlefield 2, the only problem is, it won't let me. I open up the game, it joins a server, goes through the loading process, I then finally click the join game button, it does join the game, and shows everything for 5 seconds, and it then it freezes, at the same spot every time, right when I join the game. Then sometimes my monitor turns off too, but my computer is still running, and I have to hold down the power button to restart it. Why is it doing this? Any help will be great.

    And if it helps, I have a Sapphire Radeon x1600, AMD Athlon 64 bit 3200+, 1 gig of Kingston Value Ram, ASUS A8NE
  2. Rik

    Rik Banned Posts: 3,814

    First thing to do is make sure all your drivers are up to date. Not just the graphics card but all the mobo ones too.

    Running dxdiag may help too. To do this, click on the "run" on your start menu, then type "dxdiag" then hit enter. Run through the graphics tests then perhaps the sound ones too to look for any problems.

    Hope that helps, if not, i will do my best to help further. Rik.
  3. shem

    shem TS Rookie Topic Starter

    I ran all of the tests, and everything was fine. I tried some more games to see if it was more than just BF2, and it was, it did it in Call of Duty 2, and even Quake 3.
  4. sw123

    sw123 TS Rookie Posts: 595

    Could be an overheat problem
  5. DonNagual

    DonNagual TechSpot Ambassador Posts: 2,406

  6. shem

    shem TS Rookie Topic Starter

    Well, I put it in a new case not too long ago, and had a tempature sensor on the video card, and while starting battlefield 2, it ran at a steady 95ºF. So I can rule out that it isn't an overheating problem. Any other ideas? I updated all of my drivers, even got a new case, so I don't know what it is. Could it be my 430 watt Thermaltake PSU?
  7. shem

    shem TS Rookie Topic Starter

    Ok, I did my research, and found out on Sapphire's forums under troubleshooting that this is a huge problem for anyone with an ASUS motherboard and an Nvidia chipset. This is just lame puke:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...