Problem with Internet connection

By Caroline ยท 16 replies
Jul 31, 2007
  1. Hello,

    I have an old laptop that runs Windows 2000 and until 2 days ago, the Internet was working just fine on it.
    2 days ago, it stopped working. After trying several things, I phoned the hotline for the Internet provider, and they said my connection is working just fine.
    The modem is linked to a router, and as a matter of fact, the Internet is working. I brought back my laptop from work, and I can connect to the Internet. It's only my old laptop that cannot have access to the Internet at all. I tried several things on it: the IP address displays fine, I can ping the server, etc. I really don't understand why suddenly it doesn't work.
    can anyone help?


  2. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    on the laptop, try;

    ipconfig /release all
    ipconfig /renew all

    and then get the new config via
    ipconfig /all

    ping your dns address shown and then
  3. almcneil

    almcneil TS Guru Posts: 1,277

    If it happened out of the blue, i.e. you didn't install or mess with settings, then it's probably spyware or virus.

    Try running the following 3 anti-spyware utilities (if they are supported on Windows 2000) :

    • Ad-Aware 2007
    • Spybot Search & Destroy
    • AVG Anti-Spyware
    All are free and can be downloaded over the Internet.
  4. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    It's more likely that your modem or router need a firmware update, as most of
    them fail to respond correctly to the release/renew cycle created by the ISP.
    This leaves you with a malconfig'd tcp settings and thus no connection.
  5. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    When you connected the work laptop to the internet, did you connect through the router?
    at the command prompt, can you ping or just local IPs?
    have you tried rebooting the router?
  6. Caroline

    Caroline TS Rookie Topic Starter


    Thanks a lot for all the answers!
    I tried all the suggestions, but to no avail.

    I tried to release and renew the IP. Each time, it worked.
    When I pinged the DNS address, it said Request time out.

    I also ran Spybot and AVG (that were already installed), and everything seems to be fine.

    Regarding the firmware, I upgraded it to the latest available version.

    And to answer the last questions, I connected my work computer via the router. My Internet connection on the work laptop works just fine.
    I tried to reboot the router, the modem, nothing worked...

    Any other ideas?


  7. almcneil

    almcneil TS Guru Posts: 1,277

    Did you try a repair installation?
  8. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    use run->cmd /k ipconfig all
    and post the results as followup.

    also View Network Connections and describe each
  9. Caroline

    Caroline TS Rookie Topic Starter

    Tried a repair, it did nothing.

    Here is the information after doing ipconfig/all:

    Windows 2000 IP configuration

    Host name: Caroline
    Primary DNS Suffix:
    Node type: Broadcast
    IP Routing enabled: No
    WINS Proxy enabled: No

    Ethernet Adapter Local Area Connection

    Connection specific DNS Suffix:
    Description: D-Link DFE Cardbus PC Card
    DHCP enabled: Yes
    Autoconfiguration enabled: Yes
    Autoconfiguration IP Address: 169.254.XXX.XXX
    Subnet mask:
    DNS Servers:

  10. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    your NIC card is not seeing the router AT ALL!

    disconnect the system from the router
    use View Network Connections->properties
    pull down to TCP/IP->properties

    set both IP and DNS to DHCP
    on the alternate tab, clear every off

    now reconnect and repeat the ipconfig /all
  11. tipstir

    tipstir TS Ambassador Posts: 2,477   +126

    You're getting a PRIVATE IP address when you see the 169.254.. Try jobeard method or you can take out the card if you have a card type of adapter restart W2K then you login into W2K wait until everything loads then insert the card back in.

    click on start
    then on run
    type: cmd
    type: route print

    The first line should say the correct Gateway then the Interface you not be the 169.254.. and say the correct one...

    If all fails then you need to take out the driver for the NIC (network card) reboot the system then re-install the driver.
  12. Caroline

    Caroline TS Rookie Topic Starter

    Thanks again for your replies.
    I tried to set the TCP/IP properties and they seem to appear fine.
    I reinstalled the driver for the card and rebooted, tried the cmd/route print and the interface showed the right number I think, but Internet is still not working.
    Any other ideas?
  13. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    post your results from ipconfig /all
  14. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    Looking back at this one I think your network card is bad. Can you try another one - perhaps a USB based network adapter as they are easier to install?
  15. Grummangy

    Grummangy TS Rookie

    It may also be worth mentioning that if you have any AV with firewall protection on that PC in question to check what is and is not being blocked. I've found that Trend Micro for some reason of late on clients PC's has been blocking access to the net for no apparent reason. I deleted and redid network connections and then set a custom new profile within TAV, systems are humming along. With other AV/FW software just check the settings to see what is being blocked or restricted.

    To quickly check the NIC, have both PC's connected to the router, type IPCONFIG on your work PC and note the addy, then ping it from the other PC with the problems. If you get a successful result the NIC is fine. It's more than likely to be an issue with installed software. If not then yes the NIC could be faulty. You can also reverse the process and ping the PC in question from the new one once you have the address.

    Also check that both PC's are actually being given similar addresses from the DHCP side of the router eg 192.168.X.X and 192.168 X.X and subnet. The fact that you are being assigned an address tends to have me lean away from hardware, but I've covered both here.

    Hope this helps.
  16. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    ping is a protocol on a specific port and thus it too can be blocked.
    customarily, the WAN port on a router defaults to stealth mode for ping
    and allows ping on the LAN port(s). SOME routers have controls for ICMP
    which is not targeted to a specific port.
  17. tipstir

    tipstir TS Ambassador Posts: 2,477   +126

    Did the internet gateway load? Did you block the laptop in the router from access the internet. Sometimes this happens by mistake trying to filter out stuff. Check your settings for that laptop or add the laptop to your list to access the internet.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...