Problems with System Restore & SDS 2.0

By venus_lluv
Apr 15, 2006
  1. I was online the night before and my I.E. froze after I clicked on a link. This happened a few times before, but this time I couldn't end/close it with "ctrl + alt + delete". So being too sleepy and tired to wait OR THINK, I unplugged the USB adapter. Before I knew it, my whole computer crashed and failed to reboot. So I forced shutdown by pressing the power button.

    This morning I had to reboot a few times before the computer finally restarted. However, it took like 5 minutes to load, and one of my programs quit working. I tried system restore the whole day, but none of the points work. Don't ask me why, but I also tried to reverse the last restore points just to see, and it didn't work either. And to make things more confusing, the "software distribution service 2.0" keeps on appearing as one of the restore points.

    Does anyone have a similar problem or know anything about any of this??? If you find a solution, please let me know. I would really REALLY appreciate it.

  2. Peddant

    Peddant TS Rookie Posts: 1,446

    Yes - Similar problems

    We certainly will.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...