Tech Stocking Stuffers: 18 awesome gifts under $50

Really irritating "memory cannot be read errors"

By Rathgar ยท 8 replies
Aug 4, 2006
  1. Hi all,

    I've been having some problems lately with my computer. The whole "memory cannot be read" or "memory cannot be written" style error had been coming up intermittitly on my computer for a while, but after a reformat, it's been worse.

    As for can see from the screen shot, iTunes refuses to load, as does an unrelated iPod program. And StrongDC crashes when it closes. I originally thought it was a ram problem, and so tested my two sticks of ram with both Memtest 86 and Microsofts own ramtesting program.

    Well the microsoft program found nothing, and neither did the memtest program... Until i selected "BIOS - ALL" in the scanning options.. then it went off.

    Funny thing is.. if it's a bios problem, when i tested the sticks one by one, only one of them gave me the errors. Fair enough i thought, and left the stick out of my computer whilst booting. Tried programs again. No dice. Still have the errors. One site suggested that this can be a problem with the Geforce series of cards, so i updated my drivers.. and again, no dice.

    It was at this point, i got fed up, put my other 256 mb stick in my computer, and gave up.

    It doesn't seem to be a ram issue, because, as i said the issue is still around even on the "good" stick of ram (according to memtest it's good). It's not a H/D issue either cause i tried installing Itunes on my Archive drive to test that theory...

    So .. i'm lost. Any suggestions guys ?...

    If it helps at all, the computer was slow when running a MATS+ ram test on these ram address ranges:

    00100000 - 00400000
    004de000 - 1fff00000


    Computer Info:

    Athlon Xp 2600+
    512 (2x 256 Kingston Valuram) Ram
    Gefore 5200 fx
    1x 60g Boot drive
    1x 200g Sata Archive Drive
    Windows XP Pro SP2 + Patched to July 06
    Latest Direct X, Detonator and MoBo Drivers
  2. iss

    iss TechSpot Chancellor Posts: 1,994

    what brand and chipset is the mobo? Do you have the latest available bios? it is possible that it is a Mobo problem.
  3. Rathgar

    Rathgar TS Rookie Topic Starter

    Hi iss,

    Thanks for the quick reply.

    My motherboard is a Gigabyte 7N400 Pro, running bios update 11. There are some more bios updates above this one, but they seem to be more concered with things like Digital Camera compatibility and such.

    Bios message: GA-7N400 PRO F11

    If you think it's worth a shot, i'll definitely update to a newer version... and the funny thing is that problem with StrongDC is gone, but with iTunes remains.
  4. photonboy

    photonboy TS Rookie

    probable cause of "memory cannot be read errrors"

    I have the same error. It is fairly new and I'm pretty sure my system hardware is reliable. I too have run extensive tests.

    I'm almost positive that is software related. It could be an app or drivers. It could be something that was accidentally removed during an uninstall. It could even be damage caused by a virus. Unfortunately it is difficult to troubleshoot. It is extremely unlikely that is a BIOS problem.

    I highly recommend getting a program such as Acronis True Image that can backup your system. You can backup your current system in case you discover the problem. Before I do that I might uninstall as many applications that I think might be the problem (write them down) and see if the error is still there. Also, uninstall and reinstall ALL your drivers (especially system drivers). Also, try uninstalling your video drivers completely and dealing with the default ones for the time being (I'm not certain as to the reliability of add/remove when it comes to video drivers). Make sure to disable antivirus when installing drivers.

    I'm probably going to backup my crucial files and reinstall Windows XP Pro. I'll use Acronis True Image to make a snapshot once it is installed (even before my drivers are installed). I then will use an "incremental" backup every five programs or so which means I can jump to any point and get my system back quickly. This is far superior to Windows' System Restore which can't truly put you back to an EXACT copy of when you backed up your system. Make sure to write down on paper exactly which programs/drivers you are installing to easily keep track. Install programs that you trust most first to avoid jumping too far back when the error is finally discovered. Open and use ALL your main applications and try to induce the error. Write down all the applications that seem to trigger the problem. Focus on these when troubleshooting.

    My errors seemed to be triggered primarily by video related applications. VLC got the error and J River Media player even got a blue-screen which I know is related as it is all new. My errors started after a week of installing and uninstalling lots of apps. I also got some freezing of the screen.

    If you use a backup program, you should install most of your apps (except for large games) and make a backup of your Windows drive, preferably to DVD. Now you know that all you have to do is save your e-mail, Internet settings and other documents/pictures to another partition or disc (ie DVD+RW), restore our glitch free, virus free application.

    I've found that if you use Windows XP a lot (especially if you install and uninstall a lot of apps) you seem to end up with an error or something annoying that you just can't fix. Restoring to an earlier configuration via a Restore application is the way to go. You can start the process in one minute (after backing up files) and walk away. In usually 15 minutes to an hour you can walk back to a nice healthy system.

    I know this is long and doesn't exactly address your Memory problem specifically but this is my best advice after dealing with Windows extensively for several years. It can take less time to reinstall and backup a system then to spend hours reading posts and fooling around. Plus, a nice fresh install can often take care of other glitches you aren't aware of. I'm seriously debating defecting to Apple especially now that you can dual-boot with Windows depending on how Vista compares to the Mac OS by 2008.

    Good luck,


    PS, it has just occurred to me that Azureus (a bit client) is potentially suspect. It uses a large amount of RAM and such programs have been known to cause memory problems such as memory "leaking" which can induce the fault we're talking about. If you use a bit client definitely try uninstalling it (as well as most of your easily re-installed applications) before wasting time on a Backup application. However, I think most people should get a backup application. (Acronis True Image Home 9 or Workstation 9.1)

    Links: (see external links at bottom) (use filters, click on "rating", or "date")
    Other apps: Paragon Drive backup, Nero Image drive
  5. photonboy

    photonboy TS Rookie

    I just solved part (or maybe all) of my problem. VLC was malfunctioning, reinstallation would not work until I checked "delete preferences and cache" then it installed and ran without crashing. It was preventing Zoomplayer from using the Color Control and VLC crashed on start with the "...Memory cannot be read.." error. I've had these errors with other apps but it appears possible that VLC had screwed up a setting and had tied up something that other apps (primarily video related) needed.

    I hope that gives someone else ideas. I must emphasize that even though I uninstalled VLC and deleted the folder it did NOT solve my problem. Whatever change VLC had done needed to be undone the "delete preferences and cache."
  6. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    run memtest 86+ for at least 7 passes. Boot from a floppy or a cd rom
  7. Rathgar

    Rathgar TS Rookie Topic Starter

    Hi All,

    Thanks for all your feedback.

    Jeff, I'm pretty sure mine is a memory error because it was happening before my last install and started occuring, albeit in a different program, after my reinstall. Unfortunately i don't have any spare ram on me at the moment to test my suspicions.

    Tedster: I'm run memtest86 before for a couple of passes and got clean UNTIL i selected the "memtest ALL" .. so i'm suspecting that possibly my cache ram is bunged.

    In any case i'll run it a few times over night and see how i go.

    Thanks for all the feed back and idea's guys!


  8. digitcode

    digitcode TS Rookie

    I was just about to do a backup and reinstall because of that stupid error. My last shot has been to start to uninstall drivers and took away the wireless intel adapter driver and et voila! Problem solved.

    Hope it helps other people.

    Really did hate that memory cannot be read error.
  9. crodaddy

    crodaddy TS Rookie

    Memory errors possible solution

    I dont know what the error message actualy read for me but it was something like 0x6543232 cannot be close app kinda box. Similar to what the posts have been explaining.

    I have played a few Adobe Flash Player games on a site called

    I have had no problems ever with the memory errors on that site or even on my computer until i switched a slider in game. With the application open I right clicked and it gives you two options

    settings or about adobe flash player 9

    I clicked on the settings and it opened up and the middle tab called storage (looks like a folder)i clicked n the tab and their is a slider asking you how much information can store of your computer, well i slid it to unlimited and thats when i started having the error messages. I slide the slider back to where it was 100kb and havent had a lick of trouble since. Hopes this helps at least one of you.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...