Realtek AC'97 Audio for VIA Audio Controller

By 0shelly0 ยท 24 replies
Jan 5, 2007
  1. Hi
    I've been given an old PC with win98 so I'm fixing it up for some kids who can't afford a PC. I have reformatted the HD with win98 and everthing is working fine except for the sound. In the "Control Panel" under "Device Manager/PCI bus" there is an exclamation mark (!) next to "Realtek AC'97 Audio for VIA(R) Audio Controller". I have loaded DirectX 9 on to the PC hoping this would fix the problem but it hasn't. I've searched the net and also searched the Forums here for a fix but just can't find one. I have spent several hours trying to fix it so as you can imagine I'm getting to the end of my tether.
    Sound is important because I have loaded the computer with educational games and an Encyclopedia for the kids as they won't be connected to the net for financial reasons.
    If anyone can help me I will be so grateful and so will the kids as they are waiting patiently for their "New" computer.
  2. wolfram

    wolfram TechSpot Paladin Posts: 1,967   +9

    Hi & Welcome to TS!!

    You need to get the audio drivers from Realtek. Go to their website and download the AC'97 audio driver for Win 98.

    Regards :wave:
  3. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    You`ll need to find out what model the mobo is, then go to the mobo manufacturers website for the onboard sound drivers and any other mobo drivers.

    Regards Howard :wave: :wave:
  4. wolfram

    wolfram TechSpot Paladin Posts: 1,967   +9

    If you don't know your mobo's model, just click on the first link in Howard's signature.
  5. 0shelly0

    0shelly0 TS Rookie Topic Starter

    Done that

    Hi, thanks for your welcome and quick reply. I have already done that, that was the first thing I did but the exclamation mark is still there. I have removed it and Windows reinstalls it on startup. When I view the properties it says "Device Statis. This device is either not present, not working properly or does not have all the drivers installed. (Code 10)
    Try upgrading the device drivers for this device".
    So I have found another driver on called and tried to use that to upgrade but the message comes back telling me that the best driver is already loaded and won't allow me to change it.
    What other driver would the error message be referring to? Do you know?

  6. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Please give us the mobo model and we`ll see if we can find the correct drivers for you.

    Regards Howard :)

    Edit: Hey wolfram. Rather than us both posting more or less the same advice at the same time, I`ll let you you continue to help with this thread lol. Regards Howard :)
  7. wolfram

    wolfram TechSpot Paladin Posts: 1,967   +9

    Did you do that?
  8. sghiznaneck

    sghiznaneck TS Maniac Posts: 403

  9. 0shelly0

    0shelly0 TS Rookie Topic Starter

    The PC I'm trying to find the drivers for is not connected to the net it doesn't have a modem nor a network card so I'm having to do everthing second-hand so to speak.

    The mobo is Micro-star Model ms-5187 ver1.

    At first I searched to find the graphics card driver as it wasn't working properly, found the zip file for the mobo which fixed this issue. It also loaded Realtek drivers for the sound card and this is when the exclamation mark showed up. Previous to this there was no sound so I took it that no drivers were loaded for sound prior to this. I then downloaded the file from Realtek but this didn't fix the prob neither.

    I have now downloaded the suggested PC spec program so will transfer it to the other computer and run it so I can tell you more maybe.


    I have run the Everest program and under Multimedia it shows "Windows Audio and PCI / PnP Audio" under PCI / PnP Audio it shows "VIA AC'97 Audio Controller, MPU-401-compatible and Sound Blaster Pro".
    Does this shed any further light on things for any of you...I'm at a loss really!


    Yes thanks did this....please see other replies with more info.


    Okay Howard thanks for the heads up.
  10. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    I can`t seem to find the drivers on the MSI site.

    Maybe try You will need to register, but the drivers are free.

    Regards Howard :)
  11. 0shelly0

    0shelly0 TS Rookie Topic Starter

    Yes done that also

    Yes I did find the MSI driver, that is how I got the graphics card to work and that is when Realtek drivers were loaded...I got them off
  12. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    These are the correct drivers for Windows 98/98se and that southbridge/integrated sound:

    You may also wish to ensure you have the motherboard chipset drivers also correct from that same site (

    If the problem persists, make sure to see what the device manager lists as the problem with it. If it says ".. the drivers are not installed.." the above link should fix this (provided the northbridge and chipset drivers are installed correctly). If it says it's disabled, you may have to go into the BIOS and enable it. Lastly, if it says insufficient resources or there is a conflict, you may have to disable some hardware or shuffle cards. Win98 still has the IRQ limit and can be a pain to get combinations of hardware to configure if you have a lot of sharing.

    You can see IRQ allocation and sharing by right-clicking on "Computer" at the top of the Device Manager and selecting Properties. This will list the IRQ list and what's on them.
  13. 0shelly0

    0shelly0 TS Rookie Topic Starter

    error message

    Thanks for that but...I loaded it on and this is the error message I got so this may shine some light on the problem...but I'm affraid not for me.

    [ Error Starting Program

    The MSIEXEC.EXE file is linked to missing export MSI.DLL-222 ]

    I also went onto Viarena but couldn't find anything on the mobo chipset so am lost here too really.

    Any sugggestions?
  14. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    Hmmm.. is this a "legit" copy of windows? msiexec/msi.dll are part of the Microsoft Installer system that is standard with Windows 98/98se...

    Somehow these are missing/not-installed which is a primary symptom of a non-genuine copy of Windows (******/serialed version).

    If this is in error and you're sure it's genuine Windows, fire up Windows Update and obtain all the latest updates. There have been a few patches to the MSI installer.. perhaps it will fix-up your problem with the installer sub-system.
  15. 0shelly0

    0shelly0 TS Rookie Topic Starter

    Still no luck

    Yes it's definately a legitimate version of Win98SE.

    The MSIEXEC.EXE and MSI.DLL files were last modified on 26/01/02 so that would be the last update I guess.

    Looking at Computer Properties the IRQ setting 11 is shared by the following;
    - Realtek AC'97 Audio for VIA (R) Audio Controller
    - VIA Tech VT8501 Graphics Controller
    - IRQ Holder for PCI Steering
    Does this info help diagnose the problem?

    I don't know how to update the Chipset so if you could just give me the basics of what I need to do to fix this I'll be able to do that.

  16. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    Hi again Shelly,
    Sorry for the delay in response as I've been busy!

    I'm not entirely sure your Win98 installation can be trusted as it appears some basic core pieces of Win98 are having problems. This wasn't too uncommon with Win98 and Win98se as it had some issues that need resolution and a bit more difficult to get solid/right without a firm planning of hardware.

    It looks like you already have an IRQ conflict Graphics controller and Audio controller. The entries for "Steering" you can ignore- those are a placehold for each IRQ so most IRQ's should have two entries: a device + IRQ holder for Steering (most, not all). You may wish to enter the BIOS and disable any devices not used- such as spare serial ports or such. Sometimes ya gotta disable some things in hopes of shuffling IRQ's around for Win98. Happily, this is a thing of the past with XP. :)

    Your motherboard/system is long past it's end of life, you support will need to be home-brewed vs. looking to MSI. Luckily VIA Arena is a site for hardware junkies with old VIA based systems, which your system is VIA.

    Your system has the VIA MVP4 northbridge and VIA VT82C686A Southbridge. There are fixed/patched drivers that have been worked on since MSI stopped supporting your board.

    Unfortunately, it's important to do several things first with Win98- such as isolate and fix all IRQ conflicts first, then install the OS, then some very important OS critical fixes, then the chipset (northbridge) drivers.. from there, south bridge drivers- then drivers for all your add-on hardware or cards (if any). If you haven't done too much work already, you may wish to consider fdisk/format and starting over as it may yield better success. You can use your basic install NOW though to isolate and fix IRQ problems.

    If I were in your shoes, I'd do the following:
    1) Use the Win98 now to get all IRQ conflicts handled. VIsit the BIOS and see what you can disable. COM2 usually comes to mind, and possibly COM1 if they have no modem, serial mice (not usb) or other serial devices.
    2) Once all conflicts are cleared/no shared IRQ's (and BIOS has been triple checked for enable/disable of devices you wish to use and wish to disable) you can then format/wipe out and re-install Windows 98 se.
    3) Once Win98se is installed, the FIRST thing you need to do is apply the IDE Cache fix. Without this fix, just about every time you are asked to restart your computer or shutdown, you're likely corrupting data on your disk lol (BIG screw-up on Microsoft's part):
    4) You then install Winzip (floppy or cd) so you can perform the Chipset 4-in-1's. I recommend the 4.43's found here:
    5) If you are using the integrated motherboard video, it should be the KPLE MVP4, which you can get the drivers here:
    If you are using a 3rd party AGP card, you can skip this for now and complete after everything else. It's also important if using a 3rd party AGP card you have the integrated video disabled in the BIOS or by motherboard jumper.
    6) Obtain the VIA Audio drivers here:

    If you are encountering problems AFTER the northbridge/4-in-1 driver install, you can patch your MSI Installer here:

    If you are having difficulty getting Windows Update or other components of IE working properly, you can update your IE for Win98 here:

    Good luck!
  17. 0shelly0

    0shelly0 TS Rookie Topic Starter

    Thanks heaps for your help

    Thanks heaps, I've done a re-format again and will try the things you have suggested and if all else fails I'll throw a sledge hammer through, probably should have done that in the beginning. Anyway I'll let you know how I get on.

    Cheers to you and all the others who made suggestions.
  18. tweakboy

    tweakboy TS Guru Posts: 467

    proper mobo drivers,, enable audio onboard in BIOS,, gl,
  19. laterunner

    laterunner Banned

    I'm suffering the similar problems with the loss of sound &
    Realtek AC97 audio for VIA (R) audio controller not seemingly doing it's job.Lost Sound .'
    Downloaded Driver for updating the sound driver as it was dated. But hadn't removed previous one. Removed that & once again downloaded the
    Realtex Ac'97 Audio for VIA (R) Audio Controller. as the suggested replacement.
    'System model' VT8367-8235
    On 'Device man'. there is a yellow query on that ''Realtex Controller.'' in ''sound etc etc .
    It is in my ''System Info.''
    In ''sound etc'' in 'Control panel' there is no sound device -->
    ''? Direct sound missing- not detected.'' Code 10.
    This is now not greyed-out but still no sound
    My computer spec's Win. 2002 XP home. Service Pack 2.
    AMD Athlon (tm) 2200.
    Pentium 3.
    Cache. 256 K12.
    Mem.- 512 MB RAM.
    Processed speed. 1798 MNZ.
    Graphic Card. 'Saphire Radeon 9600 -256MB. Series ACP.
    Hard Drive. 50GB.
    Modem. 56k Soft V 92.
    Version. 5.1.2600.
    I Removed Realtex.
    --'no hardware found'' in the wizard.??
    'Device Man.' has two yellow question mark next after the 'Network Device' on 'Other Devices' & 'Multimadia Controller'
    Microsoft says that 'VIA AC'97 Audio Controller' is somewhere
    Yellow ? on ''other devises'' & ''multi media controller''
    Seems realtek is not signed by Microsoft ????

    System Model
    Windows XP Home Edition Service Pack 2 (build 2600)*
    VIA Technologies, Inc. VT8367-8235
    Enclosure Type: Desktop
    Processor a*
    Main Circuit Board b
    1.80 gigahertz AMD Athlon XP
    128 kilobyte primary memory cache
    256 kilobyte secondary memory cache*
    Board: VT8367-8235
    Bus Clock: 133 megahertz
    BIOS: Phoenix Technologies, LTD 6.00 PG 09/22/2003

    Memory Modules c,d
    80.02 Gigabytes Usable Hard Drive Capacity
    52.98 Gigabytes Hard Drive Free Space

    HL-DT-ST RW/DVD GCC-4521B [CD-ROM drive]
    3.5" format removeable media [Floppy drive]

    WDC WD800BB-22DKA0 [Hard drive] (80.03 GB) -- drive 0, s/n WD-WCAHL6414146, rev 77.07W77, SMART Status: Healthy
    512 Megabytes Installed Memory
    Slot 'A0' is Empty
    Slot 'A1' has 512 MB
    Slot 'A2' is Empty
    Local Drive Volumes

    c: (NTFS on drive 0)
    80.02 GB
    52.98 GB free
    Network Drives

    None detected
    Users (mouse over user name for details)
    Standard floppy disk controller
    Primary IDE Channel [Controller]
    Secondary IDE Channel [Controller]
    VIA Bus Master IDE Controller - 0571
    SAPPHIRE RADEON 9600 ATLANTIS [Display adapter]
    SAPPHIRE RADEON 9600 ATLANTIS - Secondary [Display adapter]
    TAR LCD19-4 [Monitor] (19.1"vis, s/n C79632007758, August 2006)
    Bus Adapters
    Standard Enhanced PCI to USB Host Controller
    VIA Rev 5 or later USB Universal Host Controller (3x)
    Unimodem Half-Duplex Audio Device
    VIA AC'97 Audio Controller (WDM) (2x)
    Other Devices
    PCI SoftV92 Speakerphone Modem
    VIA Rhine II Fast Ethernet Adapter
    ZyXEL USB ADSL WAN Adapter
    Networking Dns Servers:*
    ZyXEL USB ADSL Device
    USB Human Interface Device (2x)
    CanoScan LiDE 30/N1240U
    Serial Cable using IrDA Protocol [Infrared]
    HID Keyboard Device
    USB Browser Mouse
    Generic USB Hub (2x)
    USB Printing Support
    USB Root Hub (4x)
    Virus Protection [Back to Top]
    All required security hotfixes (using the 04/08/2008 Microsoft Security Bulletin Summary) have been installed.
  20. rf6647

    rf6647 TS Maniac Posts: 829

    ToonPal used this method
    for a similar problem with ac97 audio drivers. Drivers worked in a fresh install of XP, but there was no audio when re-installed in a working copy of XP. This situation involved differing flavors of the ac97 audio drivers. The method used tracked down all the software programs listed in the device driver list for the audio. He deleted a legacy file being used by the new drivers.
  21. tweakboy

    tweakboy TS Guru Posts: 467

    Do yourself a favor and get dedicated sound card. A onboard one uses CPU processor and slows down your games..... have fun!
  22. laterunner

    laterunner Banned

    Thanks but just to remind you I'm a silversurfing novice.

    Simple English please.!!!
    Where from ?
    What is Dedicated?
  23. laterunner

    laterunner Banned

    I've now reinstalled that Realtek AC'97 & still have the yellow quiery in Device Man..
  24. laterunner

    laterunner Banned

    ><> ><> Now I have it insalled but no sound.:grinthumb :mad:
    Help me p- l- e- a- s -e
  25. rf6647

    rf6647 TS Maniac Posts: 829

    Common replies for this problem:
    1. Rollback the drivers
    2. Do a System Restore to the point before updating drivers.
    3. Obtain drivers from the manufacturer of the mobo. (as posted on the Realtek site).

    Use Google: realtek ac97 no sound VT8367-8235

    Here is one result that references your mobo at another forum.

    Google: VT8367-8235 --- I did not detect a manufacturer site listed (first 10 results). Not a good sign. Via Technologies perhaps?

    For this topic, most posts run out of gas, just as this one has in the past.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...