Replacing a hard disk in a Toshiba Tecra S1

Not open for further replies.
I've got a Toshiba Tecra S1. In the last 2 years the hard disk has failed (bearings) 4 times. The laptop is just out of warranty so I bought a 40Gb Seagate (deciding the Toshiba disks are doubtful). I used the "product recovery" Cds to re-install the OS etc on the new seagate. Everything went fine until the end. After the new os had been installed a message comes up "Remove all disks and press any key". I did this the screen blanks, up comes the Toshiba splash screen, it clears, then nothing! just a cursor flashing in the top left. This sort of procedure at boot up suggests a self test failure, does any know if Toshiba laptops will only work with Toshiba disks.
I checked the disk by connecting to anoth PC using a usb adapter and it looks fine, all the OS seems installed, all the right directory structure. Obviously there is no fault with the disk or the Toshiba laptop (as the product recovery CDs managed to access the new disk to install the OS). I checked the BIOS and loaded "default" to be sure. The Bios can see the new disk. I'm lost for a solution, can anyone help?


Posts: 6,450   +3
Check that disk using e.g. Partition Magic. You probably did not set the first partition 'active' , so the PC does not know that there is a bootable HD in it.
Thanks for the reply, I'll buy you a Guinness if you can help sortout this one, a crate even!
After using the recovery CDs from Toshiba I took the disk out, installed it a USB external casing and had a look at it on another PC. The disk shows up as 'active' (as opposed to 'system' as you'd expect for the other PCs main disk). I had a look at the boot.ini file and that looks OK too.
As mentioned before, the 'recovery procedure went fine, the disk was recognised and the whole procedure went fine without a hitch - just at that point when it says "Remove all disks - meaning the CDs - and press any key". Its at that point that things fall over. I just get the Toshiba splash screen then nothing. Its obviously failing the hardware check, but why. If the recovery procedure can find the disk and istall the whole OS why is it failing? To be honest mate, it's got me buggered.. :cool: :cool:


Posts: 5,451   +7
If it manages to get to booting from the CD then it obviously passes all the hardware tests. The fact that it hangs when staring to boot from the HD means there is something wrong with the bootloader installed there. You could try getting your hands on a real Windows CD and fix the bootsector with that.

Laptop makers have the habit of setting up a hidden partition for their own tools resulting in a weird partition table. What happens if you install a clean Windows, not the one from the recovery CDs?
I don't think its even getting as far as the bootloader, I'd expect at least some error message if that was the problem. I ead the Toshiba manual regarding 'nothing' after the splash screen and they just said the hardware check had failed (very informative). I actually tried what you suggested, insatlling from a generic windows XP disk, got all the usual stuff of loading 1001 drivers etc that won't be needed, just at the point when it says "starting windows" (at this point it hasn't tried to access the disk, just stastarting windows from the CD, I get the 'blue screen' saying it had shut down to protect my PC, failed to initialise the hardware. This isn't the correct message, I'm just working from memory but you get the idea...This makes me think that there may be something on a Toshiba laptop and their disks that's not quite conventional, generic windows is making a call through the Toshiba hardware that is not 100 kosher.
Any suggestions are VERY appreciated!


Posts: 6,450   +3
Did you put the jumper on the HD back to MASTER? Also try without jumper if that does not work.
I just had a similar problem yesterday, when I put together a PC from old components.
The HD in question was originally set to Slave in a 2-disk PC. Putting it in as a single Master HD refused to work, until I took the jumper off alltogether.
Thanks, again. I doubled checked the jumper setting after reading your email against the online manual for the drive, the drive is as it should be with no jumper installed for a master drive. Just had an email from Toshiba tech support who said "maybe the seagate isn't compatible", they only recommend Toshiba, Hitachi and IBM drives. I've pointed out to them that 1. The drive appears in the Bios and 2. Their recovery software partitions, formats and then installs XP on to the disk. By my reckoning if it gets through all that it must be compatible, but, re your earlier point, perhaps something in the bootloader is amiss. Hmmm - I don't really want to go and get another (Toshiba/Hitachi/IBM) drive to only have this problem reappear!
Your help is much appreciated by the way coz I'm completely out of ideas!


Posts: 6,450   +3
Some BIOS settings to try for the HD:
automatic discovery of HD by BIOS
manual (User) settings of HD
LBA support or
NORMAL support if that is an older laptop.
Format FAT32 or NTFS (depending on OS)

Did you try Nodsu's suggestion with a 'normal' Windows CD?
Well, finally fixed it!!!

A bit of a scruffy solution but it worked. When I bought the new disk it wasn't recognised by the Toshiba at all so I put it in an external USB 2 enclosure and accessed it on another laptop (a compaq) and used the disk manager to partition and format the disk. When I returned the disk to the Toshiba it was recognised by the BIOS etc, as explained before, and I could run the Toshiba disk recovery cd on it OK, just wouldn't boot.
After all these troubles I suspected maybe the original format on the compaq may be responsible, not that there was anything wrong with it but perhaps the Toshiba thought the disk was formatted to its liking but wasn't really. Anyway I went to the Seagate site and downloaded their disk manager software as an iso file, burnt it to a cd and booted the Toshiba off that. I used the utility to scrub the new seagate back to "off the shelf", no formatting, just partitioned.
When I re-ran the Toshiba recovery software it took a good couple of minutes to format the disk (in the past it took only seconds) so it was really doing a "Toshiba format" and not accepting the compaq one, when it finished the whole system came up as new!!!!
So I guess Toshiba formatting is a little different after all and is in fact doing some funny stuff either with the disk recognition system or the boot loader.

Thanks for all you help, its still worth a few Guinness tho' let me know and I'll send you a few through an oline store!

Regards, Rob :giddy:


Posts: 6,450   +3
Thanks, I appreciate the gesture.
Glad you got it sorted, albeit indeed in a weird way!

PS: with all the 'proffered' black stuff I could probably sponsor a pop concert, and still have some Guinness left afterwards!
Not open for further replies.