SATA drive only boots in IDE mode

By juergeninpgh ยท 6 replies
Feb 23, 2011
Post New Reply
  1. I installed a SataIII drive on an Asus M4A88TD-V Evo board with win XPsp2 OS. Since I only have Xp service pack 1 on cd the install of the drive on the new board failed (xp setup did not work although I had the new drive -as the board manufacturer suggests- on Sata5/6 in IDE mode) and I detoured by installing the drive first on the old machine, installing the raid driver during setup, updating xp to service pack two and then moving the drive to the new board/machine updating the drivers for the board (what a pain)

    During boot up, I see a message saying: searching for devices: no device found if that means anything.

    Now XP boots fine with the velociraptor in IDE mode on SATA connectors 5/6 but poops out in AHCI mode or in IDE mode on Sata connectors 1-4 .

    My questions are: is there a fix without re-installing the whole caboodle and b) if I run the 100000 rpm drive in IDE, am I loosing speed or just the hotswap capabilities?

    PS: Two days later, I am running win 7 but still have issues.

    Thank you!
  2. superty12

    superty12 TS Enthusiast Posts: 413

    What company made the drive?
  3. juergeninpgh

    juergeninpgh TS Rookie Topic Starter

    It is a Western Digital Velociraptor 600 GB / Sata III / 32 MB Cache

    In the meantime, I got tired of the issues with Win XP and upgraded to win7. This time, I was able to install it right on the new configuration with the asus board and on the WD drive. There was no need to load raid drivers as they come with win7 I guess. I updated win7 to service pack one which was just released. I still can't set the bios to AHCI mode and during post, the message still is no devices after the bios scans for devices. The drive is recognized as SATA drive in the bios though...
  4. superty12

    superty12 TS Enthusiast Posts: 413

    If I understand the information correctly, you need to switch it to AHCI and reinstall Windows 7.
  5. juergeninpgh

    juergeninpgh TS Rookie Topic Starter

    I thought that may be the solution, although the Asus manual suggests to set the bios to IDE so that the board can recognize the sata drive. Thank you for your response!
  6. captaincranky

    captaincranky TechSpot Addict Posts: 12,754   +2,429

    The following links show how to change the HDD mode from IDE to AHCI without reinstalling the OS; and one directly from M$; (They'll even do it for you, or so they say).

    You sound like you enjoy tinkering a bit, so I just thought I'd mention it. One of our members found this solution in response to the exact situation being discussed here. This was allegedly a rousing success, although I've never tried this personally.

    I suppose the worst result is that you'd have to reinstall Windows. But hey, we're already there, right?
  7. juergeninpgh

    juergeninpgh TS Rookie Topic Starter

    Thank you!!!

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...