1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

SATA Drive problems

By yjkader ยท 10 replies
Nov 29, 2006
  1. G'day ladies and gentlemen,

    I got a new PC for free awhile ago, and have a problem with Serial ATA, specs are as follows:

    -P4 2.8ghz
    -1Gb of RAM
    - Nvidia GF 7600GS
    -SB Live! SC
    1x 80GB Maxtor IDE
    1x 80GB Maxtor SATA
    - Win XP SP2
    The problem is that the SATA HD works at free will, 90% of the times when I boot up my computer, the SATA HD doesn't work, I have to turn the PC off and back on in order for it to work, power isn't a problem I believe(400W PSU), and once it works it works like a charm.
    It's currently on SATA bus 0 (I only have 2 SATA ports, tried both) I had my OS on the SATA drive, however to reduce headache I placed my OS on the IDE drive for the time being, I have no idea what could possibly be faulty, the IDE has always worked like a charm, and I don't know what to blame the mobo or the HDD. Sad part is i don't have another SATA HDD to try it out, i have reset my bios settings already, problem wasn't solved.
    Any ideas?
  2. Nodsu

    Nodsu TS Rookie Posts: 5,452   +7

    Try disabling quick boot or configuring the hard drive delay option in BIOS.
  3. yjkader

    yjkader TS Rookie Topic Starter

    So I've disabled quick boot and set a 3sec pre-delay, still out of luck.
    Any other ideas?
  4. Rik

    Rik Banned Posts: 3,679

    Give the cables in the back of the sata drive a bit of a wiggle and see if that helps!!!!
  5. mailpup

    mailpup TS Special Forces Posts: 7,412   +629

    Perhaps you need to reinstall the motherboard's SATA/RAID drivers.
  6. Tedster

    Tedster Techspot old timer..... Posts: 5,746   +14

    If it works sometimes, it sounds like something is not connected good enough. Reseat your cables and/or replace them, reseat any controller cards (if any). If using a controller card, use a pencil eraser and gently rub the contacts a few times on the card to remove oxidation. Then reseat the card.
  7. yjkader

    yjkader TS Rookie Topic Starter

    The mobo has onboard SATA ports and I'm using that, I've tried reseating, swapping over and tried both SATA ports on the mobo, same results.
    More details on this?

  8. owenlitniel

    owenlitniel TS Rookie

    Hello! how can i unlock a Dell D 600 that is proword protected?
  9. mailpup

    mailpup TS Special Forces Posts: 7,412   +629

    yjkader, if you check the Device Manager and under IDE ATA/ATAPI controllers see if any controllers have a yellow symbol next to it, for sure you are having a driver problem. However, if all seems well, a reinstall of the SATA/RAID controller drivers might not be necessary but I was suggesting it under the category of "It can't hurt to try."
  10. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,552   +437

    Dell BIOS Password Removal
  11. yjkader

    yjkader TS Rookie Topic Starter

    I double-checked the IDE ATA/ATAPI controllers which seemed fine, and did check the SATA/RAID controller which also didn't have a yellow symbol, however with the SATA/RAID controller even though it didn't have a yellow q mark on it, I noticed that there actually wasn't a driver provided for it, so I downloaded the driver from the Intel website and placed it onto a floppy disk, placed my windows xp sp2 CD into my drive and booted, (during boot pressed F6). I installed the driver from the floppy. When I got back into Windows, now there was a yellow q mark on the SATA/RAID driver in Device Manager, so I clicked on Update Driver, and returned to the old driver without a Q mark, however no driver provided (driver date, driver version etc).
    I also figured that my SATA drive isn't functioning at all now, I've tried formatting it and it says the drive is corrupt or the SATA controller isn't installed, this was happening just before I did all this however. Before I was leaning towards that the mobo was at fault, now I don't know to blame the drive or mobo, or sadly both. I'm only working on my IDE 80GB which isn't enough, only have 500mb left dammit, I'm thinking of getting those SATA to IDE convertor for my HDD, which might solve the prob if the mobo is at fault.

Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...