SATA Drive (Seagate ST3120026AS) not recogonized after reboot

By midnightraver ยท 4 replies
Oct 29, 2003
  1. I've been working with Seagate tech support to try to get my 120GB SATA drive to work correctly. The drive is a Seagate ST3120026AS SATA drive connected to a Chaintech 9VJL5 mobo with onboard SATA controller.

    The problem is that the drive is only detected when the system is booting from a hard power off. If you ctl-alt-del the system, hit the restet switch or reboot via Win-XP shutdown command the drive is not detected. As soon as you power off and power on the system the drive detects.

    I'm starting to suspect a mobo problem since the PS/2 mouse port failed a couple of days after I installed the board and started using it.

    I figure this has to be a problem at the hardware or BIOS level since the OS doesn't necessarily have to be invoked to see the problem at work.

    I've tried tweaking every setting imaginable in the bios including disabling quick self testing, changing SATA mode from IDE to RAID and back, removing all other devices from the system except the SATA drive and video card, etc. I've been through all the BIOS settings that would apply to power cycling the machine, the SATA controller and the IDE controllers. I've checked Chaintechs website and loaded the latest BIOS (9/30/2003).

    Seagate tech support seems very responsive but their advice has been time consuming and has not solved the problem. Chaintech's tech support has not responded (72 hours and counting) with so much as an automated reply. I've spent hours scouring the internet for a similar problem, but I haven't seen anything.

    Any suggestions would be appreciated.
  2. Nic

    Nic TechSpot Paladin Posts: 1,549

    Have you checked for bios updates for your mainboard?
    It does sound like a mobo problem.
  3. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Is there a SATA BIOS loading sequence after the POST ?

    Sometimes that BIOS will fail to load on a reboot.

    I can't seem to find your mainboard on the Chaintech website. The closest seems to be the 7VJL, but there are different versions of that one. The different versions have different chipsets ( kt333/kt400 ) so I think it matters to know exactly which one before looking for info.;)

    Which one is yours ?

    PS. Welcome to TechSpot. Hope you enjoy your stay. :wave:

    Are we gonna have to start reminding everyone to completely read all previous posts ( especially the opening post ) ???
  4. Nic

    Nic TechSpot Paladin Posts: 1,549

    Re: Re: SATA Drive (Seagate ST3120026AS) not recogonized after reboot

    No. I was in a hurry (busy) and skimmed through his post. Sorry ... :)
  5. midnightraver

    midnightraver TS Rookie Topic Starter

    :eek: Thanks for all the responses - wow!

    Much to my embarassment I found the problem! The BIOS has 2 settings for the SATA devices - one for Enabled/Disabled and the other for RAID/IDE. As I only had one drive installed I assumed that I would need to set the mode setting to IDE. I switch the setting to RAID and everything works great.

    Thumbs down to Chaintech tech support though, they have yet to responde to any of my requests.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...