SATA not recognized after PSU change?

By GossamerS
Jan 18, 2009
  1. Hi All -

    Confident a PSU had died on me (again), I replaced it with a Zalman ZM600. OK Cool. Only disconnected power sources and the SATA connection to move around a little easier.

    Reconnected everything back up, and the drive is not recognized in the BIOS cuz it doesn't seem to be spinning up - at all. Tried two different connectors from two different SATA ports on the MOBO (I still have two available to try). No other drives connected except DVD-ROM drive via IDE channel. Even tried booting with IDE disconnected, but the boot order is still HD first, CD/DVD rom second. Cables on back of Zalman are firmly connected, and even tried using the extra SATA cable to verify. All fans spin up fine and get through BIOS and HW check - just no HD to boot from. CD/DVD-ROM is recognized and powers up.

    SATA is a Seagate. Machine is custom. I have a second Vista Boot HD that also used to work, but is also not getting juice. Both drives are not connected at once. Please tell me I'm missing something really stupid. :S


Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...