1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Screen goes black when playing games

By Jelle ยท 4 replies
Mar 6, 2009
  1. After trying all possible things I could think of I sill have the same problem.
    Every game (The Witcher, Need 4 Speed) I 've tried so far results in black frames.
    The games start ok but just after I start playing the screen goes black but the ingame music keeps playing. If I don't move my keyboard and mouse I'll get some visible frame's back. Usually just enough to be able to quit the game. System does not lockup or something. No blue screens either. All other software (Windows 7 & Vista ,Photoshop, Open Office, etc) behave normally.

    I have got a brand new system (just 1 week old when writing this) to play around with.

    Coolermaster CM690
    Core i7 920
    Club3d ATI 4850 512mb
    MSI X58 PRO
    OCZ 1Gb 12800 (1600) triple channel kit (3Gb total)
    Antec Earthwatts 650w
    Samsung spinpoint F1 640Gb

    Things I've tried so far:

    Firstly I Installed Windows 7 (Beta 64bit) and the ATI Catalyst drivers for windows 7 (Beta 64bit). Uninstalled Catalyst Beta and installed Catalyst 9.2 And updated everyting i could think of. No solution there.

    Then I started all over again this time round using Vista Ultimate. No solution there either.

    Is there somting I've missed or do I have to replace defective harware?
  2. redk

    redk TS Rookie Posts: 91

    Did you try using an older driver? I had a similar issue with Windows 7 x64 7048 not playing games with Cat 9.2 installed. I ended up going back to Cat 9.1, and everything works perfectly.
  3. Jelle

    Jelle TS Rookie Topic Starter

    Haven't tried 9.1 , just the Beta and 9.2
    I've uninstalled Windows 7so ill try using 9.1 on Vista, Il let you know in a minute.
  4. Jelle

    Jelle TS Rookie Topic Starter

    Tried Catayst 9.1 , still the same problem unfortunately.
  5. mrtraver

    mrtraver TS Evangelist Posts: 409   +116


    Have you tried reinstalling the appropriate version fo DirectX? I don't know if these are DX10 games or not, but I just read today on TechARP about DirectX 9 corrupting DX10, and reinstalling DX10 correcting the issues.

    Good luck!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...