secondary hard disk drive 0 not found on a dell laptop what do I do?

Aug 12, 2006
  1. I have a dell inspirion 9100 and I just recently installed a new dvd-ram drive because the old dvd-rw died...
    I have a pioneer dvr-k16 and when I boot up it stalls for like 30 seconds now and then flashes "secondary hard disk drive 0 not found". Windows starts up like normal and my drive works, although I've only watched movies so far and haven't tried burning anything. How do I get the error message to go away? I've tried going into setup and that doesn't seem to help anything because I don't know what to do in there. I keep reading on other threads that you have to change the slave to cs or something like that but I have no clue as to how to do any of that or if that would even alleviate my situation. Maybe just a dirty computer? I do have two cats :) and I have fur balls floating all over the place that I can't seem to get rid of...that's a whole seperate issue of course. HELP?
  2. Rik

    Rik Banned Posts: 3,814

    The bios in your laptop was set up to use your old drive, the specs on your new drive will be different.

    First off, have a look at the drive you took out to see if it was set to master, slave, or cable select. To do this, have a look at the back end of the drive near the connector for the jumper setting, then make sure your new drive is set the same.

    Then you need to go into the bios and look for any options to scan for hard drives (this will scan for optical drives too). You need to make sure its set to your new drive and not your old one.

    If you don't know how to do any of this the your manual will help, if you don't have it you can probably download one from dell.

    If you still have problems then let me know and i will do my best to help further.
  3. bluem

    bluem TS Rookie

    maybe you can help since I am having similar problem, but now I am longer able to boot my PC here is my situation...

    here is detailed explanation of how the problem started...

    System Spec:
    P3, Windows XP Pro, Floppy, CD-RW in one bay, and DVD-RW in another bay, about 700 MB of RAM in memory or something close to it.

    Problem Details and History:

    One time I restarted my PC and I got the error messages below
    "Secondary Hard Drive 0 not Found"
    "Secondary Hard Drive 1 not Found"
    "Press F1 to Continue or F2 to enter Setup".

    I hit F1 and the PC rebooted ok with no problems. This happened a few weeks back. Today I was working on my PC and it locked up on me so I had to do a hard reboot and when I restarted again I got the same error messages listed above, I hit F1 then I got to a screen which gives me the following options:

    1-Safe Mode
    2-Safe Mode with Networking
    3-Dos Prompt or something smilar to that
    4-(Last Good Known Configuation)
    5-Start Windows Normally

    I selected the option to Start Windows Normally, but I got the same error messages about Secodary Hard Drive 0 and Secondary Hard Drive 1 not Found (same as above error messages) and after I hit F1 it came to same menu options and I selected Start Windows Normally, and the PC kept going into the same loop.

    After I got tired of it I clicked on F2 and went into the Startup options. On my Startup Screen I have the following selected
    Drive 0: Auto EDIE DRIVE 65535
    Drive 1: None

    Drive 0: None
    Drive 1: None

    Boot Sequence: Diskette First

    I went ahead and changed the Secondary options above for Drive 0 and Drive 1 to Auto. Restarted the PC and this time I did not get the error messages. Instead the PC brought me into the menu options I listed above and when I select Start Windows Normally, it goes into the same loop and gives me the menu options again. I even select Safe Mode, Safe Mode with networking, Last known good configuration and that kepts bringing me to the same menu.

    Since the error messages were pointing to Secondary Drive I thought the problem might be with my CD-RW and DVR-RW drives, and maybe something is wrong with cable that I have running from the motherboard to both drives, so I went ahead and purchased a new Dual Internal Cable which I plugged one side to the mother board and one end to the CD-RW and the second end to the DVD-RW. I restarted the PC and went into Startup option and found that the Secondary was showing the options:
    Drive 0: Auto CD-ROM Device
    Drive 1: Auto CD-ROM Device

    I restart the PC again to see if that will fix the proble, but again I got the same menu options listed above and selected the option to Start Windows Normally, but my PC kept going into the loop with the menu options.

    Is there something wrong with my harddrive, motherboard...or is it something else? Also, I tried to insert a bootable CD-ROM into each drive, but I could not get the PC to boot to the CD.

    Can someone please help....

  4. guggyd

    guggyd TS Rookie

    Same Problem + Help Rik

    I have got the same problem as posted by JLN.
    i tried to do what u wrote , but there is a problem. My Cd drive is TEAC DW224-E and it has no option ( jumpers ) to make it slave , master or cable select on the drive . What should i do ? Please help
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...