1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Sony Vaio PCG-7192L: Getting unidentified network, no connection to internet

By techchill ยท 13 replies
Oct 4, 2018
Post New Reply
  1. Sony Vaio PCG-7192L: Getting unidentified network, no connection to internet, yellow triangle and exclamation mark. My other Sony desktop and Toshiba tablet are able to get internet, so it is not the router or modem. I was advised that it could be the driver. I don't know what to do. Could someone guide me on how to get to the internet? Thanks
     
  2. Gabriel Pike

    Gabriel Pike TS Booster Posts: 142   +33

    Going to start with the basics. Wired or wireless? Can you connect elsewhere?
     
  3. jobeard

    jobeard TS Ambassador Posts: 12,368   +1,390

    The YELLOW triangle is telling you that the driver is wrong and needs an update
     
  4. Gabriel Pike

    Gabriel Pike TS Booster Posts: 142   +33

    Is the yellow triangle in the taskbar on your network icon or in the devices menu in device manager?
     
  5. techchill

    techchill TS Rookie Topic Starter

    When my laptop was using the wireless, it says the wireless signal was excellent but no internet connection. I was advised to connect the laptop to the modem using the Ethernet cable, I did that and I was able to connect to the internet.

    My wireless seems to work because I have 2 other systems that are able to connect to the wireless and connect to the internet. So it is not the router at all per my ISP suggested so.

    I updated the latest version of the adapter device, and that still doesn't work.

    ---------
    The system had been scanned using Windows Defender, Webroot, and Malwarebytes.

    Uninstalled driver and rebooted several times but still not able to connect to the network.

    It gets the signal from the WiFi but no internet connection.There is no yellow triangle on the network adapter from Device Manager, so I think it is not corrupt?

    I think it has to do with the DNS Suffix. For testing, how would I set this DNS suffix from ipconfig?

    If I am not hard coding the ip addresses, then ipconfig should list the DNS suffix and the default gateway.

    ------

    In the command prompt window that opens, type the following commands, each followed by the Enter key:

    Reset WINSOCK entries to installation defaults: netsh winsock reset catalog

    Reset IPv4 TCP/IP stack to installation defaults. netsh int ipv4 reset reset.log

    Reset IPv6 TCP/IP stack to installation defaults. netsh int ipv6 reset reset.log
    ------

    IPCONFIG /RENEW

    I got the following error:
    An error occurred while renewing interface Local Area Connection : A device attached to the system is not functioning.

    --------

    None of the suggestions specified here worked. The laptop is getting internet when using the Ethernet cable connected directly to the modem. It's not the router because the other systems are able to get internet.

    The yellow triangle is at the taskbar not at the network adapter from Device Manager.

    Error......A device attached to the system is not functioning. Would this be the network adapter not functioning?

    What do you think the problem is with my laptop?
     
    Last edited: Nov 6, 2018
  6. Gabriel Pike

    Gabriel Pike TS Booster Posts: 142   +33

    Yes. It looks like your wireless card has malfunctioned. A USB dongle would be your cheap fix.
     
  7. techchill

    techchill TS Rookie Topic Starter

    I took my laptop to the computer repair shop and was advised that the wireless card doesn't have to be replaced. They did some testing by using their USB dongle and it did the same. Both were able to get to the router but wouldn't connect to the internet. They said the issue is either the configuration or the settings. Would you list the required settings or configuration that would let the laptop reach the internet?


    Thanks
     
  8. Gabriel Pike

    Gabriel Pike TS Booster Posts: 142   +33

    As long as the NIC is in DHCP mode that is all that is normally required for settings.
     
  9. Gabriel Pike

    Gabriel Pike TS Booster Posts: 142   +33

  10. techchill

    techchill TS Rookie Topic Starter

    Oh no what happened to my previous reply.

    I checked that step several times in the past and even used specific addresses. Any other places to check? I have Windows 7.

    To Moderator Could I have my previous reply shown on this thread? I didn't save the URL link. Was it considered a spam post?
     
  11. Gabriel Pike

    Gabriel Pike TS Booster Posts: 142   +33

    Not that I can think of. @jobeard Do you have any other ideas?
     
  12. jobeard

    jobeard TS Ambassador Posts: 12,368   +1,390

    WiFi connection ok but still no Internet is typical of a DNS config error.

    Go to the WiFi adaptor and manually insert
    DNS 1.1.1.1 and a secondary of 8.8.8.8
     
  13. jobeard

    jobeard TS Ambassador Posts: 12,368   +1,390

    The two critical tests for Internet access are:
    1. ping 8.8.8.8
    2. ping yahoo.com
    (1) tests access to your ISP and any other IP address
    (2) tests your DNS to produce an IP address given a domain name

    BOTH must work for your browser to function correctly.
     
  14. techchill

    techchill TS Rookie Topic Starter

    It was able to ping 8.8.8.8 but not yahoo.com after adding the settings of 8.8.8.8 and 1.1.1.1

    The 'Connection-specific DNS Suffix' is blank on the laptop but the desktop has for instance 'ab.cd.net'; this must be the ISP DNS name. The desktop can get to the internet.

    How would set this parameter 'Connection-specific DNS Suffix' to the ISP DNS name?
     

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...