Spread the love! TechSpot Tech Gift Shortlist 2017

System instability, freezes and BSODs

By Klohgloh ยท 14 replies
Mar 17, 2008
  1. Hi,

    My problem is quite difficult to describe - i was experiencing many types of STOP errors (*) on my XP Home so i eventually decided to reinstall the system. Everything was going well with no problems, but only for one or two days! Then, the same BSODs slowly started to show again. The System Restore tool helped when i "returned" just after the reinstall (but again just for few days). The system also freezes often (with no error report) - and this happens in random operation, even when doing nothing. Well i post the three last minidump files so if someone can have a look on them ...

    (*) Just to mention the most common STOP errors, they were the following: 0x7F 0x8E 0x0A 0x50 0xD1 but i don't have their minidumps anymore :-/

    Any help would be much appreciated, thanks
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    It was not possible to read any of your minidumps. With such unreadable dumps along with such varied errors I suspect corrupted memory.

    1. Run MemTest for a minimum of 7 passes and if you have any errors you need to replace your RAM. Also, if there are errors, run the test on each stick to determine if one or all need to be replaced.

    2. Run chkdsk

    3. Scan for malware/viruses/trojans

    * But do MemTest first
  3. Klohgloh

    Klohgloh TS Rookie Topic Starter Posts: 32

    Ok, i ran MemTest overnight and it didn't find any error - same as ChkDsk (i also tried to use only one of my two RAM modules, in both slots). The system looks to be clean of any malware (also i got errors on absolutely new installation ...).

    Anyway, today i have some better and quite typical minidups to analyze i guess.

    The first one (1) comes from an error which occures when i run a game (vietcong.exe) - it crashes after 5 mins or so (and this game always crashes aproximately after this same period of time). But then while restarting the system it crashes again (2) and then once more (3) in the very same moment of loading the system as before. The last one (4) is from a bsod which showed up when i was viewing these minidumps in WinDbg.

    It happens very often that the BSODs come repeatedly like this during the reboot (after a random first one of course)

    Thanks for help again!
  4. Matthew

    Matthew TechSpot Staff Posts: 5,325   +101

    If you have Comodo Firewall installed, uninstall it and see if there is any change.
  5. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Z beat me to it! Three of four minidumps point to cmdguard.sys which is a driver for the COMODO firewall.
  6. Klohgloh

    Klohgloh TS Rookie Topic Starter Posts: 32

    Yeah, you were right, i uninstalled COMODO and the arrors on rebooting disappeared ! But it keeps crashing when i run the game. (i'll try with some other apps.)
    I'll post some more minidumps when i collect them ;) (unluckily it often crashes without making one)

  7. Klohgloh

    Klohgloh TS Rookie Topic Starter Posts: 32

    OK i have another one ;)
    The overall stability increased a lot when i reinstalled all non-WHQL drivers to latest WHQL !
    I tried to evoke a BSOD by running another game application and after a short time i got one (attachment).
    It shows clearly to a sound related error i think - i have Realtek AC'97 integrated sound card.

    + i made a full memory dump:

    Probably caused by : ALCXWDM.SYS ( ALCXWDM+7ceeb )

    Followup: MachineOwner

    kd> !analyze -v
    * *
    * Bugcheck Analysis *
    * *

    This is a very common bugcheck. Usually the exception address pinpoints
    the driver/function that caused the problem. Always note this address
    as well as the link date of the driver/image that contains this address.
    Some common problems are exception code 0x80000003. This means a hard
    coded breakpoint or assertion was hit, but this system was booted
    /NODEBUG. This is not supposed to happen as developers should never have
    hardcoded breakpoints in retail code, but ...
    If this happens, make sure a debugger gets connected, and the
    system is booted /DEBUG. This will let us see why this breakpoint is
    Arg1: c0000005, The exception code that was not handled
    Arg2: f698deeb, The address that the exception occurred at
    Arg3: ba576aac, Trap Frame
    Arg4: 00000000

    Debugging Details:

    *** ***
    *** ***
    *** Your debugger is not using the correct symbols ***
    *** ***
    *** In order for this command to work properly, your symbol path ***
    *** must point to .pdb files that have full type information. ***
    *** ***
    *** Certain .pdb files (such as the public OS symbols) do not ***
    *** contain the required information. Contact the group that ***
    *** provided you with these symbols if you need this command to ***
    *** work. ***
    *** ***
    *** Type referenced: kernel32!pNlsUserInfo ***
    *** ***
    *** ***
    *** ***
    *** Your debugger is not using the correct symbols ***
    *** ***
    *** In order for this command to work properly, your symbol path ***
    *** must point to .pdb files that have full type information. ***
    *** ***
    *** Certain .pdb files (such as the public OS symbols) do not ***
    *** contain the required information. Contact the group that ***
    *** provided you with these symbols if you need this command to ***
    *** work. ***
    *** ***
    *** Type referenced: kernel32!pNlsUserInfo ***
    *** ***

    EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - Instrukce na adrese 0x%08lx odkazovala na adresu pam

    f698deeb ff5108 call dword ptr [ecx+8]

    TRAP_FRAME: ba576aac -- (.trap 0xffffffffba576aac)
    ErrCode = 00000000
    eax=85d5fa3c ebx=85ceb924 ecx=00000001 edx=d0c40000 esi=85ceb888 edi=00000000
    eip=f698deeb esp=ba576b20 ebp=ba576b38 iopl=0 nv up ei ng nz na pe nc
    cs=0008 ss=0010 ds=0023 es=0023 fs=0030 gs=0000 efl=00010286
    f698deeb ff5108 call dword ptr [ecx+8] ds:0023:00000009=????????
    Resetting default scope




    LAST_CONTROL_TRANSFER: from 8051dea6 to 805339ae

    ba576674 8051dea6 0000008e c0000005 f698deeb nt!KeBugCheckEx+0x1b
    ba576a3c 804dfada ba576a58 00000000 ba576aac nt!KiDispatchException+0x3b1
    ba576aa4 804dfa86 ba576b38 f698deeb badb0d00 nt!CommonDispatchException+0x4d
    ba576ab8 8054b038 86647038 8667e670 8657ad00 nt!Kei386EoiHelper+0x18a
    ba576b38 f68fe25a 85ceb888 8657ad20 8609d8a8 nt!ExFreePoolWithTag+0x676
    ba576b58 f6cf20fc 86699128 8609d8a8 ba576b80 portcls!DispatchClose+0x39
    ba576b68 f68fd880 8657ad20 8609d8a8 8609d8b8 ks!KsDispatchIrp+0x71
    ba576b80 f68fd841 8657ad20 8609d8a8 ba576be4 portcls!KsoDispatchIrp+0x43
    ba576b90 f69563c0 8657ad20 8609d8a8 804e3d77 portcls!PcDispatchIrp+0x5f
    WARNING: Stack unwind information not available. Following frames may be wrong.
    ba576be4 80563ff6 0070d908 8670d8f0 00000000 ALCXWDM+0x453c0
    ba576c00 804e3c55 8670d908 00000000 804d9190 nt!ObpRemoveObjectRoutine+0xdf
    ba576c24 baa3f135 85d39018 e2b28690 baa3dba2 nt!ObfDereferenceObject+0x5f
    ba576c30 baa3dba2 85d39008 ba576c4c baa3e35c sysaudio!CInstance::~CInstance+0x28
    ba576c3c baa3e35c 00000001 861d53b0 ba576c5c sysaudio!CPinInstance::`scalar deleting destructor'+0xd
    ba576c4c f6cf2737 8633f768 85d39008 ba576ca4 sysaudio!CPinInstance::pinDispatchClose+0x26
    ba576c5c 804e3d77 8633f768 85d39008 85d39008 ks!DispatchClose+0x32
    ba576c6c 8056afec 86188518 00000000 00000000 nt!IopfCallDriver+0x31
    ba576ca4 80563ff6 00188530 86188518 00000000 nt!IopDeleteFile+0x132
    ba576cc0 804e3c55 86188530 00000000 00000fac nt!ObpRemoveObjectRoutine+0xdf
    ba576ce4 80567543 85ea6c88 e2bbc470 85f8f4e8 nt!ObfDereferenceObject+0x5f
    ba576cfc 805675ac e2bbc470 86188530 00000fac nt!ObpCloseHandleTableEntry+0x155
    ba576d44 805675f6 00000fac 00000001 00000000 nt!ObpCloseHandle+0x87
    ba576d58 804df06b 00000fac 0012fd48 7c90eb94 nt!NtClose+0x1d
    ba576d58 7c90eb94 00000fac 0012fd48 7c90eb94 nt!KiFastCallEntry+0xf8
    0012fd38 7c90d592 7c809bbb 00000fac 0012fd60 ntdll!KiFastSystemCallRet
    0012fd3c 7c809bbb 00000fac 0012fd60 73ed9350 ntdll!ZwClose+0xc
    0012fd48 73ed9350 00000fac 054354d8 73ed9315 kernel32!CloseHandle+0x51
    0012fd54 73ed9315 00000000 0012fd84 73ed3c06 DSOUND!CKsRenderPin::~CKsRenderPin+0x23
    0012fd60 73ed3c06 00000001 73ed3bed 0503a4f8 DSOUND!CKsRenderPin::`vector deleting destructor'+0xd
    0012fd68 73ed3bed 0503a4f8 73edb4da 05037390 DSOUND!CDsBasicRuntime::AbsoluteRelease+0x10
    0012fd70 73edb4da 05037390 05037390 03186670 DSOUND!CDsBasicRuntime::Release+0x18
    0012fd84 73f0eb0a 00000000 73ef80f3 05037390 DSOUND!CKsSecondaryRenderWaveBuffer::FreePin+0x7b
    0012fd8c 73ef80f3 05037390 0012fdc4 73ee49ac DSOUND!CKsSecondaryRenderWaveBuffer::FreeResources+0xa
    0012fd98 73ee49ac 00000000 050373e8 73ee4b72 DSOUND!CDirectSoundSecondaryBuffer::FreeResources+0x3e
    0012fda4 73ee4b72 00000000 051b14a0 00000000 DSOUND!CDirectSoundSecondaryBuffer::Stop+0x55
    0012fdc4 73ee17a3 0012fdf8 00000000 03186670 DSOUND!CDirectSoundSecondaryBuffer::GetStatus+0x53
    0012fdd8 00956f34 051b14a0 0012fdf8 00000026 DSOUND!CImpDirectSoundBuffer<CDirectSoundSecondaryBuffer>::GetStatus+0x51
    00000000 00000000 00000000 00000000 00000000 TmNationsESWC!CConstructionMenus::MenuReplay_CryptedConnect+0x1d12a4


    f698deeb ff5108 call dword ptr [ecx+8]



    FOLLOWUP_NAME: MachineOwner





    BUCKET_ID: 0x8E_ALCXWDM+7ceeb

    Followup: MachineOwner
  8. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    ALCXWDM.SYS is a driver for Realtek AC'97 Audio (WDM). Update the latest drivers for your onboard audio.
  9. Klohgloh

    Klohgloh TS Rookie Topic Starter Posts: 32

    Yeah, i updated my drivers to the latest version and the error i previously posted occured. So i disabled the OnBoard Audio in BIOS and then a received an absolutely new DirectX related error (dxg.sys) :/
    Don't you think these "signs" show to a damaged motherboard ?

  10. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Did you download your drivers from RealTek or your motherboard manufacturer's website?
  11. Klohgloh

    Klohgloh TS Rookie Topic Starter Posts: 32

    Yes i downloaded them from MSI's "drivers" page for my mb
  12. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Okay, try this. Download most recent audio drivers but don't install them. Make sure everything that has to do with your onboard audio is deleted. Reboot into safe mode and install your onboard audio drivers. Reboot again and see if that rectifies the problem.

    Also, have you updated your video drivers?
  13. Klohgloh

    Klohgloh TS Rookie Topic Starter Posts: 32

    I already tried something like this - i uninstalled the driver, then using Driver Cleaner i deleted all Realtek drivers (and all the stuff DC does), rebooted and reinstalled. But i think some files were left in the C:/ Programe Files/Realtek folder - do you think this is also important to delete ?


    EDIT: and yes, i tried more nvidia drivers, now i run the latest version
  14. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Yes, that is important to delete everything. Remnants can cause problems.
  15. Klohgloh

    Klohgloh TS Rookie Topic Starter Posts: 32

    Hello again,
    so i reinstalled the audio drivers and i received a STOP error related to alcxwdm.sys again. I also tried to disable the onboard audio (+ onboard LAN and USB) in BIOS but nothing improved. I actually received one usbport.sys and one tcpip.sys related error...

    It looks hopeless to me since the suspected drivers are always so different ;).
    Anyway i attached some of the latest minidumps so you can have a look at them.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...