Terminal Services help

By kiroboy69 ยท 10 replies
Jul 22, 2009
  1. Users trying to access a Windows 2000 server using Remote Desktop are able to get to the server login screen, but upon entering their logins/passwords they are not taken to their desktops. Instead, they seem to get stuck at a blue screen like the desktop but with no icons at all.

    What things should I try to troubleshoot?

    I have tried connecting using our public IP address from a remote location, and using the server's internal IP address from within the network. Same result both times: login works but stops at a blank blue screen.
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I don't have any specific answers for you.. but here's some ideas for troubleshooting

    1) Refer to this MS KB How To Connect Clients to Terminal Services By Using a Terminal Services Client in Windows 2000
    2) Check your Windows Event Logs to see if anything logged in System or Application logs giving you clues as to the failure
    3) I know you can in XP (you best double check Win2K ) set your Group Policy to Audit user logon/logoff events. These events would then appear in the Event Log Security logs. Just thinking this MIGHT also provide clues on where in the logon process things are failing (just a thought as something to try. Don;t know if it would or wouldn't help)
    4) Of course, be sure you've run Windows Update to make sure all updates have been applied
  3. jobeard

    jobeard TS Ambassador Posts: 11,170   +989

    perform the test from a computer in the same room, attached to the same LAN.
    this removes question for the infrastructure/gateway equipment and is much faster+easier to resolve.
  4. kiroboy69

    kiroboy69 TS Rookie Topic Starter Posts: 19

    I have done that... I 'remoted' into the TS server using another server on the same rack but still cannot get in.

    I will look at the logs soon (i'm the only IT guy for this company and I'm on my last day of vacation hehe)..

    I am able to remote in to a different server behind our firewall, and from there I can access the TS server using a VNC icon.

    I accessed the TS server and looking at the task manager, I see a process called 'ntJavaConsole.e' is taking up lots of processing power..up to 50% and it's just fluctuating nonstop.

    I have a feeling this is causing the problem with users trying to access this server remotely.

    What is that process and how can I calm it down? (i will google this in the meantime)
  5. jobeard

    jobeard TS Ambassador Posts: 11,170   +989

    that process is associated with ANY Java program -- VNC itself could be involved.

    think about the requirement of showing the desktop -- that's going to take some resource to show the screen updates.

    If you can login to the remote win2k, then the lack of presentation will be associated with that system, not the one you are accessing from.

    Win2k is downlevel by a ton, so I would first attempt to get it as up to date as possible.
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    on first glance, a quick search on ntJavaConsole.exe seems to indicate
    >> Do you run a product called Cold Fusion??
    >> If so, several people complained of similar high CPU (even higher usage!) with the same executable and, one person reports they uninstalled cold fusion and that solved their problem

    If applies to you, you might also check for Cold Fusion updates
  7. jobeard

    jobeard TS Ambassador Posts: 11,170   +989

    to my understanding "Coldfusion" is a webserver side application for generating html content.
  8. kiroboy69

    kiroboy69 TS Rookie Topic Starter Posts: 19

    Yup, we use Coldfusion code in our website...it works pretty good with our MSSQL system.

    In my research I found what someone posted as a solution, and it worked for me as well. I had to disable three coldfusion related services in services.msc and that did the trick.

    Time will tell if these changes will have a negative effect on our web or database elements!
  9. kiroboy69

    kiroboy69 TS Rookie Topic Starter Posts: 19

    Thing is...the coldfusion problem has been taken care of, but we still cannot access the server via remote desktop.

    Can I just stop troubleshooting and just uninstall/reinstall terminal services on the server? Is it difficult or dangerous at all?
  10. kiroboy69

    kiroboy69 TS Rookie Topic Starter Posts: 19

    The system event log specifies Event ID 1111: Driver MFC-6800 required for printer MFC-6800 is unknown. Contact the administrator to install the driver before you log in again.

    Here's what I know: on the machine of the user that first started experiencing this problem I installed a network printer located in their office using the add printer wizard and the IP address of the printer. I did not have the drivers for that particular printer loaded onto the machine, so I just chose the Brother mfc-6800 option in the wizard.

    Will this have caused the terminal services meltdown?

    I will load the correct printer driver onto the user's XP machine and i will see if that helps.

    Also, we already have drivers for the MFC-6800 loaded on the server....
  11. kiroboy69

    kiroboy69 TS Rookie Topic Starter Posts: 19

    I corrected the errors pertaining to printers, but I still am unable to access the Win2k server via remote desktop, not even from within our network/subnet...

    The bizarre thing is that one of our clients in another city actually CAN access the server remotely via remote desktop.

    How is this possible?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...