Toshiba L300 laptop won't boot up

By Colonel30 ยท 5 replies
Jun 18, 2011
Post New Reply
  1. Hi, I have a Satellite L300, and when I try to boot the machine up, the opening welcome screen from Toshiba appears, with the option to press F2 or F12 to go to the set up options, but after that the laptop will not proceed any further. At this point the battery light and power light are constant green, but the HDD light only flashes temporarily before going off again. I've tried disconnecting everything for a couple of hours (including taking the battery out) and then connecting everything back up again, but to no avail. Have you any other ideas on what I could try, or what the problem may be?

    Many thanks, Greg
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    The hard drive may have failed. Remove the hard drive and try booting up the laptop. Does this cause "no operating system found", or change the stopping point at all?
  3. Colonel30

    Colonel30 TS Rookie Topic Starter

    I removed the hard drive as you suggested and tried to reboot. I still get the Toshiba greeting message, and then a couple of error messages come up on a blank screen. After 10-15 seconds of turning the power on it tells me
    "no bootable device - Insert boot disk and press any key"

  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    I would say that the hard drive is bad...
  5. Taken1986

    Taken1986 TS Rookie

    i got the same problem. In my case even if i remove the HDD the system still stops at the Toshiba welcome screen. It neither responds to the F2 or F12 keys to go to the setup options. someone pls help me.
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    corrupted bios or a bad keyboard may be the problem. Try attaching an external PS2 keyboard and see if you can get into the bios using that

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...