1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Unrecognized SATA drives

By pete76
Jun 18, 2012
Post New Reply
  1. upgraded to an
    Gigabyte (GA-EP43-S3L) motherboard & Intel Core Duo 2.8 GHz

    can boot to bios but wont recognise sata drives sata 500gb hitachi or sata cd drive. when removeing battery and useing jumper, then bios recognise both but soon as u save and it reboots the`re missing. be gratefull for any ideas.
  2. Dawn1113

    Dawn1113 TS Booster Posts: 319   +68

    Hi, pete76. Well, I'm sure you've already done this, but I'll say it anyway, just in case. The first thing I'd do is check the cables and connectors on both ends, the connections to the PSU. I'd double check to make sure that the primary drive -- when detected (before saving, as you described) -- is in IDE mode, as well.

    Is your CMOS battery still running OK? Have you observed any other inconsistencies in the BIOS settings -- lost or incorrect time, perhaps? A failing CMOS battery can produce all kinds of symptoms and errors, including the failure to recognize drives.

    But if all of that checks out and the problem persists, I'd strip everything out, leaving only the boot HDD just to make sure there isn't some device messing up the BIOS somehow. It appears you've already cleared your CMOS. So maybe some kind of failure in the SATA ports? Have you checked for blown caps?
  3. Cinders

    Cinders TechSpot Chancellor Posts: 867   +12

    OK, I'd strip the motherboard bare like Dawn said. Are the drives connected directly to the motherboard, or are you using some type of daughter card to connect the drives to the motherboard? One or more of the drives may be broken, and a broken drive can make your motherboard do weird things. I'd connect one drive at a time to the motherboard and then check to see if the device works. I'd start with the optical drive in place and try to boot into a burned Memtest+ disk or some other bootable disk you already have, and see if the disk will run. If that worked I'd take the optical drive out and try to boot into the hard drive. I assume you have an operating system installed on the drive already. If that passed the test I'd then reconnect the optical drive and see if they worked in place together. If when you connect a device the motherboard quits working, then that device is probably the culprit.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...