USB 2.0 Flash Drive issues in Windows XP SP2

By Romin ยท 18 replies
Feb 2, 2005
  1. I upgraded my PC to Windows XP SP2. I have two flash drives (memorex & simpletech) - both 256 MB. And none of them appear in Explorer. In fact I get an error saying that there is a USB Power Surge on the Port, etc.

    I dont even see any of the devices in Device Manager.

    Surprisingly, I have other USB devices like Web Cam and Camera and they work perfectly. Even they give an error about USB Power Surge on the Port but they still work. So thats all the more confusing.

    I have tried all kinds of stuff like:
    1) Uninstalled all USB Ports and installed drivers again
    2) Installed the latest Chipset drivers from Intel
    3) Rebooted the PC with the Drives inside, etc.

    I have applied all Windows Updates too.

    Please let me know of any other things to try. Appreciate any response.
  2. Paul

    Paul TS Rookie Posts: 58

    On the page where you see all your drives C: D/E etc ,I need you to right click and go to properties,The system properties box open go to universal serial bus controllers and click on this,look for usb root hubs and open each one by clicking twice,Go to power in this new box opening,The new box will be usb hub properties,now click on power properties,When you have your flash drives inserted check in properties and look at device description see if your removable drives are mentioned,If not either your usb ports are defective or your flash drives them selfs,Try an other computer with thoses flash drives to see if they can be read.
  3. Romin

    Romin TS Rookie Topic Starter

    Still problematic

    Thanks for the reply.

    Yes -- I forgot to mention that the drives work properly in other systems both Windows 2000 and Windows XP.

    I did try the suggestions that you mentioned i.e. notice the power settings as each device is plugged in. I found that when I use my web cam, etc. it does short the stuff and the power ratings at 250ma, etc.

    But when I plug in any of the USB 20 flash drives, I see nothing there. I even upgraded all the host controllers but nothing seems to work.

    Is there a possibility that the flash drives are USB 20 and not USB 11 and because of that something is going wrong somewhere. This is because my webcam and digital camera work ok. My BIOS and Motherboard do have support for USB 20. And worst point is that these drives have worked before on the same machine.

    Any clues? Thanks once again for your response.
  4. Romin

    Romin TS Rookie Topic Starter

    Unknown USB Device

    OK, when I plug in the Flash Drive and go to the Power Settings on the USB Hub

    a) Originally there were 6 ports available.
    b) When I plug the USB Device, I do get the following shown under the Power Tab:

    Description Power Required
    ?Unknown USB Device Unknown
    ?Unknown USB Device Unknown
    4 port(s) available 0 mA

    Why does it show it as Unknown USB Device. To the best of my knowledge, Windows XP comes inbuilt with support for these devices and doesnt need any drivers as such to be installed for flash drives.

    Any hints?

  5. Paul

    Paul TS Rookie Posts: 58

    Is there any button tab on the drive that says read only.I have seen some drives that have the switch,Try to switch it to unlock so you can read and write. Yes xp should not need drivers as you say,But the drivers could have problems,I would work on one usb port only if you know this port works.Try to delete that root hub in device manager and then shut down.let xp reload that hub up and then reinstall the flash drive and see if that works.
  6. Romin

    Romin TS Rookie Topic Starter

    Tried that too

    Paul - Thanks for your help so far on this.

    One of my flash drives (Memorex) has the read only stuff. So I made sure that the button is not on "locked". The other one (SimpleTech) does not have any such button.

    I tried what you suggested i.e. worked with just one port (in fact my webcam works off any port -- so the two USB ports that I have are ok -- I guess). I uninstalled the USB Root Hub for that -- restarted -- XP found the Hub and installed stuff on its own -- but still nothing gets recognized.

    Some additional points that might be of interest:
    1) Each of the Flash drives have a little LED that comes on -- a green light. On machines with which they work this light becomes green. On my XP SP2 machine that is giving problems -- they dont even come on green. So, is it likely that the "Power Surge on Hub" message that comes is basically doing something. I cant believe that there is really a power surge on the Hub. These drives were working perfectly before.

    2) As I mentioned in the previous post, when I plug only one flash drive, it does display on the Power Tab for the Hub as:
    Description Power Required
    ?Unknown USB Device Unknown
    ?Unknown USB Device Unknown
    4 port(s) available 0 mA

    WHY does it show two ports as Unknown -- shouldnt it just show one since only one flash drive has been inserted and the other USB port is empty.

    Any hints?

    Thanks once again for your interest in helping me out. I have not yet lost hope :)
  7. Paul

    Paul TS Rookie Posts: 58

    If nothing is connected to that port it will show as unknown.Please tell me if you have any thing else connected to your usb ports if not great,If you have a mouse connected plug it in to ps2,Now what i want you to do is this,go to device manager in system in control panel and look for your universal serial bus controller,this is where you will see all your root hubs and you will see universal host on universal serial bus controllers high light it and click remove,Shut down and restart,Make sure there is nothing installed on any usb ports when you do this,When up and running plug that drive in to any port while at your desk top,See if it will recoginize that drive,If not you have SP2 issues that do not like your flash drives.
  8. Romin

    Romin TS Rookie Topic Starter

    Tried this too

    Paul -- thanks for your reply.

    Yes -- I tried what you suggested too but still the same problem i.e. Power Surge on USB Port and then nothing gets recognized. I also do not have any other USB Devices connected. My mouse and keyboard are PS/2 devices.

    It does look like there is something that the SP2 does not like about my flash drives.

    I was thinking of some options:
    1) Do you think that getting a 4-port USB Hub (powered by an external power supply) might help in this case here ?

    2) I did contact the BIOS folks also and they seem to say that they have a nice BIOS upgrade for me which provides compatibility for XP SP1 and SP2. But they want $29.95 for it. I am not too sure if this might solve the problem anyways.

    Any suggestions would be welcome.

    Thanks once again.
  9. Paul

    Paul TS Rookie Posts: 58

    No the hub would not make a differents,It could be any thing thats not compatiable,would not hurt to flash the bios.But i put the blame on Sp2 ,This service pack had lots of problems for xp,I could not count them all,i fully recommend win2000 anyway.
  10. Romin

    Romin TS Rookie Topic Starter


    Paul - I think I will end the thread here and thank you very much for your suggestions.

    I wanted to try my best to make SP2 work because every other thing in the system is working like a charm without any problems.

    But the flash drives are too important to me because I use them on a daily basis to transfer work related data between my office and home. And I dont want to go and buy some new USB 2.0 flash drives just because my current two drives are not being accepted by XP SP2.

    I like Windows 2000 too and it never gave me any issues -- not atleast the ones that I have now. Maybe I should go back to Windows 2000...... or wait for SP3 ... no cant wait.
  11. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

    USB Flash is a Mass Media type

    configure / add the USB Mass Media driver!
  12. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    Thats the first I've heard of USB 2.0 FD problems! Dosen't WinXP have all neccessary drivers for Flash Drives? My lil 256mb came with drivers but I didn't need them. & these days if u buy one it says when installing on XP no drivers are needed.
    Have u tried repairing WIN? But yeah, in any case the above is right! Mass storage device so tweak settings in Device Manager (or update drivers, roll back, etc.)

    Good luck wiv that & if u fix it ... let us know how eh? :grinthumb
  13. Butkus

    Butkus TS Rookie

    I recently upgraded my son's T41 laptop to XP SP2 and had USB drive issues too. His Kingston Data traveler did not show up in My Computer. It was in Device Manager though. After trying many of the things suggested here and from googling, I went to Kingston's site where their faq mentioned that there can be drive letter conflicts after installing sp2. Sure enough in Disk Manager the usb drive was listed on the F drive and was accessable from their. In My Computer the F drive was a network connection to his desktop. Changing the drive leter in Disk Manager for the usb drive made it accessible in My Computer and allowed to open automatically like it is suppossed to :) . Apparently sp2 has problems assigning drives in some cases. Hope this helps some people.
  14. j_fli

    j_fli TS Rookie

    Butkus....just when I was starting to get discouraged and bail on this entire post.... I read what you just said....It worked for me.....Thanks a million! And the simplicity of it all..... ;)
  15. Butkus

    Butkus TS Rookie

    Hi j_fli,

    Glad I could help. From what I have seen this is apparently a bigger problem than many realize.

    A lot of times the solutions are so simple. We tend to pass over them and look for complicated solutions.
  16. ahmadhumayun

    ahmadhumayun TS Rookie


    Hi all,

    I have tried every single thing mentioned by you people over here.. still having the same problems as Romin was having.. though he has ended his thread, any helping suggestions would still be appreciated.

  17. tjhall

    tjhall TS Rookie

    I also am having trouble with a USB 2.0 flash drive on an XP Pro SP2 system. My symptoms appear a little different than those I have read in this thread.

    I have three flash drives, two of these work fine (one USB 1.1 the other USB 2.0). The third is a new drive that is not yet useable on two of my three systems (verified to work on one system). On my desktop at work (Dell Dimension 4600) the flash drive's ***** light illuminates steady (suggesting it is powered and thinks it is ok), the drive shows up in Device Manager under 'Disk drives' and in USB device controllers with both saying it is operating correctly. Explorer eventually (tens--hundreds of seconds) provides a drive letter (originally conflicting with another device; now no other USB devices are plugged in) and calls it a 'removeable disk', but Explorer is unable to obtain a directory (semaphore timeout error) and the drive is not listed in Disk Management (no entry for it at all, even after being plugged in for hours). Plugging inot a different USB port has no apparant effect on behavior.

    A fourth similar flash drive behaves much the same but does not even get to the point of getting a drive letter assigned.

    I have updated the chipset firmware and the BIOS. I have uninstalled the flash drive device driver, the USB hub driver and rebooted without the flash drive to allow the system to reinstall the USB hub driver. I then reinserted the flash drive to reinstall that change, still not functioning correctly.

    I have run out of (useful) ideas and would greatly appreciate any help.
  18. JtMoney!

    JtMoney! TS Rookie

    Problem: known good USB Flash Drive will not work. It worked before on the same machine until the machine had it's power supply replaced.

    Symptoms: No removable drive detected. Unknown USB device appears on list of devices. Error message "USB Device not working properly" appears when first connected. Light on USB Device illuminated for 1 sec, then turns off.

    Solution: This was a unique problem with an easy fix. disconnect the device for a minute and then re-plug it. When the list of USB devices appears and you see the "Unknown USB Device", right-click and Uninstall it. Unplug the USB Flash drive again, and wait 10 seconds. When re-plugging it, try to insert it slowly until the light appears. It should stay lite this time. once it stays lite, you can fully insert it. Ok, honestly, the whole slowly inserting thing might be bs but that's what I did so i added it. I'm not sure what the problem is and why this fix worked..but it did! lol, hope this helps someone.
  19. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...