USB Flash drive does not work

By Svintus ยท 5 replies
Nov 30, 2005
  1. I have a Lexar JumpDrive that is not recognized when inserted into the USB port. Nothing happens in windows XP. I tried on 2 machines 1 with SP1 and 1 with SP2. I tried other devices and they all work on the machines. The one I have has a light on the drive to signify that it is working. They LED light on the drive does not turn on. I am thinking the thing is done. So my question is....

    1. Is there a way to get to the information on it?
    2. Is there a more scientific way to figure out if the drive is really broken and can not be accessed?

  2. Rik

    Rik Banned Posts: 3,814

    You are not the first person to have trouble with a Lexar Jump Drive. If its still under warranty then the best idea would be to take it back.
  3. BiZ


    If your trying to plug it into the USB ports in the front they may not be plugged in. Look inside the case and see if they are. If they arent bust out your motherboard book and find where they're suppose to be plugged.
  4. swity20

    swity20 TS Rookie

    please help me with my problem. i borrrowed 512mb SANDISK Cruze mini USB from my classmate. Then i have used it for so many times then the last time i used it Windows XP didnt detect the device anymore. I even used it to other windows but still it the computers didnt detect it. What im going to do? Please help me... Please help... Im very desperate because i can't afford to pay for it or buy another USB.
  5. jimjim

    jimjim TS Rookie


    I have a SanDisk Cruzer Lock 1. I have files in the encrypted section that will not respond to the PW. Some files will but 5 will not. on entering the PW the message I get is the "file is not encrypted", yet they cannot be moved from that section to the Un-encrypted.

    Any thoughts.

    BTW-SanDisk says it's not their problem, they only include the Encryption as an added feature of the Cruzer and they don't support Cruzer 1.
  6. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +422

    Please use the Search Feature This type of problem with Sandisk as well as some other brands have been discussed countless times on the forums.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...