USB Flash Drive (PNY Attache)

By c18kay · 12 replies
Sep 27, 2006
  1. Hi there, I've just purchased a 1Gb Flash Drive (PNY Attaché USB) and whenever I stick it in my computer Windows tries to install the software then it comes up Unknown Hardware followed by the following message:
    USB Device Not Recognizes
    One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it.

    I've tried it in my old computer and it works fine so I know it's not the hardware - any ideas?

    Hope someone can help - thanks in advance


    A bit about my computer:
    Windows XP
    Dell 8400
    Intel Pentium 4
    1024 RAM
  2. tipstir

    tipstir TS Ambassador Posts: 2,474   +126

    Yeah I've notice that at work too last night on a DELL 680. But I had a new Maxtor Backup USB2 200GB attached to E where the PNY tries to use the same E drive. If you don't have anything attached using E, try different USB ports on the rear. Changing drive letters do work at times, but not in certain cases.

    But I've noticed that some USB jumpdrives just don't work at all. They are either faulty or just won't work.

    Memorex and Scandisk ones work no matter what...
    PNY seem to give problems on some PCs..
  3. c18kay

    c18kay TS Rookie Topic Starter

    Thanks mate, my DVD-RW is currently Drive E so might try changing that and trying again.

    The first time I tried the Flash Card I used one of the USB slots at the front, however I heard that people experience problems using this so thought I would try one of the back ones - still no joy.

    Do you think it would be best just returning the Flash Card and buying a more expensive / reliable one?
  4. tipstir

    tipstir TS Ambassador Posts: 2,474   +126

    Well I have the same PNY ATTACHE you have and I am keeping it, since it works with my new laptop and all my clone PCs I've built with 6-port USB 2.0 front and back. Most of the PCs I've attached to it works except for that one last night. But that's up to you if you want to return it. I did get a LG and had crazy problems with it, and I did return it for Memorex USB 2.0 and had no problems with that one.

    Yes try changing that drive letter for your DVD-RW to F:..

    And you're welcome... always like to help! :)
  5. c18kay

    c18kay TS Rookie Topic Starter

    Thanks I'll give it a try and let you know how I get on
  6. c18kay

    c18kay TS Rookie Topic Starter

    I tried changing my DVD-R drive letter and unfortunately it didn't resolve the problem.

    Guess will just try to return it (although might struggle as the problem is my PC and not the Flash drive itself) unless anyone can think of any other ideas?

    Thanks again
  7. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    Check the Device Manager in Control Panel to see if there are any yellow symbols next to the USB controllers. Those would indicate driver problems with them.
  8. c18kay

    c18kay TS Rookie Topic Starter

    Already had a look in the devide manager but everything seems fine :(
  9. Bluemouse

    Bluemouse TS Rookie Posts: 195

    Try going to the manufacturers website and installing the drivers from there. They should still have them for machines not running an NT based OS. Does that work?

    Did you try it in other ports? Same issue? I get that sometimes but i just take it out and put it back in and it usually works.
  10. korrupt

    korrupt TS Rookie Posts: 716

    I don't think you'll need to install any drivers or anything...

    So is it a brand new flash drive? If so, try formatting it. I suppose you've tried it in other computers too?


  11. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    For what it's worth I have the same PNY 1GB flash drive as well as couple of other smaller PNY flash drives. As soon as I plug into a USB port for the first time, Windows XP recognizes the new hardware and finds the native driver and installs it. Thereafter, it works normally. After installing the proper driver, it also works in an old 98SE machine I have. That's how it's supposed to work, anyway.
  12. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

  13. c18kay

    c18kay TS Rookie Topic Starter

    I have now fixed the problem - thanks for your help

    For reference:
    I have a Dell All In One printer that has slots at the front so you can insert memory cards ect and my computer seen this as a storage device. I unplugged the printer and the flash drive seems to be working fine now so must've been conflicting :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...