USB flash drive recognized but Windows can't see it

By Reckoning ยท 11 replies
Sep 6, 2011
Post New Reply
  1. When I plug in my flash drive windows recognizes it and tries to run some kind of setup utility that came on the flash drive. I exit that and just go to my computer but my flash drive is not seen there. When I go to disk management it is seen there and says online. I've tried changing the drive path but no matter what I do it brings me the error "The operation failed to complete because the Disk Management console view is not up to date. Refresh the view by using the refresh task. I the problem persists close the Disk Management console, then restart Disk Management or restart the computer."
    I've refreshed, restarted the comp.. still same problem. I've downloaded and used the USB clean up utility here on Techspot and still same problem.
  2. WinXPert

    WinXPert TS Guru Posts: 445

    Allow Windows to finish the installation of the USB flash drive driver.

    Try clearing your mountpoints

    DL and run Autorun Protector and clear the Mountpoints.

    ...or you can manually delete Mountpoints2 entries in your registry. Create a backup of your registry before doing so.
  3. Reckoning

    Reckoning TS Enthusiast Topic Starter Posts: 96

    I do let it finish, it's real quick. I exit after it's installed and gives me the options like "browse folder, run utility.."
  4. WinXPert

    WinXPert TS Guru Posts: 445

    That means that your USB drive was detected.
  5. Reckoning

    Reckoning TS Enthusiast Topic Starter Posts: 96

    The utility program is detected, not the drive. The drive is only seen in disk management.
    This is what I'm talking about is detected and shown right when plugged in, which isn't the drive.
    And if I click to open the file/folder there. That folder ittself is only 6mb I can't store anything on that

  6. WinXPert

    WinXPert TS Guru Posts: 445

    Your drive is detected. Proof? the utility program in your drive is detected and you can see the folder there, though the size reported is wrong.

    Try to do a CHKDSK on your drive. Or you can repair its partition using EASEUS Partition Manager
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Is this a SanDisk? In any case, i can see from your screen shot, this is a "U3" drive.

    I have a SanDisk U3 also. I've never really tried to understand how to use the U3 launcher, etc, how it works and all it can do. Rather, I just uninstall U3 and use it as a normal flash drive. Go to the SanDisk website to uninstall U3. You can reinstall U3 if you ever want U3 in the future.
  8. Reckoning

    Reckoning TS Enthusiast Topic Starter Posts: 96

    It is detected but not seen. It does me no good that it detects the utility program only when I am trying to use it as a storage device. How do you chkdsk on the usb drive?

    It is a sandisk and same here I just use it as the storage drive I never bothered with the program. Until now it's worked fine so I never bothered even removing the program.
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Have you also tried it connecting it to a different machine as well?
  10. WinXPert

    WinXPert TS Guru Posts: 445

    at the CMD prompt

    chkdsk f: /f
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    U3 drives are different then other flash drives. When they connect to Windows, they look like a USB Hub with both a CDROM and a disk drive attached. If you look back at Reckoning's snapshot, you'll see the F drive is the U3 CDROM.

    Hey hey! I may have found something! I was connecting my own U3 drive under XP before. I just rebooted into my W7 partition and this time now i see the same two choices you do: Launchpad or View Folder.

    When you click View Folder, Windows is showing you the small CDROM partition on the U3 drive! Next time, click to run the Launchpad. Then use the Launchpad menu to open the Folder.

    Does it work?

    /* edit */
    btw.. i think this occurs when the Autorun option is turned off for CDROM drives (which is how i happen to have my W7 configured) U3 relies on the CDROM Autorun file to run Launchpad - ONLY AFTER Launchpad runs can you see the disk partition on U3! To avoid this non-sense, you can also just uninstall U3
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    I was just thinking about your first posts. sounds like you can't run launchpad? Based on what i discovered (in my last post) i think that's why you can't see the u3 disk. If you can't run launchpad HERE's another method that might uninstall it for you from the flash drive

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...