USB Keyboard Failure in BIOS

By madquincol ยท 10 replies
Jul 1, 2009
  1. I have a Dell Dimension 9150 that only has USB ports (no PS2) and for no particular reason, the keyboard drop dead. I have checked both the mouse and keyboard on another computer and they work perfectly and I have tried others that I know to work and they won't work either.

    The Pheonix Bios gets almost to the end and then says "keyboard failure", and asks me to press F1 or F2 (now that is pretty screwed up). I can't press anything.

    I have followed other advice and reset the bios, drained the system of power, removed the lithium battery, checked the physical ports etc etc etc.

    At the moment, the only answer is to buy a new computer - not happy. The computer is only 18 months out of warranty.

  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Do new USB keyboard and new USB mouse work on your motherboard?
    Have you reinstalled or updated your Chipset drivers?
    Can you find a way to get to the System->Hardware list? Any red or yellow flags?
  3. lcwolfman

    lcwolfman TS Rookie Posts: 21

    If the keyboard works on another system and you have tried connecting the keyboard on the other USB port then I would say its a motherboard problem.. Try removing all cards except video and disconnect all drives.. Dont think that will help but its a normal first step.. If you happen to have a pci USB card handy you could pop that in and see if the keyboard works.. Im guessing faulty USB ports..
  4. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Also, check for dirt and crud in the socket... or for a disconnected usb socket which you can easily see when you remove the case cover.
  5. T77

    T77 TS Enthusiast Posts: 300   +6

    there may be some problem with the usb port(not necessary since ur pc is new)
    i assume there may be some driver problem.the comp that i am using now had the same problem when i bought it,my pc is just a month keyboard just wont work.neither did it show any light.i checked the cotrol panel in windows and it said that there was some device driver loading problem & the driver file may be corrupt or missing.
    at last i had to format and re-install windows,and now it is working perfectly fine!
  6. lcwolfman

    lcwolfman TS Rookie Posts: 21

    He is having the problem outside windows during posting (the process before the OS loads) this takes out any driver issue.. His system is also not new..
  7. kidudu

    kidudu TS Rookie

    Same problem

    I have the same Dell 9150 unit and have just experienced the exact same problem with having no mouse or keyboard at start-up. XP continues to load after I get the keyboard error in the BIOS, but then of course I cannot even log in. Tried moving them to the front USB ports with no success, so I don't think it is a connection issue. Can't get into BIOS to make any changes. Aarrghh!!
  8. lcwolfman

    lcwolfman TS Rookie Posts: 21

    Have you tried a different USB keyboard? As soon as you turn your system on tap the f1 (it could be different for your system) and see if you can get into the bios.. If you still get the keyboard error during post (bios loading screen) then disconnect your power cable open the system case and remove the cmos battery (round watch size battery) for 30 seconds pop it back in and try the system then..
  9. kidudu

    kidudu TS Rookie

    I do not have bluetooth capability on mine. Will try the battery trick. Not at home right now to try however. Hitting F2 to gain control during start-up doesn't work as Madquincol described. What else can be tried to gain access/control? Could a corrupted BIOS be caused by a virus?
  10. lcwolfman

    lcwolfman TS Rookie Posts: 21

    The bluetooth comment I made was without thinking as you would most likely not have a way to pair the keyboard to the computer without being able to login to windows anyway.. As for what button to press to enter the bios it should be mentioned during the bios loading screen most likely at the bottom right.. It could be f1, f2, or the del key.. If its mentioned and still does not work try the cmos battery comment I made and see if that helps..
  11. kidudu

    kidudu TS Rookie

    Thanks for the help!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...