USB problem (Driver? Bios? something else?)

By jaeh ยท 9 replies
Feb 26, 2005
  1. I'm not sure if I was supposed to put the thread here, but if it's placed in the incorrect place, may a mod please put it in the correct thread? thank you.

    Anyways, back to the problem.
    All of my USB ports are not working at all, the Adaptor USB 2.0(I think) port that came with the motherboard does not work either. Everything is in place, and the 4 green lights on the back shows that the USB Adaptor was A-OK and ready to be used.
    I tried using the ports to setup my printer/digi-cam, but they both are not showing/booting up.
    Are there and drivers or bios updates or something to make the USBs usable?
    (Bios things are not my cup of tea, I would probably kill my motherboard before I can figure out what to flash/update)

    The Motherboard that I am using is a MSI K8T Neo2FIR. If more information is needed, I will gladly post it on this thread.

    Thank you,
  2. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Do they show up fine in Device Manager in Windows? (I guess you are using Windows, although you didn't say)

    It could be that you haven't enabled IRQ in bios for usb. Details about it should be in the mainboard manual.
  3. jaeh

    jaeh TS Rookie Topic Starter

    Yea, I am using Windows.
    But in Device Manager, it doesn't show any USB controllers bracket after the System Devices bracket.
  4. luvhuffer

    luvhuffer TechSpot Paladin Posts: 443

    Go to folder options in the control panel. On the view tab make sure there is a check in the box "show hidden files and folders"

    Go to your root drive (C?)/windows/system32/drivers. Make sure you have a driver named usbehci. If it's not there, then that may be what is causing your USB problem.
  5. gorg666

    gorg666 TS Rookie

    Also check that your USB controller is enabled in your BIOS
  6. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Did you install the motherboard drivers that come on the mobo-CD?
  7. jaeh

    jaeh TS Rookie Topic Starter

    I don't seem to have a file named usbehci. Is there any way of installing it or something?

    The motherboard CD did not have any USB thing to install either, But if you browse around the CD there will be a USB folder. PC to PC, and USB2.0. USB2.0 tells me to go to the official Microsoft webpage, and install whatever updates. However, it looks like I have already downloaded/installed all of the important updates, and don't have anymore updates to download/install.
    For the PC to PC, I installed it but it doesn't seem to be a USB driver..

  8. luvhuffer

    luvhuffer TechSpot Paladin Posts: 443

    Send me an E-mail. Put usbehci in the subject line so I know it's you. I'll send you the file. you can copy it and paste it in your windows/system32/drivers folder. Then post back here and let me know if it fixed it. Also are you using XP or another OS. tell me in the E-mail so I send you the right one. Click on my name to send the e-mail.
  9. jaeh

    jaeh TS Rookie Topic Starter

    I got my USBs working, it WAS my BIOS settings. Damn, the smallest things could be the biggest problems.

    Thanks for all your help.
  10. lgp171188

    lgp171188 TS Rookie

    Problem with USB flash drive

    I have a 1GB Transcend Flash drive. I accidentally tried to copy text from a word processor to it and it didn't copy. But when i unmounted the drive and inserted it, it said usb drive not detected and it happens the same way in any system. Is there any way to set this right or even format the drive??
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...