USB Removable Drive Issue

By HerenIstarion
Jun 5, 2008
  1. I know there are several threads about the issue hidden in the recesses of the forum. In fact, I've read quite a few and tried out some solutions suggested. But, for one, seems like all of them differ slightly, for two, none of the solutions worked it my case, for three - I was a spotlight of a new thread :D

    TwinMos 20X 4GB flash drive, in the form of leathery trinket turning on its own axis, looking nice and ladyish

    It is a birthday present for my wife, so I had it stuck in somewhere for a couple of weeks but as the date approaches, I've decided to fill it with some music for her to carry to the office, kind of additional bonus, type of

    So I did stick it in, XP Version 2002 Servic Pack 2 provied the driver OK, I've written in all I wanted, unstuck it (with all due care through 'remove harware' green arrow.

    Then I've thought up of some more files I wanted to go into it, inserted it again and, in the process of revision, decided to delete some of the previously written data

    Now we come to the salt of the thread - fecking thing refuses to delete files on account of being write protected

    It does show up in My Computer with correct size, it does show it has 3 folders written into it, with total free space of 3.5GB and used of 319MB, but it simply refuses to let me delete the files or add more (though copying of the existing ones works all right)

    Further steps involved:

    Step 0 - turning it all over trying to locate a physical write protection button if any - none found
    1. Rebooting the machine
    2. Un/re-sticking the drive from one USB port to another
    3. Effort to scan the disk for errors (gives report of it being in working order in case of quick scan but failure to fix errors in full scan mode on account of write protection)
    4. Outright effort to format (quick and full, FAT/FAT32, failure)
    5. Effort to format through cmd command window
    6. Effort to format through Computer Management/Disk Management
    7. Downloading and using of some recovery free software (all junk so far)
    8. Modification of registry (anythign that looked remotely like usb controling value, changing values from 0 to 1
    9. Uninstalling the current driver and effort to replace it with a driver provided by the manufacturer (failure since manufacturer only provides drivers for WIN 98)

    I would have returned it, but: 1. I seem to lack time, only 3 days left, 2 out of them being weekend and tomorrow being a hardworking end of a week. 2. I don't seem able to locate the receipt for the feckin thing, so I doubt they would grant my money back request

    It cost some 35-40$, and I wouldn't mind reviving it - so, if anyone has anything to suggest - immensely grateful I'd be
  2. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    TwinMos has an application and manual with instructions here. The instructions describes how to unlock protected areas and other things. Perhaps you can find something there that will help.
  3. HerenIstarion

    HerenIstarion TS Rookie Topic Starter

    Cheers, too late - I've already stomped on it in rage, shattering it to pieces :J

    Just kidding, returned it, expecting replacement on Tuesday 'cause we've run out of stocks'. Not bad but still sucks because it's after birthday

    And of course thanks :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...