1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

USBMonit quit working, can't open from system files - ??

By macx ยท 11 replies
Oct 3, 2005
  1. A tech loaded USBMonit on my 98SE to help safely unplug Sandisk flash
    drives (it's reportedly exclusively for that)

    All of a sudden it quit working and doesn't show up in the task bar anymore.

    I can find it in the Windows / System files, but when I try to open it
    I get no response. Looking at Properties, it does show that somethng
    is there. I've scanned it with AVG and Norton and no nasties shown.

    I've also looked for a fresh download, but can't find it anywhere.

    Thanks for any tips or help or links!
  2. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    If you can see the drive in Explorer(Sometimes Boot the computer with the drive installed),then change the Drive letter for the USB to "U" or any letter at least halfway through the alphabet.
  3. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  4. macx

    macx TS Evangelist Topic Starter Posts: 718

    I'm a little confused - nothing new.

    The drive works fine.

    It's just that the application USBMonit which
    is just for safely removing the drive doesn't.

    It did until a little while ago. It's in
    the C\Program files. I click on the app
    but it won't open. When it quit, the
    icon in the status bar disappeared, too.
    It used to show up when the drive was
    hooked up.

    From what I've been able to find out
    by doing a search, USBMonit is a
    separate app from the drivers etc
    for the drive.

    Am I missing something in your replies?

  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    See if it is in your Add/Remove programs. Uninstall and re-install it.
    Looked everywhere but could not find a download-location for it, only descriptions.
    Can you tell us where you got it from?
  6. macx

    macx TS Evangelist Topic Starter Posts: 718

    Nope, afraid it's not in Add/Remove.

    It was in C/System files, so I tried copying it
    to Program files. Was apparently able to do that.
    But still won't open or do anything.

    Awhile ago, before I found this great site, I was
    having trouble (as I usually do with Windows apps)
    getting some DVD burner software to install and
    work, so took it to a tech. She installed it
    (along with Spybot, AdAware & HJT - none of which
    I'd ever heard of before).

    I, too, couldn't find anyplace to download it, only
    info. I did find that it seems to be available within
    a suite of apps that, if I recall, costs around $50.
  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    In one of the HJT-logs from someone else, I found that little program USBmonit.exe
    I asked the person if he could attach it to his post because someone else (you) needed it.
    To make a long story short, here it is, stored in sandisk.zip:

    Hope it helps.
  8. macx

    macx TS Evangelist Topic Starter Posts: 718

    OK - here's where I'm at now.

    I unzipped the file, put a copy in Program Files.
    Clicked on it, nothing happened - won't open.

    Tried installing the flash drive, restarting,
    still doesn't show in the task bar.

    Tried to put a copy in System files, got a
    dialogue window saying the existing one
    couldn't be replaced because it was in
    use (!!??)

    Just thought of one thing - I've got 2 flash
    drives, one a Sandisk mini, the other a Sandisk micro.

    If I recall, that app is specifically for just one or the
    other, can't remember without going back into all
    the research which one.

    I've got the mini plugged in right now and it isn't
    showing up in the taskbar. Maybe it's just for
    the micro? I'll have to shutdown so I can remove
    the mini then try the micro.

    However (never ending saga!) the micro went
    inoperative awhile go while I was struggling with
    all this stuff. I had been using the Monit to remove
    it, but it quit working - won't open, can't save to it,
    Properties says it's full.

    Therefore have been trying it with the mini. (I thought
    from reading thru all the stuff that it was the mini that
    app was supposed to work with, but maybe it's the micro.)

    So - I'll keep trying.

    Thanks for the help & effort!

    I'll post the results, if I get any, when I try the micro.
  9. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Since they are highly portable, why not bring those over to someone else with a PC with Windows 2000 or XP?
    See how those USB-keys do there. If one is full, you could perhaps delete some stuff or have it first burned onto a CD, then delete.

    AFAIK you can just pull those keys out under W98, no need for such a program
    Why don't you run just the Hijackthis program from this post and post it here as an attachment?
    Follow these instructions ONLY for the HJT bit and put HijackThis in e.g C:\Program Files\HJT and NOT in Temp or on the Desktop!.
    Read: How to remove Begin2Search/Coolwebsearch and Other Nasties

    Then Read: How to post your Hijackthis log-files as an attachment.
  10. macx

    macx TS Evangelist Topic Starter Posts: 718

    My computer at work has XP Pro. I was using the drives
    to download stuff there and bring it home.

    The one drive still works fine on both machines.

    I had been hot unplugging the one that doesn't work
    now before I discovered the tool on the XP machine,
    and I imagine that's what lead to the problems.

    It now won't open, or at least won't show anything
    that had been on there before it quit working.,
    in either machine.

    Properties says the drive is full.

    I even tried to reformat on both SE & XP,
    but that wasn't allowed.

    I did run the HJT recently and did post it, and you did
    look at it and advise me that a couple of the things
    were "garbage" so I deleted them.

    I also went thru all the stuff in that "removing nasties"
    sticky step by step. Also downloaded/installed/ran
    AVG. Also had been using spybot and AdAware for awhile.
    No problems found anywhere.

    I think the drive is more or less screwed.
  11. macx

    macx TS Evangelist Topic Starter Posts: 718

    ONE problem solved anyway - USBMonit working!

    Hey Mr RealBlackStuff - that link you sent me apparently
    did the trick after all.

    But it took another discovery to "put it all together"

    As I previously mentioned, I've got a Sandisk Cruzer Mini
    and a Sandisk Cruzer Micro. The Micro quit working, so
    I'd been using the Mini.

    I tried taking another stab at solving the Micro's problems
    and when I installed it, voila! the USBMonit popped up
    in the taskbar! Works with the Micro, NOT with the Mini.

    Now if I could just get the DRIVE to work!
  12. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    There's another big thread https://www.techspot.com/vb/topic20810.html and a few smaller ones about Sandisk USBkeys in the Storage & Networking forum.

    I use 2 Sandisk Cruzer Minis @256MB with W2K and XP and have no problems.
    Using the Sandisk drivers I also could access them under W98 and W98SE without any problems.

    Perhaps you should uninstall your W98 USB and all USB-related items, then reinstall them, using the latest drivers from MS and any hardware.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...