Tech Stocking Stuffers: 18 awesome gifts under $50

Vista not detecting Nikon driver?

By eek ยท 26 replies
Jan 26, 2011
Post New Reply
  1. so recently my nikon d60 stopped showing up when i connect it into the computer...everything worked fine for like two years or so and now all of sudden i get this when i go to device manager:

    when i connect the nikon d60, it will not show up at all in my computer. all drivers have been updated, all software is up to date, etc. etc.

    i googled the hell out of this issue and saw where ppl said to go into the camera's settings and set it to ptp or usb or whatever the hell but apparently thats not an option because either the camera never came with the option or updating the firmware removed the option (thanks, nikon).

    so after googling again and again, i came across this site and i see that a user here had a similar issue:

    his isn't exactly the same as mine afaik, but one post stood out to me:

    when i right click on D60 under portable devices in device manager and click properties, C:\Windows\system32\drivers\libusb0.sys is unsigned.


    is that the issue thats preventing me from being able to move the photos that i've taken from my camera to my computer??

    how do i solve this? thanks.
  2. mike1959

    mike1959 TS Evangelist Posts: 1,031   +54

    As a first try at solving this, I would uninstall the nikon software, reboot the pc, plug the camera back in and see if windows finds it.
    Do you use a separate card reader for your SD cards? Does it show up as 'Devices with removable storage' in 'My computer' ?
  3. eek

    eek TS Rookie Topic Starter Posts: 18

    that didn't work.

    i have a usb cord that came with the camera that i just plug into the camera in order to get my pics off of it and onto my computer. i don't have a separate card reader.

    the camera doesn't show up at all in my computer, either.
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1) When you connect the camera via USB to computer is the camera turned ON?? (it should be turned on)

    2) Are you at least hearing the USB device connect ding-dong sounds when you plug/unplug the camera USB to computer?
  5. eek

    eek TS Rookie Topic Starter Posts: 18

    normally when i plug it in i make sure that its off and then turn it on and the computer picks it up...but i tried your way and got the same result.

    i hear the usb device connect sound either way.
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Ooops. I skimmed the thread too quickly. The fact D60 appears in DevMgr of course shows the camera's being detected on USB.

    as to camera being on... sorry, i just meant to assure the camera was turned on (if it wasn't being detected) but that's not the problem

    Suggest you next try this

    1) disconnect the camera USB from computer
    2) as mike1959 suggested, go back and look through Cntl Pnl->Programs and Features and make sure any Nikon software is uninstalled. Reboot

    3) Next see [post=875300]How to Cleanup and Remove old USB Storage Drivers[/post]

    4) Then Open Device Manager first. Connect USB with camera turned off. Turn camera on
    > Do you hear USB ding-dong? (you should still hear it)
    > Do you see Device Manager display refresh?
    > Does a new device appear in Dev Mgr (maybe the camera or a new device that may appear as a new removable disk drive?)

    /* EDIT */
    Or new device may also be a non-removable new disk drive too (i'm expecting the camera disk to mount using Microsoft generic USB storage drivers. i would think should occur even with no Nikon software)
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Sorry for double post to make sure you see this..

    To clarify: Good to have both Device Manager and My Computer windows open when you connect the camera. Things to look for when the camera is connected via USB and turned on

    Device Manager
    > should add a new USB Mass Storage Device under USB and
    > if all good, you'll also see a new disk appear under Disk drives

    My Computer
    > is where to look for a new removable disk or a new disk drive to also appear
  8. mike1959

    mike1959 TS Evangelist Posts: 1,031   +54

    Ok. Next I would download the transfer software from Nikon's site.
    A search found this;
    You may know about this already? It supports all windows version, 32 & 64 bit. The file is 50.55MB. It's worth keeping saved, even if it doesn't work right now.

    I use two Fuji cameras with a Sandisk card reader, over time I have tried almost all image editing software, now do all my editing with Faststone software;
    This will handle Nikon NEF RAW as well as jpg.
  9. eek

    eek TS Rookie Topic Starter Posts: 18

    nothing showed up in my computer.

    under device manager, the same thing that happened before happened again...D60 shows up with an exclamation point. right clicking and clicking on properties reveals its a code 10.

    to clarify, i did the steps in your previous post (post #6) before doing what you said in post #7.
  10. eek

    eek TS Rookie Topic Starter Posts: 18

    i had nikon transfer from the software cd that the camera came with...originally it worked but as of the last few weeks, the camera isn't detected so its useless (for now). i d/l the one from your link and still have the same issue. thx tho.
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Thanks for that update as well. I was also hoping mike's download file might help <Rats!>

    In DevMgr,
    1. Rt click the D60, select Properties->Details tab. Copy/paste the Device ID that you see
    2. Also try rt click D60 and select Update Driver, follow the prompts to allow Windows to search the internet (is worth a shot to see if windows finds anything or not - don't recall if you might have tried this or not from info in other D60 thread)

    I'll have to also go back to re-read the old Nikon D60 thread sometime tomorrow
    Also under Device Manager watch under the USB category, do you see a USB Mass Storage entry appear/disappear as well as you plug/unplug the Nikon cam? Or nothing change in that category?
  12. eek

    eek TS Rookie Topic Starter Posts: 18

    you're welcome. thanks for helping me.


    i tried this before but it didn't find anything. it said all drivers were up to date. i tried it again just now just to see if it would find anything new/different but it says that the driver is up to date.

    unfortunately, nothing changes in this category.
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hmmmm... yes, is starting to come back to me now... including issues with libusb0.sys with the Nikon D60 (and from some other threads as i recall)

    First, a few notes and some personal opinions (other input / ideas / opinions welcome)
    1. fyi: libusb0.sys - libusb0.sys was developed as a public project. The file and its source code are all stored on (an archive of unlicensed, public software projects)
    > Your post #1 shows me Nikkon decided to use and integrate libusb0.sys into their software. That post also shows
    ==> Nikon included libusb0.sys v0.1.10.1 with their software and that version is not digitally signed

    2. When i look at the libusb-win32 project page on
    So we know the version distributed by Nikon is buggy and we can tell it's "unsigned"

    3. On the other hand, a newer and signed version v1.2.2.0 has been developed which fixes many bugs and is digitally signed. In theory that sounds great (just replace old version with new) but problem is Nikon software was never tested with new version so if any software interfaces changed or the new lib changes how any of the interfaces work, it could still be a problem with Nikon

    I think mabye comes down to these choices
    a) The Nikon has internal memory card, right? If you can live with buying a card reader and moving memory card back and forth between camera and computer is the "safest" but not most convenient option

    b) As you mention, i did also find info that "in theory" that Nikon should be able to be config'ed to look like a mounted USB Storage disk (which right now it's not) so you can manually drag - drop files) but not clear if can find how to do that

    c) We can try to upgrade libusb0.sys and HOPE with some luck everything will work correctly (tho is still some risk of it still not working or, worse yet, causing some other problem). Which is why if you want to pursue this option suggest you first
    > Create a disk image backup of your computer hard drive (EASUS ToDo backup is good freeware tool, if needed). Image backup creates an exact "snapshot" of disk you can later restore if need be
    > Would also recommend creating a System Restore point before upgrading the libusb0.sys file
    > Then we could look at the libusb0.sys updgrade documentation and hopefully it will be straight forward enough with instructions to let us try and accomplish it. Then see whether or not it helps/works!

    So first question, can you live with using a card reader and moving the memory card?
    Are you adventurous and want to try the libusb0.sys upgrade (but will need precautions and proceed at own risk type warning, etc....)

    /* EDIT */
    Curiosity question: Is mike's download file still installed? Could you see which version of libusb0.sys it uses? just curious...

    /* EDIT 2 */
    I forget if you mentioned this earlier, are you running 32 or 64 bit Vista? Click for how check
  14. eek

    eek TS Rookie Topic Starter Posts: 18

    yes, mike's download file is still installed.

    how would i be able to see which version of libusb0.sys it uses?
    i'm running 32 vista.
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Open DevMgr, rt click D60, select Properties->Driver->Driver details, select the libusb0.sys file to see info... (look at your pic in post #1. It shows us the original libusb0.sys info) ;)
  16. eek

    eek TS Rookie Topic Starter Posts: 18

    its version
  17. mike1959

    mike1959 TS Evangelist Posts: 1,031   +54

    In an earlier post I put Windows 32 bit & 64 bit are both supported by Nikon. On reading it again it's 32 bit only. (Don't think that applies with this problem though).
    The page is;
    They quote that Vista includes the correct software to allow connection of Nikon D60 with nothing extra installed.
    In the spec sheet of the D60, it says 'Hi speed USB, data transfer protocol MTP, PTP'
    Is it possible a setting in the camera can be changed between several options that affects the USB mode? (Guessing here, not having a camera like this.)
  18. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184


    1) USB transfer protocols
    Thanks mike for that add'l info from nikon. It pointed me towards learning something new (including that the Nikon documentation is at least inconsistent) plus Nikon varies their USB transfer protocol support by camera device
    > This Nikon link is old but Table 1 would seem that the D60 only supports MTP/PTP vs. MSC support - which is the USB Mass Storage Controller device which is needed for the camera to appear as a remote disk
    > But as eek points out (and i saw online posts also) there are some online who claim to find the USB Mass Storage option in their menu (many others who don't)
    > MTP/PTP should also be supported by default on Vista

    2) Most interesting of all yet!
    I googled for any more info about libusb0 related issues and Device Manager problems when I pulled up THIS very interesting MS KB that MS just posted this month!
    > While the MS KB is about Zune player, i see much in that article that i believe also applies to the Nikon D60
    ==> including Checking Event Log, trying to uninstall libusb, checking for corrupt driver filters

    @eek: Go ahead and try running the MS Automated fixit that they offer. Post the result. If still problem, don't do any manual steps yet. I'll post back with adapted instructions for your situation

    /* EDIT */
    btw.. What Vista service pack is installed?
  19. eek

    eek TS Rookie Topic Starter Posts: 18

    i still have the same issue. basically when i ran the fix it said that there was a problem with the driver. it searched for a new (probably the current driver i had) driver, uninstalled what i had and installed the new driver...but the same issue occured.

    even tho the problem was diagnosed by the fix and supposedly solved, a window popped up in the lower right of my screen that said that the driver didn't install correctly.

    i looked at device manager and its the same issue as before. code 10.
  20. eek

    eek TS Rookie Topic Starter Posts: 18

    when i tried to find out what service pack i had, i wasn't able to. nothing showed up indicating that i even had a service pack when i did start>run>winver.

    so i went to control panel>programs>programs and features>installed updates and looked and saw that the latest i have is windows service pack 2.

    well, it says Microsoft Office 2007 Service Pack 2 (SP2) which was installed on 1/12/2011.

    do i need to d/l another service pack or does that one count? i'm not very tech savvy...
  21. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Microsoft Office has its own service pack vs. service packs for the Windows OS (in your case Vista)

    Look HERE. Do you have any Vista service pack installed?

    If we need you to install a Vista service pack, i'd advise you first back everything up. Service Pack upgrades usually run without problems but certainly not always

    At minimum, backup your files and folders/personal data. I think preferred you image your drive (which provides for worst case scenario). Image backups allow you access to recover either the entire drive image if need be or just select files/folders so you get best of both worlds

    /* EDIT */
    also, if it ever came down to it, do you have your Vista install CDs/DVDs if you ever needed to reinstall?
  22. eek

    eek TS Rookie Topic Starter Posts: 18

    nothing indicates that i have ANY service pack installed when i do that method.

    no, i don't have a vista install cd...and i need to go to the store in order to back up my comp because i'm out of dvd's and don't have enough blank cd's to do it.

    i'll try to do that tomorrow. thanks for your help, guys.
  23. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    oh. no. not CDs. Would take forever.

    1) a single DVD holds about 4.5 CDs worth of data but aside from that

    2) you really want to get a good large (e.g. 1TB) external USB disk drive to hold large backups. you can still burn personal data to DVD to be safe.

    i'd recommend an external USB drive that also has its own AC adapter. Personally, i like Buffalo products but they;re are many good ext USB drives to choose from
  24. eek

    eek TS Rookie Topic Starter Posts: 18

    thanks; i will search for one in the store.
  25. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1) Did you tell us your computer make and exact model? i forget... didn't notice...
    2) Many of the vendors proviided a "Vista recovery" partition on the disk drive. If you look under Start->Programs is there a Recovery program? (or some similar name - as the vendor Recovery utility also often allowed you to build/burn your own set of installatiion DVDs
    3) Is probably good to still get some DVDs to have plus an external USB disk drive (which comes with its own AC adapter) (NOT one that only has USB cable only)
    ==> IMO USB drives with "USB cable only" are helpful but they must depend on the USB port for their power. This often becomes its own problem. So they are best for "portable" drives to carry/move stuff around on. But when you need a ext USB disk to keep on your desk and will trust to save your backups, you want one that has its own AC adapter so it doesn' have to rely on the computer USB to get all it's power.

    chat later..

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...