Drivers WAN Miniport (PPPOE) problem- Error 678

Not open for further replies.


Posts: 16   +0
Hey Guys!
My OS is WinXP SP2.
I did a virus, malware, adware scan with different tools like Avast! Home Edition, AVG Anti Spyware, CCleaner, Spybot Search, Ad-Aware PE etc. After that my Internet connection was working.

But i had a Firewall, WebRoot Desktop Firewall , which i removed manually.
Afterwards, i'm unable to connect to the Net.
Its says @Connecting to WAN Miniport (PPPOE)@ and gives a Error 678, unable to contact the remote host.

I logged into another OS on another drives which is also WIN XP SP2. There was no problem there. When i did @show all@ for network adapters it shows WAN Miniport Adapter. But the problematic OS doesn't show this.

So i think i've some problem with this WAN Miniport (PPPOE) adapter, which i dont know much abt it?? Please somebody help on how to restore the Net connection!!


Posts: 580   +3
Microsoft say -

1. A network cable is disconnected.

2. The modem has been disabled.

3. The modem drivers are corrupted.

4. Spyware is running on the computer and is interfering with the connection.

5. Winsock has to be repaired.

6.Third-party firewall software is blocking the connection.

I`m liking 5 & 6 at this moment in time.See HERE


Posts: 16   +0
  • Thread Starter Thread Starter
  • #3
Hey PO' Girl!
Thaks for the info.. I did remove the third-party firewall "WebRoot Desktop firewall" by deleting its folder as i was unable to uninstall it. After that the problem started. I'm not able to ping the Default Gateway, it says "Request Timed out". But on another drive on another XP , its working fine. When i say "ipconfig" , i'm unable to see the WAN Miniport (PPPoE) adapter which i was able to see when the Internet connection was working fine.!!

I'll go thru ur article and let u know if it worked. Meanwhile just help me out ??


Posts: 16   +0
  • Thread Starter Thread Starter
  • #4
I tried! But still a prob!!

Hi 'Guys!
I did what was mentioned in the KB Article of Microsoft. I updated my network driver, ipconfig /renew etc everything but still the problem remains.
I'm unable to ping the "Gateway". I think the DELETED third-party-firewall or some VIRUS or SPYWARE is blocking the access.

If you know any solution, please provide!!
As i dont want to re-format my drive!!

Thanks in advance


Posts: 580   +3
As previously mentioned,causes 5 & 6 are the most likely.

- Winsock messed up by spyware

- Firewall messed up Winsock :)

Solutions :

- Repair the Winsock.See that Microsoft page (Step 6) and/or download Winsockfix

You may even have to reinstall the firewall,then uninstalll it properly.See Webroot uninstall info
and uninstall it properly.

If you find you cannot reinstall the firewall,you will have to delete everything webroot related,
then run a registry cleaner like RegscrubXP,and then hope.


Posts: 16   +0
  • Thread Starter Thread Starter
  • #6
how to know!!

Hey Po' Girl!
Thank u very much! But how do i know that anything related to Webroot still exists!! Is there any tool where i can know that!! Bcz i removed Webroot folder so that doesnt exist. But still what exists, how do i know?? Also i ran the WinSockFix , but that didnt help!!
Please help!!


Posts: 580   +3
If you have still have spyware the Winsockfix would not work.
If you still have some part of the firewall running,same thing

You could post an HJT log,that might indicate something.

Webroots online support mesage box is HERE
They should tell you what to search for.

Other than those 11 suggestions on the Microsoft page,
I can`t suggest anything else. :(
Not open for further replies.