WARNING! Got a Worm From Registry Mechanic!, Now I can't open Windows (98SE)

By macx
Oct 18, 2005
  1. Saw the ad for Registry Mechanic on the main page of another large computer forum (is that what's being
    advertised on this Forum also!?), thought it should be a good idea to have that as it was advertised on the forum and therefore obviously approved, and highly rated
    by PCWorld.

    Downloaded it, paid for it, installed it and ran it.

    Then computer restarted and it required my product
    code to start Windows.

    Typed in product code, but says it's invalid.

    I called MS Support, they first gave me 2 different
    product codes to try to unlock Windows, neither worked.
    Then transferred to a Tech who said I had gotten a worm with Registry Mechanic which was the reason I was unable
    to access Windows.

    They worked with me for over 2 hours, including going
    back to and installing a backup registry created the day
    before this Registry Mechanic was installed, but I am still
    being blocked from starting Windows.

    They are going to work with me more tomorrow.

    Further, the Tech said emphatically that such tools
    should not be used on the registry, that it would
    only lead to problems, even without such a worm.

    A MOST unhappy experience from what should have
    been a trustworthy source! :mad:
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Is it only the W98SE product-key that's stopping you from booting?
    Check your PM.
  3. macx

    macx TS Evangelist Topic Starter Posts: 718


    I'll give it a try when I get home from
    work @4:30 this AM/Thurs.

    I tried a few things today,
    like going into Safe Mode Command Prompt Only,
    at the prompt, cd\windows\command
    at the C prompt, scanreg / restore
    selected an earlier registry from before the problem
    it installed, but when restarted, had the same problem

    Then tried RESTORE, but then it came up with a msg
    about "invalid link call from VWIN32(01) +
    00000714 to device 0009, svc1" whatever that means,

    and also said that the Win config is invalid, and to run W Setup again to correct, didn't go there yet, not sure if
    it would basically wipe out all my settings or what

    Then I tried FIX, and it came up that there was no
    extended memory driver

    Then I went to the step by step thing in the
    startup menu, bypassed ("N") for a whole line
    of things containing something about "shoot"
    that just didn't look like they belonged there,
    then the computer found the extended memory drivers
    but upon restartup, back to the same old problem,
    can't get by the Prod Code window.

    Methinks there's a worm in there that keeps circling
    around and has anticipated all these attempts to
    repair the problem and blocks them.

    MS Tech didn't call back during the time frame I
    told them I'd be available (did earlier when I wasn't
    home) so still haven't been able to see what he's
    got to offer. Hope it's good!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...