Webserver responds to External address, but not LAN

By zellyman
Aug 3, 2005
  1. I have a WinXP PC that I use to create and send content to a laptop running mandrake linux 10.1. For almost 4 months everything worked fine, I had a Samba share setup and mapped to a drive that I used to transfer data to my webserver. However, today I try to browse the share via windows explorer, and it says that the drive could not be reconnected. I go to 'view network computers' and at first it shows my local machine that I am on, and not the Server, and when I refreshed it after rebooting the server, I get a 'You may not have permission to use this network resource' So i decide to connect to the laptop via ssh to take a look at my configuration files, using the address, my ssh client would not connect. however, I CAN connect using the servers external address, www.jeremysmitherman.com. and on that note, my webserver is still operating properly as long as I use www.jeremysmitehrman.com , and other computers outside of my network can access it as well. however, typing into my web browser only yields a timeout (And yes, I am sure the Internal address is right, ifconfig tells me that the address is indeed I can give you whatever conf files you need on request thanks.
  2. PanicX

    PanicX TechSpot Ambassador Posts: 669

    Does the internal IP respond to a ping request?

    Have you tried bringing the inteface down and back up?
  3. zellyman

    zellyman TS Rookie Topic Starter Posts: 33

    checklist mode, :eek:n
    Server can ping PC
    PC cannot ping Server if using internal address (works fine if I ping the port using external address)
    Interface has been restarted plenty, its not the problem. The server is fully functional. Just for some reason the PC dosent recognize the Server as being on the LAN.
    When attemptting to connect with an SSH client, Request will timeout if I use (which has worked until the problem started) HOwever, If I try to connect via an external address (uhoh.servecounterstrike.com) I connect with no problem
  4. zellyman

    zellyman TS Rookie Topic Starter Posts: 33

    Problem resolved, Its was a name resoulution error (of course), adding the internal IP address with a manually specified name into my hosts file solved the problem. Thanks for trying to help Panic :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...