Audio Weird audio pitch change on Realtek HD Audio

jazznorthwest

Posts: 9   +0
I have a new Medion Akoya P7360 (MD 8855) PC running Windows 7. I have been using Skype, and on one call my cousin couldn't stop laughing, he said I sounded like I'd been breathing in helium! I eventually pinned it down and discovered that it happens every time the PC goes into Sleep mode. After power-up, I can ring the Skype Call Testing Service (echo test) and it echoes back my message perfectly. If I put my PC into Sleep Mode (or allow it to do it automatically) then revive it, it raises the pitch of the microphone by about 5 semitones. I have tried a USB Phone, and this sounded OK. The only way I can resolve it at the moment is to re-boot the PC. I'm at a loss to think what the problem could be. I'm pretty sure I have the latest drivers. Anybody got any ideas?

Fred
 

jazznorthwest

Posts: 9   +0
  • Thread Starter Thread Starter
  • #3
No I haven't actually, but I can't see how a simple microphone can shift all the audio frequencies by 5 semitones. Equally, no matter how many times a day I've tried it over several days, it only does this after the PC has been in sleep mode. The same headset has been in use on a different PC and only exhibited this effect since I plugged it into the new one, a bit of a conincidence, but I'm willing to give it a go if you really think it could be that. Personally I can't see it.
 

jazznorthwest

Posts: 9   +0
  • Thread Starter Thread Starter
  • #5
Thanks, I did Windows 7 update and checked realtek audio driver and Windows searched on line and reported it was up to date. Another development tonight. I tried a test using Windows Live Messenger. I spoke to someone before and after sleep mode, and they reported an initial change but then settled to normal. Whilst talking to him, I recorded myself using audacity and then listened to playback. The pitch had changed. I saved the recording, emailed it to the person I was talking to so he could compare. He laughed when he heard it and said it sounded like Pinky & Perky, but the original audio via Messenger had been quite normal. So this fault has now shown up in Audacity, Cool Edit, and Skype, but not WLM!
 

jazznorthwest

Posts: 9   +0
  • Thread Starter Thread Starter
  • #13
These are the listed drivers for this device, which do you suggest I remove?

C:\Program Files\Realtek\audio\HDA\AERTSrv.exe
C:\Program Fles\Realtek\Audio\HDA\RtDVBg.exe
C:\Program Files\Realtek\Audio\HDA\RtHDVCpl.exe
C:\Program Files\Realtek\Audio\HDA\RtkAudio Service.exe
C:\Program Files\Realtek\Audio\HDA\RtlUpd.exe
C:\Program Files\Realtek\Audio\HDA\SkyTel.exe
C:\Program Files\Realtek\Audio\HDA\vncutil.exe
C:\Windows\system32\AERTACap.dll
C:\Windows\system321AERTARen.dll
C:\Windows\system321drivers\drmk.sys
C:\Windows\system321drivers\portcls.sys
C:\Windows\system321drivers\RTKVHDA.sys
C:\Windows\system32\FMAPO.dll
C:\Windows\system32\MaxxAudioAPO.dll
C:\Windows\system32\MaxxAudioAP020.d1
C:\Windows\system32\MaxxAudioEQ.dll
C:\Windows\system32\RP3DAA32.dl1
C:\Windows\system32\RP3DHT32.d11
C:\Windows\system32\RTCOM\RTCOMDLL.dll
C:\Windows\system32\RTCOM\RtkCfg.dll
C:\Windows\system32\RTCOM\RTLCPAPI.dll
C:\Windows\system32\RTEED32A.dll
C:\Windows\system32\RTEEG32A.dll
C:\Windows\system32\RTEEL32A.dll
C:\Windows\system32\RTEEP32A.dll
C:\Windows\system32\RtkAPO.dll
C:\Windows\system32\RtkApoApi.dll
C:\Windows\system32\RtkColnst.dll
C:\Windows\system32\RtkPgExt.dll
C:\Windows\system32\RTSnd Mgr.cpl
C:\Windows\system32\SRSHP360.d11
C:\Windows\system32\SRSTSHD.dll
C:\Windows\system32\SRSTSXT.dll
C:\Windows\system32\SRSWOW.dll
C:\Windows\system32\SysFxUl.dll
C:\Windows\system32\WavesLib.dll
C:\Windows\system32\WMALFXGFXDSP.dll
 
I have never liked the software that installs with the realtek drivers. When ever I format my computer, I install the realtek drivers and use the run command msconfig and turn off all of the realtek software leaving the computer with only the basic drivers. Have found ventrilo to sound cleaner that way. Sorry don't know if that will help you or not. I wish I knew where to find realtek stand alone manual install drivers, WDM or whatever you like to call them.
Good luck :)
 

jazznorthwest

Posts: 9   +0
  • Thread Starter Thread Starter
  • #16
OK I uninstalled Raltek HD Audio and the drivers re-installed themselves after re-start. The problem was still there after I put PC into Sleep mode. Today a friend visited and he had a USB 2.0 audio adapter http://cpc.farnell.com/jsp/displayProduct.jsp?sku=AV17601&CMP=aballnobrochure
We tried that and it was OK after Sleep mode. Unplugging the adapter and plugging the headset into the PC mic socket, the fault returned.
 

Giwrgos

Posts: 39   +0
realtek has a program that is used to make some changes in sound EQ and has a "Funny game" i as i call it to change the sound pitch.Maybe you touched it a little bit without knowing..or someone else did.I don't know the real cause but if this was getting on my nerves i would download the simplest pitch changer i could find on the internet..put it on start up and do this until you find a solution.
 

jazznorthwest

Posts: 9   +0
  • Thread Starter Thread Starter
  • #18
That really doesn't fit in with the problem, It's fine when I start Windows and stays fine all day unless I put it into Sleep Mode, or it goes to Sleep automatically after a set timeout. Once awoken the fault returns. I can't believe I'm accidentally touching something each time. In fact the only thing I touch is the mouse to wake it up. I could change the pitch manually, but it's just as easy to restart Windows. Thanks anyway
 

techsuitor

Posts: 131   +0
hmm.. your problem regarding this is unusual .. We better search for more thoughts to come up to a better or possibly the best one.

good luck my friend :)