Western Digital Passport not recognized

By nukedukem ยท 7 replies
Jun 1, 2011
Post New Reply
  1. So I have a 6 month old WD passport 500gb external usb 2 hd. I have it partitioned into an ntfs and fat32 partitions

    I plugged the hd into an internet cafes computer and it didn't recognise. Since then no computers will recognise the hd. I have tried several recovery software including the wd own software. Also tried a different, shorter cable. The light starts up as normal and the hd doesn't make any unusual noises but after a second or 2 the light goes dim like there is no activity inside

    I also tried chkdisk from command and still nothing. If I could just get the hd to show up maybe I can use these recovery programs to recover data. Even if I lost the data and just got to use my hd again I would be happy.

    Any ideas from anyone would be HUGELY appreciated. I have spent hours on google trying to find a solution short of sending it away for repair ( which would cost more than its worth ). Also heard a trick of putting it in the freezer but I'm not sure about any of this!

    Thanks for reading
  2. nukedukem

    nukedukem TS Rookie Topic Starter

    Anyone had this happen before?
  3. Zen

    Zen TechSpot Paladin Posts: 861   +50

    The only thing that comes to mind, in regards to your external hard drive problem is this. Maybe this (internet cafe) thing had some sort of a blocking program installed on it's computers! Maybe it blocks users from coming in and breaking the bank when it comes to very large downloads or illegal downloads. I've heard of company's doing this, their I.T. guy's will install a program that doesn't allow anything larger then they specify, like certain sized data storage devices, on their computers. Maybe this cafe had such a program, kept your external hard drive from working, because it was to large of a data storage device.

    As far as why your experiencing problems, after the fact, I'm not all that certain. Maybe that blocking program at the cafe left something in your hard drive. Or maybe this is just by coincidence and something else is going on here!
  4. nukedukem

    nukedukem TS Rookie Topic Starter

    Ya the only thing I noticed was the usb port on the computer I was using was not lit up. It looked damaged, when I used a different machine their ports were lit up. Im thinking something like power surge? Looks like Il be buying a new HD then... maybe not WD this time?
  5. kristain

    kristain TS Rookie Posts: 47


    How many drives do you have? I've noticed that sometimes a USB drive won't show up if there are other drives taking up all the letters D: through F:. Can you disconnect other drives to see if it will appear?

    Also, have you tried rebooting the computer? Sometimes that will do the trick.
  6. nukedukem

    nukedukem TS Rookie Topic Starter

    I have 2 partitions on my internal HD and 2 partitions on my external. Tried rebooting with it plugged in and plugged out. Tried plugging in while in different programs. They normally come up as I: and H:?
  7. WinXPert

    WinXPert TS Guru Posts: 445

    Run this app. Autorun Protector and clear your mount points. Then plug in your WD passport. Hope this helps
  8. nukedukem

    nukedukem TS Rookie Topic Starter

    Thanks for the suggestion but it didnt work.

    I keep getting the message at the bottom right 'USB Device not recognised. One of your usb devices has malfunctioned'

    Tried on different computers and operating systems...

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...