Western Digital WD600bb shows less than it should

By donjo13 ยท 16 replies
May 1, 2005
  1. My WD600bb HD (60GB supposedly) Only shows 33.8 GB total. I formatted, fdisked, used the WD utility, and it didnt change anything. What can I try? It works great other than that!
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Depending on which os you`re running will determin how much of the harddrive will be recognised.

    I.E Windows 98 only shows about 33gig while 2000 and xp with the correct service pack installed will show all of it.

    Regards Howard :grinthumb
  3. donjo13

    donjo13 TS Rookie Topic Starter Posts: 71

    I'm running win xp sp1
  4. ripken204

    ripken204 TS Rookie Posts: 139

    wow, u rly need to get sp2
  5. donjo13

    donjo13 TS Rookie Topic Starter Posts: 71

    Downloaded it (SP2)....Problem remains. ??????????????
  6. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Control Panel -> Administrative Tools -> Computer Management -> Disk Management.

    Look there, it will show you your partitioned space and unpartitioned space if there is any.
  7. donjo13

    donjo13 TS Rookie Topic Starter Posts: 71

    I looked there and says 33.8 GB total. Either the drive is messed up, or something is hidden that I can't see or get to. ??????
  8. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,742   +421

    Somethings not right then, as far as I know Disk Management shows you everything as far as the size of the disk. If its not in Disk Management its not there*.

    * I'm not 100% sure on this, there may be some crazy way you can hide things. But unless you bought the drive used, the chances of that are about 0.
  9. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Just a thought.

    On the back of the drive is there an extra jumper that limits the size of the drive?

    If so remove it.

    Regards Howard :grinthumb
  10. donjo13

    donjo13 TS Rookie Topic Starter Posts: 71

    After extrensive work with the WD data lifeguard, It showed 60GB...I formatted it through the program and tried to load win 2000 pro. It gace me errors galore. Then I loaded win xp pro. It partitioned the drive into 2 sections. One 33GB and the other approx 24(unusable)GB. So I assume the hard drive is screwed. It does work fine however as a 33.8Gb HD. I'll use it til it goes out.
  11. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Did you look for the jumper howard talked about? Some drives have what's called a "32gb clip" that limits the total space of the HDD. This is for backwards compatibility reasons for older machines.

    Research the markings on the drive, and also research the data on the drive manufacturer's web site to make sure the jumper is correct. As there can be many "master" jumper settings. As in, master-full-size, and master-32gbclip.
  12. donjo13

    donjo13 TS Rookie Topic Starter Posts: 71

    Thanks for the input, but yeah, I checked the jumpers. It doesnt have an extra one and I ran it the way it said in the data guard, then tried master,single, and no jumper at all. It still shows the same. Uncle! I'm just gonna use it as is til I can get another one. Again, thanks!

    PS I did buy the drive used.
  13. BillGates

    BillGates TS Rookie Posts: 88

    Well I had the same problem but my was more aggrevating
    I bought a 160GB harddrive New

    Partitioned it and at first it said 132(28giga ohh no) GB of space. Huh
    so I did it again and got 148(22 gigs come on) So I did it a third time and got the same results. It can probably be done in the boot process for windows but I m not sure and im not going to try until 6 months or more have gone buy for my

    Religous clean reinstall and upgrade time.

    I wish the manufactured distributed hard drives that gave you the advirtised space without the 128byte ti #100 crap manit is horrible.

    But I fill you on that lose of data I was mad though when I did get my space.

    To bad you didn't get a new one so you would now for sure about the drives full potential.
  14. patio

    patio TS Guru Posts: 482

    I suspect since it was a used drive that on your latest attempt what happened was XP didn't set up the 2 partitions, rather it picked up the existing ones...
    I would travel to bootdisk and grab a WinME boot disk and do the following.
    Boot from the WinME floppy; at the A: prompt type fdisk and hit enter.
    You will be given 4 choices; Create a logical partition; create an extended partition; delete a logical partition; and view partition info.
    Choose view and make sure you are working on the correct drive. "Warning" from here on the choices you make are going to destroy the data you have on that drive/partitions.
    Making sure it is the WD drive you want to first delete any extended partitions ( given your info there will be 2 partitions on the WD drive. After deleting the extended partition you then want to delete the Primary partition.
    Re-boot to the floppy and let it pick up your drives again.
    Again MAKE SURE you are working on the correct drive.
    Choose Create primary logical partition...in the next window it will ask for a size choose 100 % and let it do its job.
    Finally it will ask for a volume label just hit enter for none. Then set the partition as active, and re-boot once more to the floppy.
    Format the WD again make sure you are working on the correct drive and you're done.

    Re-boot and XP will now see a full 60G. HDD.
    There is an excellent tutorial on using FDisk Here...

    Hope this helps...take your time and read all messages and you should be good to go. Approximate time: 1/2 hour to 40 mins.

    patio. ;)
  15. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    That's because you need for the 48-bit LBA to be enabled for drives larger then 137GB, it is disabled by default on windows 2000 & XP.

    & btw 160 - 148 = 12, not 22. :p
  16. donjo13

    donjo13 TS Rookie Topic Starter Posts: 71

    Did all the fdisk stuff . Been doing that since win98 came out! It only shows 33.8 GB max in fdisk in every instance tried. It's screwed.
  17. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    fdisk can't show more than 32gb.

    Your XP CD should show the full size though.

    Maybe use fdisk to just trash all the partitions, including any "non-dos" partitions. Then leave it at that. And have XP create them later.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...