What is the Coprocessor and what driver is needed?

By dubwise78 ยท 10 replies
Oct 28, 2009
  1. I have just noticed in the device manager of my new PC, under 'other devices', something called 'coprocessor' is listed with following status: 'The drivers for this device are not installed. (Code 28) There is no driver selected for the device information set or element. To find a driver for this device, click Update Driver.'

    I have tried to update driver automatically- no luck. What is the coprocessor and does anyone know which driver I need or where to try and what to search for?

    My system:
    AMD Athlon 7750 Dual- Core processor (2.70 GHZ)
    4 gig RAM
    Windows 7 x64 Home Premium
    Nvidia Geforce 8200
    ASRock K10N78FullHD- hsli motherboard

    The PC originally came without OS and included an ASRock 'AMD- nVIDIA series support CD- Rom'- user manual, drivers, utilities. I have tried the disc, which does contain drivers when browsed but it wont auto install them. Any advice appreciated, cheers.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    You might have to update the bios on that ASrock motherboard, to be able to "see" the co-processor. Go to the ASrock support website under your motherboards model and download and install all the Windows 7 drivers for the motherboard. Hopefully they have Windows 7 drivers
  3. dubwise78

    dubwise78 TS Rookie Topic Starter

    OK thanks Tmagic. Does anyone know what this coprocessor actually is? Is it a generic term for an unknown device or is it half of my dual core processor?

    I understand that Nvidia Hybrid SLI technology could allow me to add a Nvidia graphics card on top of the integrated Geforce 8200 GPU for better graphics. Could I add any new Geforce card and would it plug and play or would it take some tinkering?
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Co- Processor

    You can add another video card depending on what type card your motherboard accepts
  5. Greeble1

    Greeble1 TS Rookie

    This seems to be a problem with the NVIDIA unified driver sets. I recently had a similar problem installing Windows 7 Ultimate x64 to a HP Pavilion dv9429 laptop. After pulling my hair out trying to find the solution, I finally came up with a fix. The Driver set that would be needed is 15.49 nForce drivers from the NVIDIA website.

    Hope this helps.


    P.S. The 'coprocessor' in this case is not a coprocessor but part of the chip-set.
  6. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    A coprocessor can frequently refer to a floating-point processing unit on the motherboard.
    I have never seen a driver being required for it.
  7. Greeble1

    Greeble1 TS Rookie

    jobeard you are indeed correct but, in this case, it was not a coprocessor but a flaw between the Win 7 sub-system and the lack of a specific Nvidia driver. The hardware ID pointed to part of the chipset. I am not sure why this did not show up in other OS's on the same computer (such as Vista and XP) but it seems to be a fairly common problem for Win 7, more specifically a Nvidia problem as opposed to MS or AMD.

    I spent a lot of time in research on this. My goal here is to save someone the frustration of correcting this problem.

  8. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    no argument from me :wave:
  9. dubwise78

    dubwise78 TS Rookie Topic Starter

    Thanx Greeble1, mines fixed now too. I downloaded a driver pack from Nvidia, which must have included the the one you found. Win 7 runnin sweet.
  10. Greeble1

    Greeble1 TS Rookie

    No problem, dubwise78, This issue is that only certain Nvidia unified driver sets have this driver. This is why most of us missed it. I thought finding drivers for the GeForce Go 6150 was tough :)

  11. Retrospect

    Retrospect TS Rookie


    I have lurked around these forums for a while now and I felt that I must register to say thankyou.

    @ Greeble1 I have an onboard Geforce 8200 and a 9800 GTX. I've never succeeded in disabling the 8200 and as a result i've had lots of problems, black screen when alt tabbing, black screen when going to task manager, what look like driver related crashes (pink screen, blue screen and one that looks like the screen has shattered) and of course the coprocessor problem. I downloaded the driver pack that you suggested and as yet I have had none of the above problems.

    So I thankyou for your time and advice :grinthumb
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...