Win2k fails to enable CD drives after mem stick failure

By MacGyverS2000
Dec 8, 2005
  1. Several days ago I tracked down flakey behavior in my web browser to a failing mem stick. Now that it has been removed (and MemTest86 reran to verify integrity), Win2k (w/SP4) fails to enable my two CD drives (a Sony CDU5221 CD-ROM and a Sony CRX140E CD-R/W)... it sees them in the Device Manager, but there's the nasty yellow exclamation mark next to them with a Code 31 (This device is not working properly because Windows cannot load the drivers required for this device).

    I tried a basic repair scenario by booting with Win2k floppies and selecting the 'R' option, but it still doesn't enable them (it did it's little repair routine, everything rebooted fine, no change in status).

    I'm sure the faulty memory killed off some needed files (probably during a defrag), but I need some advice/help on what methods to use to get my drives back.

    Many thanks!
  2. MacGyverS2000

    MacGyverS2000 TS Rookie Topic Starter

    Problem resolved!

    Not one to let time slip by, I decided to do a little more Google seaching on the issue. While I do not yet know WHY this works (no clue what this particular key is tied to), I can attest to the fact that it brought my drives back from the dead ;)

    1) Run regedit, and find the following key:
    2) Delete the "upperfilter" and "lowerfilter" entries
    3) Reboot and enjoy life again
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...