Win7 BSOD on startup

By Bah2 · 17 replies
Nov 8, 2011
Post New Reply
  1. Couple of nights ago I decided to install World of Tanks, since I've been
    hearing lot of hype about it recently, and I wanted to check out what all
    the fuss is about. While playing, Norton informed me that it's cpu usage
    was large (about 45%, and after a while the screen froze, went black, then
    filled with purplish and cyan lines, came back again and Norton informed me that video card was having problems. Before I could shut the game the screen went
    black again and wouldn't come back, so I had to reboot.

    Now, ever since that I haven't been able to start up windows without safemode.
    After booting it just gives me BSoD (dump attached). Safemode works just fine
    (I had similar problems about a month ago, but that time it was due to busted mobo, and even safemode froze after a few minutes of use).

    Repairing Windows doesn't work, neither does rolling back to a restore point from Nov 4th. Did a memtest, but it came up clean.

    As said, the most recent dump attached. Only one, I had few of them but I think they were deleted when I did the rollback.

    Attached Files:

  2. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Where did you get the download for the game?

    The minidump analasys shows wininit.exe to be the cause which is a Windows system critical file, but it could also be a virus.

    Do you have a Windows 7 disc?
  3. Bah2

    Bah2 TS Rookie Topic Starter

    downloaded straight from the site, so it should be clean.
    And I don't have the CD, my PC came with windows preinstalled.
  4. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Ok, I would like you to boot into normal mode in order to create the BSOD and produce more minidumps to analyse, I can then see if there is any consistancy in the crash dumps, before moving on. Do four more and attach them to your next post.

    One test you could also try is to boot into safe mode, open up device manager, locate the graphics card and uninstall it by right clicking on the device and select uninstall. Then try to boot into normal mode and see what happens.
  5. Bah2

    Bah2 TS Rookie Topic Starter

    OK, I uninstalled the graphics card (well, actually I think I just disabled it, I'm running a Finnish version, and it's sometimes hard to tell how familiar English terms are translated), and everything seems to be fine. So a simple driver update/re-installation should be enough? Or a new card at the most?

    Btw, I did get those dumps you requested, but I don't know if they're any good, since
    three of them were created after I disabled/uninstalled my DVB card by mistake (once again terms and translations). I'll attach them anyway, just in case it helps.

    110811-26005-01 dump is the only one I had before I read you second reply, so nothing had been disabled before that.

    Attached Files:

  6. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    The dumps suggest a few things including a bad driver but do not name it.

    Having got stability back by uninstalling the graphics driver then the problem should be almost solved. Download and install the latest driver for the card and see how it goes.
  7. Bah2

    Bah2 TS Rookie Topic Starter

    I'm having trouble installing the drivers.
    Truth be told, I haven't done it in a few years, so I'm not totally sure
    how it goes, but this is what I have done:

    1) download the drivers (released 04 oct 2011)
    2) uninstall the card (I had it disabled before)
    3) click on the downloaded exe
    4) reboot when asked to

    Now every time I boot up after uninstalling the adapter, windows insist on installing
    it's own drivers, which are dated back to 2009. And if I go with those, I get BSoD (file attached, I rebooted only once with those drivers, so there's only one).

    If I try to update the drivers from the internet or the directory the downloaded exe creates, I only get a message informing me that the drivers are up to date.

    Attached Files:

  8. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    First make quite certain that you are downloading the correct driver for your card and that it is the 64bit version.

    Check in Programs & Features and uninstall any entries that relate to the graphics card.

    Then follow this guide. This will check for any hidden drivers to give you a clean slate to start from.

    •Download the latest graphics driver from the Nvidia site for your card and version of windows and save it to the desktop.
    •Go into Device Manager and locate the graphics card under Display Adapters, right click on it and select Uninstall.
    •Run through this routine and locate any/all graphics drivers and delete them. Do not reboot, just close all the boxes to get back to the desktop.
    •Double click on the driver that you saved to your desktop to install it.

    After the driver appears to have installed (do not reboot) go back into Device Manager and check the driver is there under the disaply adapters. Let me know what you find.

    Now reboot and see if windows still tries to install a driver for the graphics, if it does, is there an option to stop it and search manually for the driver? if so then try the install again from the driver you saved to the desktop.

    If there is still a problem go into Device Manager and again uninstall the graphics card, then right click on Display Adapters and select Scan for Hardware changes, now see if this will enable you to manually install the correct driver.
  9. Bah2

    Bah2 TS Rookie Topic Starter

    Ok, I downloaded the ATI catalyst suite, that should contain the drivers.
    I uninstalled the adapter, and installed catalyst.

    During installation windows started searching for a driver from Microsoft update.
    After the installation had been completed, I get a message from windows saying that
    the driver is installed (driver from ATI, dated back to 2009), and from catalyst that no AMD graphics driver is installed.

    The adapter shows with a yellow exclamation mark on device manager.

    I rebooted, and got a BSoD (dump attached).

    I went through the procedure once more, but this time I cancelled the search from MS update. The result is the same. Windows says that the driver is installed (only this time it's Microsoft Corporation WDDM 1.1), Catalyst says otherwise, and adapter has exclamation mark. I haven't booted yet, but I think another BSoD will follow, since WDDM 1.1 was the one windows insisted on installing before.

    And now I'm off to work, so it'll have to wait.

    Attached Files:

  10. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    A yellow exclamation mark in the Device Manager indicates that the driver is not installed, we seem to be going around in circles.

    I am starting to wonder if the card is faulty. Can you give me the full model number of the card and I'll do a bit of research into this problem as all the usual resolutions have now been tried.
  11. Bah2

    Bah2 TS Rookie Topic Starter

    The card is ATI Radeon HD 4650.
  12. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

  13. Bah2

    Bah2 TS Rookie Topic Starter

    Yep, that's the one.
    Didn't download the CrossFireX profiles thou, didn't think they mattered.
  14. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Just the main package should be all you need.

    Try the following instructions to stop Windows from installing it's own driver. First go into Control Panel and Programs & Features and uninstall anything that relates to the graphics card, then go to the Device Manager and uninstall the card again.

    • Click on Start > Control Panel > System.
    • Click on Advanced System Settings.
    • Select the Hardware tab and then Device Installation Settings.
    • Select "No, let me choose what to do" and then select "Never install driver from Windows Update".
    • Then click on Save Changes and close all the windows.

    If it asks you to reboot for the changes to take effect, do so.

    Now try to install the driver package again which you should still have saved on your desktop.
  15. Bah2

    Bah2 TS Rookie Topic Starter

    No, that doesn't help.
    Windows still installs automatically on boot (which is kinda strange, since I disabled the automatic installation) and apparently when installing catalyst, just like before.
  16. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    The function you have disabled only stops windows from downloading a driver from windows update. It is detecting on bootup that there is no driver installed and is therefore installing its own generic driver.

    I have suggested every method I know of to install the correct drivers so I can only guess that the card is faulty.

    I can only suggest you try the card in another PC and repeat the installation. If it behaves the same way I would be fairly confident that the card is faulty. You could also try another PCI slot in your own PC but that is a long shot.
  17. Bah2

    Bah2 TS Rookie Topic Starter

    Meh. I think I'll just buy a new one, it's not like they cost an arm and a leg.
    And anyways all my friends seem to have laptops nowadays, so trying it on
    a different machine is not a viable option.

    And if for some reason it's a motherboard failure, faulty PCI-e for example,
    I can get that one fixed for free, since it still has warranty left.

    Anyway, thanks a bunch for your help.
  18. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Your welcome.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...