Windows 7 Windows 7 SP1 updates not installing

Hodsocks

TS Guru
Having a problem with a Dell XPS 8300 and hoping someone here has the answer as I seem to have tried many potential fixes without success. Originally tried to install Office 2010 but it got about 80% of the way through and through up an error. 1935 I think. Further investigation showed that my windows updates seem to have stopped installing as well. I followed lots of advise on many websites but still had the problem. Eventually I restored the pc back to factory settings which included a format to remove any problem. Much to my surprise I am still having exactly the same issues, so far I have tried the following:-
carried out numerous Microsoft "Fix it" programs
ran sfc /scannow
turned off Mcafee
booted the pc in "clean" mode
carried out repair of Net framework
uninstalled and reloaded Net framework
reregistered update files
stopped and restarted BITS
ran the system update readiness tool
renamed the software distribution folder
Cleared the BITS queue of any current jobs
reset the contents of the catroot2 folder
checked for incorrect registry values

Probably several other fixes but can't remember them all.
At the moment the windows update wants to install the update to the windows update but after restarting the windows update it tells me it has failed. If I turn off the pc it tells me there are numerous updates to install but it goes through the list very quickly and when it check windows update after restarting they have all failed.
I am at my wits end as logically reloading windows should have sorted the issue, whatever it is. I have even ran diagnostics on memory and hard drive and both are fine.
Any help would be greatly appreciated.
 

Cobalt006

TS Evangelist
I had the same problem with a win 7 computer . I then tried just downloading about ten updates at a time. This worked. Takes a little longer but they installed. I think the problem is on Microsoft update site.
 

Dell_BabitaG

Official Dell Support
Hi Hodsocks,

Click on this link: http://dell.to/1b9146o for steps to resolve the error 1935 which you see when installing MSOffice 2010 on your computer.

Let us know if you need further assistance, we would be happy to help.

Thanks & regards,
Babita_G
#iworkforDell
 

Dell_BabitaG

Official Dell Support
Hi Hodsocks,

We hope the issue is resolved now. Please reply if you have further queries.

Thanks & regards,
Babita_G
#@iworkforDell
 

Hodsocks

TS Guru
I finally resolved the problem by reloading Win 7 from my original windows disc rather than using the recovery mode from Dell, this allowed me to download all of the updates and Office installed without an issue, obviously some problem with the software in Dells recovery system.

Thanks for you help guys