Windows Explorer Scroll Bar Hides Columns

By mkirk ยท 7 replies
Jan 13, 2016
Post New Reply
  1. This happened for many years until a few days ago:
    In Windows Explorer (in Windows 7), when I click on a folder on the left side of the screen, four columns are displayed on the right side of the screen: Name, Date modified, Size, Type; and the scroll bar is on the far right side of the screen. All is good.

    Now when I click on a folder on the left side of the screen, the same four columns are displayed on the right side of the screen, but the scroll bar on the right side of the screen has shifted far to the left so that only some of the characters of the Name field are displayed; the rest of the name and the other three columns are hidden. I can move the scroll bar to the far right side of the screen (where it used to be), but the next time I open Windows Explorer, the scroll bar has shifted to the left side of the screen again, covering up columns' displays, so I have to manually move the scroll bar to the far right side of the screen again.

    How do I get the scroll bar to stay on the far right side of the screen like it used to?
    And why did it change? Did I do something inadvertently?
  2. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    It is quite difficult to visualise what you are describing, so a couple of screen shots would probably help.

    From Win 7, windows explorer by default would recall layouts and changes made for future use next time, saved for each folder that is changed. To save space, only changed layouts are recorded. Possibly what you are seeing is a default layout that has never been changed.

    Another possibility is the folder you click on the left does not have enough content to require a scroll bar at all, in which case none should appear. I can only suggest you experiment with changing the layout by adding another column, changing the width of columns or the sort sequence of a column. If no changes 'stick' then I well remember in XP there used to be a setting somewhere where you could specifically say you wanted the display settings saved for every folder. I have no idea where it is now, if anywhere, in Win 7. Possibly if you updated to Win 7 from XP, there is rubbish hanging around in the registry.

    In control panel, there is a utility called 'folder options' with a lot of settings under the 'view' panel. Check those options. Again, so much depends in windows upon certain overall display settings such as 'have you got enough system memory' for some features, and even 'have you got a video driver that supports Windows glass, and transparency' and other speciality display types. It is all complicated beyond rhyme and reason.

    In the last extreme, there are several explorer replacements on the market, some free, and I personally like and use 'Free Commander' although I would admit it is not too easy to select what you prefer from a myriad of options. One thing I like about Free Commander, for instance, is I can force all subfolders of a folder to sort below files, yet still be in alphabetic or date sequence as desired.
  3. mkirk

    mkirk TS Rookie Topic Starter

    Here are two screen shots that show the problem. The scroll bar shifted over to the left all of a sudden, after many years of using Windows Explorer. Apparently something got changed, but I don't know what it is.

    Attached Files:

  4. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    OK, it is now clearer, thank you. And the 'Explorer right.pdf' is still completely wrong, because the right-hand scroll bar should be at the extreme right edge of the explorer window, whereas in your case it is well inside the window, and some other artefact like a scroll bar shows even further over, but still not in the right place to be a proper scroll bar. An explorer window scroll bar cannot be moved as you describe, so you must have some sort of overlay on top of explorer.

    Just to be certain where you got where you are, was Win 7 a new install or an upgrade? Do you have SP1 installed? Do you have any explorer add-ons installed? See

    I'm completely stumped. Your explorer window lacks a menu bar. Suggest you find the explorer window properties as I previously described, and set menu bar on. When your explorer shows a menu bar, select / tools / folder options and in the window that opens, select view tab, then click the 'restore defaults' button.
    Last edited: Jan 16, 2016
  5. mkirk

    mkirk TS Rookie Topic Starter

    Problem solved!
    The Windows Explorer vertical scroll bar shifts to the left when the Windows Explorer Preview Pane is enabled.

    I was creating a reply to you this morning, explaining that the artefact to the right of the vertical scroll bar was a preview pane (shown by the "Select a file to preview" message on the right side of the Explorer Wrong.pdf screen shot). I was creating some screen shots showing what the preview pane showed by moving the scroll bar left and right. But I didn't remember a Windows Explorer preview pane feature, so I Googled it and got my answer.

    I must have pressed ALT+P by mistake sometime, which turned on the preview pane. I pressed ALT+P this morning and the preview pane disappeared.

    So my problem was a user error. Sorry for creating my own problem and wasting your time. Thank you for helping me solve the problem. One result is that I learned about the Preview Pane feature. And now you know about it, too.
  6. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Well done. So when I said 'you must have some sort of overlay on top of explorer' I was right, it was a preview pane. Free Commander has it too, the hot key is F3 and you can have it integral to the window top/bottom/left/right or free-floating.
  7. mkirk

    mkirk TS Rookie Topic Starter

  8. mkirk

    mkirk TS Rookie Topic Starter

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...