Windows Keeps Installing Wrong Driver for SB Live! and won't let me choose which one

By Obi-Wan Jerkobi · 18 replies
Mar 30, 2008
  1. Guess I need help again...

    Okay, I did a fresh reinstall of windows, got the drivers for everything, and loaded them. But for some reason I could not find the (good) drivers for my SB Live. So I went to the creative website, did an auto update, got the driver package. When I go to load the driver/program package, it hangs at 95%, when it is changing the drivers for the thing. I waited a while, about an hour, and it was still frozen at 95%. So I turned it off.

    When I turned it back on, it acted like windows had the exact driver installed (SB Live (WDM)) But I notice that there was no welcome sound and there is no audio icon in the system tray. So I go into "Sound and Audio Devices Properties" and it says that my sound card is an "Emu10kx1".

    So I uninstalled all the software, and decided to use the windows drivers. When I reboot, it installs the card, but it doesn't show a window. It automatically chooses the the driver (Sound Blaster Live (WDM)) which I thought I uninstalled! And while it's installing the driver, once again, it hangs. So, once again, I reboot, it acts like the driver is installed ok, but the sound card is once agin: "Emu10kx1"

    So I decided until I get some feedback here, I'll use the integrated audio. The problem is I need the SB Live for some new S/PDIF speakers I'm going to get (Its actually a 5.1 home theater). Any help will be appreciated, I've searched 100 pages of google and nothing has helped. :(
  2. turbo1

    turbo1 TS Maniac Posts: 353

    have you treid going into BIOS & disabling the onboard sound?
    (before you plug in your SB live sound card)

    if you did,un-install the SB live sound driver,
    take off the sound card & plug it to another
    PCI slot.then re-install the SB live sound driver.
    if still hang's.try to install it in safe mode.
  3. Obi-Wan Jerkobi

    Obi-Wan Jerkobi TS Maniac Topic Starter Posts: 502

    Yes, I disabled the onboard sound.

    Yes, it worked in one of my other computers, same process.

    I haven't tried safe-mode, I'll get back to you on that.
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Go to Device Manager, go to your soundcard, choose to update drivers, choose to do it manually.
  5. Obi-Wan Jerkobi

    Obi-Wan Jerkobi TS Maniac Topic Starter Posts: 502

    I couldn't even get into safe mode! :( The computer hanged at "giveio" or something like that. I treid installing again. Froze, closed it, and now the thing is said to be a "Creative EMU10k1 Audio Processor (WDM)" Does anyone have the actual driver file? I think that the actual program and its driver cause the pc to hang. I give up, I'm getting an X-Fi! D:<
  6. PSComputerHelp

    PSComputerHelp TS Rookie

    Hi guy;
    send me an AIM message on : pscomputerhelp and I will give you the direct download for your sound card.
  7. turbo1

    turbo1 TS Maniac Posts: 353

    for you to identify your product model:
    (specific SB live model),VARSET=ws:,case=46261

    and for the comprehensive list of SB products & model number:

    then try to download/select your driver manually:

    some OEM products also use Emu10kx1 sound chip.
    (not sure if that exactly is yours).
    if not,your sound chip will not respond to the driver.(for Emu10kx1).

    a windows update may help too.(since windows fresh install)
  8. Obi-Wan Jerkobi

    Obi-Wan Jerkobi TS Maniac Topic Starter Posts: 502

    After trying some stuff with the SB Live! I gave up and tried another sound card. That didn't work either. Actually, none of the soundcards I tried worked. I even tried installing the Realtek HD Audio and it ends with an error. Now I don't have any sound, at all!

    P.S.: I've noticed that all the cards don't work when a driver that ends with (WDM) is installed. The only problem is it won't let me install any other drivers, all the driver install utilies hang or complain they cant find the sound card.
  9. turbo1

    turbo1 TS Maniac Posts: 353

    flash your BIOS,
    check your mainboard's manufacturer website
    & download the latest BIOS as well as flash utility

    follow the guide/procedure/steps carefully when flashing BIOS.
    (check your mainboard's manual)

    suggest use a UPS,just to be safe incase of power outage.
  10. ravisunny2

    ravisunny2 TS Ambassador Posts: 1,986   +12

    Did you check to see if the motherboard cd had an audio patch file ?
  11. Obi-Wan Jerkobi

    Obi-Wan Jerkobi TS Maniac Topic Starter Posts: 502

    It doesn't matter which sound card I install, I get no sound even though I install the correct drivers. (Yes, I pluged in my speakers, yes the volume is up, yes I used the latest drivers, no I did not see any audio patch files.)
  12. Edwin Phate

    Edwin Phate TS Rookie Posts: 140

    Well I kinda had a problem like this I remember no matter what i did it wouldnt work I was live chat tech support from hp for hours to no avail.....What I finally found out was that I had to use windows XP media center edition and not Xp Home. They didnt tell me that. I had a suspicion that was it because it was orginally a Media Center Os. So I reinstalled with MCE and installed drivers and waalaa sound.
  13. kpo6969

    kpo6969 TS Maniac Posts: 710

  14. pdyckman@comcas

    pdyckman@comcas TS Rookie Posts: 527

    You have tried a different PCI slot? Do you have the drivers disc that came with the sound card? You may also want to put in your Window's program installation card and proceed as if you are going to reformat. Don't select any "repair console "that first comes up. When you get to the portion of the installation that asks you about "partitioning" or "installing on a different partition" or whatever: you will get the "repair this program instead" option again. At that point run the repair just in case you have some corruption in your entire Window's sound section.
  15. Obi-Wan Jerkobi

    Obi-Wan Jerkobi TS Maniac Topic Starter Posts: 502

    Oh, btw, the sound works perfectly in Ubuntu, all the cards worked in ubuntu. I will try the repair this program thingy today. I am getting ready to do a backup so I can reinstall...again...and I noticed all the drivers with WDM at the end didn't work.
  16. Obi-Wan Jerkobi

    Obi-Wan Jerkobi TS Maniac Topic Starter Posts: 502

    I even reinstalled windows and that didn't help... :( How can it work in Ubuntu but not in windows?
  17. turbo1

    turbo1 TS Maniac Posts: 353

    I know this kind of situation sometimes hard & soooooo frustrating.

    try another windows update,

    do another clean install of your card. by that, go to Add/Remove Progams
    and remove all that Creative stuff.

    then go to Files or Folders... and do a search for Creative and delete it..
    power down and pull your card out.

    power up without the card in, so that Windows "sees that there is no card in".
    power down.

    load back your card.
    Power up.

    let Windows find it (found new hardware).
    then install the driver manually.

    select Custom and just put in SurroundMixer/AudioHQ/drivers.
    Uncheck everything else.

    then go to Creative's site,check & download any updates by date issued.
    then install updates in the order issued and reboot after each install.

    BTW: I assume onboard sound is already disabled in BIOS,
    If the driver installed alright (add-on sound card),
    go to device manager,Sound, video & game controller,
    if you can still see your onboard sound (after disabling in BIOS),
    right click & disable it.

    If you can now boot to safe mode,try the above if it didn’t
    work in normal windows.

    old drivers sometimes work,try old to new.

    and oh,any over-clocking sometimes conflict with add-on sound card
    driver installation.
  18. ravisunny2

    ravisunny2 TS Ambassador Posts: 1,986   +12

    Have another look at what the motherboard cd contains.
  19. Obi-Wan Jerkobi

    Obi-Wan Jerkobi TS Maniac Topic Starter Posts: 502

    Did a full reinstall, (I kind of messed it up, I didn't delete the partition before I reinstalled windows) Now it works fine! :) (I already had a backup anyway.)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...