Windows PE3.0 does not detect SSD — Driver Injection

By magbastard
Oct 31, 2016
Post New Reply
  1. I’m having an issue with getting Windows PE 3.0 to recognize hard drive. At least I think this is the problem. I’m attempting to boot a Dell Latitude E7470 Solid State Drive, Windows 7 64-bit machine from a WINPE3.0 USB thumb drive. Initially, before I dug into injecting drivers, I would plug in USB and boot from USB and the Windows PE grey splash screen would show and attempt to load system files and then it would fail and restart and load Windows partition normally.

    I try to boot from WINPE again and I press f8 quickly to access a command prompt, and run diskpart to see what drives are being detected. It turns out that WINPE3.0 is not detecting my solid state drive.

    I then search out the right drivers for this model and I find out that I need these two: Picture:

    I run 7zip to extract out these files/folders and then I run DISM to mount my boot.wim (from WinPE) and run the DISM command to inject the drivers into the unmounted .wim file.

    I try two different ways of injecting drivers:

    1) The first way is I use the DISM command to add in the drivers with the recurse switch option. I put all driver files above in one folder and run recurse. Picture:

    This inject works and takes a few minutes. I then unmount and commit and copy over my newly injected WINPE package and copy it over to my USB and attempt to boot and it gives me an error pointing to a .sys file. I tried deleting the .sys file but I realize that this won’t work because the .sys is unpackaged and has many dependencies tied to it.

    2) Next, I narrow my focus inject only relevant drivers. I inject each driver and point to an .inf file and no success. I then point to the folder containing the driver files and no success. This time I get the same problem with WINPE just failing to detect driver and restarting.

    What am I doing wrong here? Is this some problem with WinPE3.0 and SSDs because I tried this same WINPE3.0 environment on a different model Dell laptop (Win 7 64-bit) with a HDD and it works fine.

    I appreciate any guidance here. Is there anything I’m missing? Thank you.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...