Winnt.ext not completing its job properly

Feb 9, 2005
  1. I've got MS DOS 7.10 (standalone build from 1999, can't remember where I got it) on my Vaio on a 500MB partition which contains the i386/ folder from Windows 2000 Professional. On running winnt.exe, it copies the Win2K files to my 20GB empty FAT32 partition. It however doesn't set the partition active or rewrite my MBR to a state where I can boot to the next stage of the installer - my BeOS bootloader is still present when the software reboots the computer.

    I've tried with the target drive as a primary partition and a logical partition, tried having a 2GB FAT16 target partition to see would that help (not that it matters, as MSDOS7 supports FAT32 anyway), etc, etc

    This machine has no floppy drive and no CD drive and Windows RIS is not an option due to other data on the drive.

    Any suggestions as to why winnt.exe isn't working right?
  2. MYOB

    MYOB TS Rookie Topic Starter Posts: 492

    OK, I found that Windows Server 2003 RIS just destroys all FAT32 partitions, so my BeOS would be safe. RIS'ed it on - file copying worked. It wrote... an invalid MBR

    Is it possible that Windows in general doesn't support the combo of an Intel i830 chipset with an ancient BIOS and an 80GB Hitachi GST Travelstar hard disk?
  3. MYOB

    MYOB TS Rookie Topic Starter Posts: 492

    bouncing this in case anyone has any ideas...
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    W2K SP4 updated winnt.exe. It is dated 19/06/2003, size=81,829.
    Try that rather than the original from 1999.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...